diff options
author | Denys Dmytriyenko <denys@ti.com> | 2014-09-16 19:10:01 -0400 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2014-11-12 15:38:31 +0000 |
commit | 5c23ec681c162636d68b3665cf6aef3af38ab205 (patch) | |
tree | 9c0cb0d9be0ee47ba2430e8605ac71f7acdc1ffe /meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb | |
parent | 2abfdcfd1c2f8d450f482fbf6922c5d2371d0aef (diff) | |
download | poky-5c23ec681c162636d68b3665cf6aef3af38ab205.tar.gz |
u-boot: update to version 2014.07
u-boot doesn't really support building its tools for the target, as they are
built with HOSTCC compiler, which is also used to compile fixdep utility
that gets executed during the build. Since it might be beneficial to have a
target version of mkimage, let's hack it to build fixdep in a separate step.
(From OE-Core rev: a8692184d25cb7d8cb3b617e1dfb901fe1b0ca3d)
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb')
-rw-r--r-- | meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb | 35 |
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb new file mode 100644 index 0000000000..a626c9599a --- /dev/null +++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb | |||
@@ -0,0 +1,35 @@ | |||
1 | SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities" | ||
2 | LICENSE = "GPLv2+" | ||
3 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb" | ||
4 | SECTION = "bootloader" | ||
5 | DEPENDS = "mtd-utils" | ||
6 | |||
7 | # This revision corresponds to the tag "v2014.07" | ||
8 | # We use the revision in order to avoid having to fetch it from the | ||
9 | # repo during parse | ||
10 | SRCREV = "524123a70761110c5cf3ccc5f52f6d4da071b959" | ||
11 | |||
12 | PV = "v2014.07+git${SRCPV}" | ||
13 | |||
14 | SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git" | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | INSANE_SKIP_${PN} = "already-stripped" | ||
19 | |||
20 | inherit uboot-config | ||
21 | |||
22 | do_compile () { | ||
23 | oe_runmake ${UBOOT_MACHINE} | ||
24 | oe_runmake env | ||
25 | } | ||
26 | |||
27 | do_install () { | ||
28 | install -d ${D}${base_sbindir} | ||
29 | install -d ${D}${sysconfdir} | ||
30 | install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv | ||
31 | install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv | ||
32 | install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config | ||
33 | } | ||
34 | |||
35 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||