summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-09-19 17:48:38 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-22 12:19:42 +0100
commit14c6a82c847b242bdb66201e171bd7780ef88da0 (patch)
tree89426da67b80593906d04abf77c10e12267f3683 /meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
parent19174b07962b6ed8d266badbfa2774abdd9d61d6 (diff)
downloadpoky-14c6a82c847b242bdb66201e171bd7780ef88da0.tar.gz
u-boot, u-boot-fw-utils, u-boot-fw-utils-cross: Use uboot-config class
The U-Boot configuration has been consolidates into a single class to avoid code duplication. This is now done by uboot-config class, so we now use it. (From OE-Core rev: d0bc7a53b1e61283fb155b4dcb67bc2ab3b1d7f0) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb9
1 files changed, 1 insertions, 8 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
index e711951405..be543431b3 100644
--- a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
@@ -17,14 +17,7 @@ S = "${WORKDIR}/git"
17 17
18EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTSTRIP="true"' 18EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTSTRIP="true"'
19 19
20python () { 20inherit uboot-config
21 if not d.getVar("UBOOT_MACHINE", True):
22 PN = d.getVar("PN", True)
23 FILE = os.path.basename(d.getVar("FILE", True))
24 bb.debug(1, "To build %s, see %s for instructions on \
25 setting up your machine config" % (PN, FILE))
26 raise bb.parse.SkipPackage("UBOOT_MACHINE is not set in the %s machine configuration." % d.getVar("MACHINE", True))
27}
28 21
29do_compile () { 22do_compile () {
30 oe_runmake ${UBOOT_MACHINE} 23 oe_runmake ${UBOOT_MACHINE}