summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
new file mode 100644
index 0000000000..14b09761e1
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
@@ -0,0 +1,33 @@
1SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
4SECTION = "bootloader"
5DEPENDS = "mtd-utils"
6
7# This revision corresponds to the tag "v2013.07"
8# We use the revision in order to avoid having to fetch it from the
9# repo during parse
10SRCREV = "62c175fbb8a0f9a926c88294ea9f7e88eb898f6c"
11
12PV = "v2013.07+git${SRCPV}"
13
14SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
15
16S = "${WORKDIR}/git"
17
18EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTSTRIP="true"'
19
20inherit uboot-config
21
22do_compile () {
23 oe_runmake ${UBOOT_MACHINE}
24 oe_runmake env
25}
26
27do_install () {
28 install -d ${D}${base_sbindir}
29 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
30 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
31}
32
33PACKAGE_ARCH = "${MACHINE_ARCH}"