summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils_2012.04.01.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-04-25 16:28:07 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-26 10:05:18 +0100
commit967bd67c374cc3a80620843f059507a06c93a550 (patch)
tree765701ee5fc2f1d9d59a71c305be47eeb2414bb3 /meta/recipes-bsp/u-boot/u-boot-fw-utils_2012.04.01.bb
parentbaf99e60d6f50c8c8a5190393b3a51233e928542 (diff)
downloadpoky-967bd67c374cc3a80620843f059507a06c93a550.tar.gz
u-boot-fw-utils: update 2012.04 to 2012.04.01 release
(From OE-Core rev: e6a6f2fb4bae146fc3077f782090e91904e00a08) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils_2012.04.01.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2012.04.01.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2012.04.01.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2012.04.01.bb
new file mode 100644
index 0000000000..fe3422a2cb
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2012.04.01.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "U-boot bootloader fw_printenv/setenv utils"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
4SECTION = "bootloader"
5
6DEPENDS = "mtd-utils"
7
8# This is needs to be validated among supported BSP's before we can
9# make it default
10DEFAULT_PREFERENCE = "-1"
11
12# This revision corresponds to the tag "v2012.04.01"
13# We use the revision in order to avoid having to fetch it from the
14# repo during parse
15SRCREV = "415d386877df49eb051b85ef74fa59a16dc17c7d"
16
17PV = "v2012.04.01+git${SRCPV}"
18
19SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
20
21S = "${WORKDIR}/git"
22
23EXTRA_OEMAKE = 'HOSTCC="${CC}"'
24
25do_compile () {
26 oe_runmake env
27}
28
29do_install () {
30 install -d ${D}${base_sbindir}
31 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
32 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
33}