summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/libubootenv_0.3.1.bb
diff options
context:
space:
mode:
authorPierre-Jean Texier <pjtexier@koncepto.io>2020-09-12 15:37:08 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-22 23:34:40 +0100
commit86814b7354590ea4a5560eef169825a3d6c3a35d (patch)
tree27d97012656631765f3c577f19f2445bf0e76a2e /meta/recipes-bsp/u-boot/libubootenv_0.3.1.bb
parentfe87efd92011883cdf2e7fca40f8d1120de7f4ec (diff)
downloadpoky-86814b7354590ea4a5560eef169825a3d6c3a35d.tar.gz
libubootenv: upgrade 0.3 -> 0.3.1
This is a bugfix release which includes the following changes: 824551a Prepare 0.3.1 ca6aaa1 Fix file reading/writing when the environment is in EEPROM a031dea Fix regression in UBI volume support c91c150 Define SOVERSION to indicate API version (From OE-Core rev: 2e646f0aca9a0af7e308590117c220c940996d86) Signed-off-by: Pierre-Jean Texier <pjtexier@koncepto.io> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 447eb941ef43cd5af19aed650fb7da718cedda61) Signed-off-by: Steve Sakoman <steve@sakoman.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/libubootenv_0.3.1.bb')
-rw-r--r--meta/recipes-bsp/u-boot/libubootenv_0.3.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/libubootenv_0.3.1.bb b/meta/recipes-bsp/u-boot/libubootenv_0.3.1.bb
new file mode 100644
index 0000000000..613e3161fb
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/libubootenv_0.3.1.bb
@@ -0,0 +1,30 @@
1SUMMARY = "U-Boot libraries and tools to access environment"
2
3DESCRIPTION = "This package contains tools and libraries to read \
4and modify U-Boot environment. \
5It provides a hardware-independent replacement for fw_printenv/setenv utilities \
6provided by U-Boot"
7
8HOMEPAGE = "https://github.com/sbabic/libubootenv"
9LICENSE = "LGPL-2.1"
10LIC_FILES_CHKSUM = "file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c"
11SECTION = "libs"
12
13SRC_URI = "git://github.com/sbabic/libubootenv;protocol=https"
14SRCREV = "824551ac77bab1d0f7ae34d7a7c77b155240e754"
15
16S = "${WORKDIR}/git"
17
18inherit uboot-config cmake lib_package
19
20EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release"
21
22DEPENDS = "zlib"
23PROVIDES += "u-boot-fw-utils"
24RPROVIDES_${PN}-bin += "u-boot-fw-utils"
25
26PACKAGE_ARCH = "${MACHINE_ARCH}"
27
28RRECOMMENDS_${PN}-bin_append_class-target = " u-boot-default-env"
29
30BBCLASSEXTEND = "native"