diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-05-18 00:03:02 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-05-31 13:07:00 +0100 |
commit | 52295fa3deef3b0374b99829626d524cefae6001 (patch) | |
tree | 90a71c05f9efdb6d67685f27b33406ddcc4277df /meta/recipes-bsp/qemu-config/qemu-config.bb | |
parent | c3a7382c9aa56fdc06198788833a27e882d5030a (diff) | |
download | poky-52295fa3deef3b0374b99829626d524cefae6001.tar.gz |
Improve handling of 'all' architecture recipes and their interaction with sstate
The existing PACKAGE_ARCH = "all" mechanism of sharing packages is problematic
with sstate since there are a variety of variables which have target specific
values and the sstate package therefore correctly changes signature depending
on the MACHINE setting.
This patch creates a new "allarch" class which sets:
PACKAGE_ARCH = "all"
(as per the existing convention)
INHIBIT_DEFAULT_DEPS = "1"
(since its not target specific and therefore can't depend on the cross
compiler or target libc)
TARGET_ARCH = "all"
TARGET_OS = "linux"
TARGET_CC_ARCH = "none"
(since these variables shouldn't change between the different packages and
target compiler flags shouldn't be getting used)
PACKAGE_EXTRA_ARCHS = ""
(since we shouldn't be depending on any architecture specific package architectures)
Not all PACKAGE_ARCH = "all" recipes can use this class since some run configure
checks on the compiler. This means they have target specific components and therefore
the "all" classification is incorrect.
(From OE-Core rev: 26e5e5feb695864b11e47e24017e254c28f14494)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/qemu-config/qemu-config.bb')
-rw-r--r-- | meta/recipes-bsp/qemu-config/qemu-config.bb | 5 |
1 files changed, 2 insertions, 3 deletions
diff --git a/meta/recipes-bsp/qemu-config/qemu-config.bb b/meta/recipes-bsp/qemu-config/qemu-config.bb index f91875e74e..70a113e8dc 100644 --- a/meta/recipes-bsp/qemu-config/qemu-config.bb +++ b/meta/recipes-bsp/qemu-config/qemu-config.bb | |||
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYING.GPL;md5=751419260aa954499f7abaabaa | |||
5 | 5 | ||
6 | COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemumips|qemuppc)" | 6 | COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemumips|qemuppc)" |
7 | 7 | ||
8 | PR = "r20" | 8 | PR = "r21" |
9 | 9 | ||
10 | SRC_URI = "file://distcc.sh \ | 10 | SRC_URI = "file://distcc.sh \ |
11 | file://anjuta-remote-run \ | 11 | file://anjuta-remote-run \ |
@@ -33,9 +33,8 @@ do_install() { | |||
33 | } | 33 | } |
34 | 34 | ||
35 | RDEPENDS_${PN} = "distcc dbus-x11 task-core-nfs-server oprofileui-server rsync bash" | 35 | RDEPENDS_${PN} = "distcc dbus-x11 task-core-nfs-server oprofileui-server rsync bash" |
36 | PACKAGE_ARCH = "all" | ||
37 | 36 | ||
38 | inherit update-rc.d | 37 | inherit update-rc.d allarch |
39 | 38 | ||
40 | INITSCRIPT_NAME = "qemu-autostart" | 39 | INITSCRIPT_NAME = "qemu-autostart" |
41 | INITSCRIPT_PARAMS = "start 999 5 2 . stop 20 0 1 6 ." | 40 | INITSCRIPT_PARAMS = "start 999 5 2 . stop 20 0 1 6 ." |