diff options
author | Fan Xin <fan.xin@jp.fujitsu.com> | 2017-06-07 14:20:30 +0900 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2017-06-09 17:12:14 +0100 |
commit | 0558ba93f065fd4bfe317c9fb34a6f63fa3f1eb8 (patch) | |
tree | 752eedf9e42586f6ad1ccee7a38c60c2cd2b2d14 /meta/recipes-bsp/pciutils/pciutils_3.5.4.bb | |
parent | d4e974b0a69eafbe9e3ec221eaacc2808c271e74 (diff) | |
download | poky-0558ba93f065fd4bfe317c9fb34a6f63fa3f1eb8.tar.gz |
pciutils: Upgrade to 3.5.4
(From OE-Core rev: cf0679d7404a4b019282b947488fb078402e5931)
Signed-off-by: Fan Xin <fan.xin@jp.fujitsu.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/pciutils/pciutils_3.5.4.bb')
-rw-r--r-- | meta/recipes-bsp/pciutils/pciutils_3.5.4.bb | 60 |
1 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-bsp/pciutils/pciutils_3.5.4.bb b/meta/recipes-bsp/pciutils/pciutils_3.5.4.bb new file mode 100644 index 0000000000..d387fba61a --- /dev/null +++ b/meta/recipes-bsp/pciutils/pciutils_3.5.4.bb | |||
@@ -0,0 +1,60 @@ | |||
1 | SUMMARY = "PCI utilities" | ||
2 | DESCRIPTION = 'The PCI Utilities package contains a library for portable access \ | ||
3 | to PCI bus configuration space and several utilities based on this library.' | ||
4 | HOMEPAGE = "http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml" | ||
5 | SECTION = "console/utils" | ||
6 | |||
7 | LICENSE = "GPLv2+" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
9 | DEPENDS = "zlib kmod" | ||
10 | |||
11 | SRC_URI = "${KERNELORG_MIRROR}/software/utils/pciutils/pciutils-${PV}.tar.xz \ | ||
12 | file://configure.patch \ | ||
13 | file://guess-fix.patch \ | ||
14 | file://makefile.patch" | ||
15 | |||
16 | SRC_URI[md5sum] = "e82537cd2194111c45fa7e684b52252e" | ||
17 | SRC_URI[sha256sum] = "64293c6ab9318c40ef262b76d87bd9097531759752bac556e50979b1e63cfe66" | ||
18 | |||
19 | inherit multilib_header | ||
20 | |||
21 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'hwdb', '', d)}" | ||
22 | PACKAGECONFIG[hwdb] = "HWDB=yes,HWDB=no,udev" | ||
23 | |||
24 | PCI_CONF_FLAG = "ZLIB=yes DNS=yes SHARED=yes" | ||
25 | |||
26 | # see configure.patch | ||
27 | do_configure () { | ||
28 | ( | ||
29 | cd lib && \ | ||
30 | # PACKAGECONFIG_CONFARGS for this recipe could only possibly contain 'HWDB=yes/no', | ||
31 | # so we put it before ./configure | ||
32 | ${PCI_CONF_FLAG} ${PACKAGECONFIG_CONFARGS} ./configure ${PV} ${datadir} ${TARGET_OS} ${TARGET_ARCH} | ||
33 | ) | ||
34 | } | ||
35 | |||
36 | export PREFIX = "${prefix}" | ||
37 | export SBINDIR = "${sbindir}" | ||
38 | export SHAREDIR = "${datadir}" | ||
39 | export MANDIR = "${mandir}" | ||
40 | |||
41 | EXTRA_OEMAKE = "-e MAKEFLAGS= ${PCI_CONF_FLAG}" | ||
42 | |||
43 | # The configure script breaks if the HOST variable is set | ||
44 | HOST[unexport] = "1" | ||
45 | |||
46 | do_install () { | ||
47 | oe_runmake DESTDIR=${D} install install-lib | ||
48 | |||
49 | install -d ${D}${bindir} | ||
50 | ln -s ../sbin/lspci ${D}${bindir}/lspci | ||
51 | |||
52 | oe_multilib_header pci/config.h | ||
53 | } | ||
54 | |||
55 | PACKAGES =+ "${PN}-ids libpci" | ||
56 | FILES_${PN}-ids = "${datadir}/pci.ids*" | ||
57 | FILES_libpci = "${libdir}/libpci.so.*" | ||
58 | SUMMARY_${PN}-ids = "PCI utilities - device ID database" | ||
59 | DESCRIPTION_${PN}-ids = "Package providing the PCI device ID database for pciutils." | ||
60 | RDEPENDS_${PN} += "${PN}-ids" | ||