summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/libacpi/libacpi_0.2.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-bsp/libacpi/libacpi_0.2.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-bsp/libacpi/libacpi_0.2.bb')
-rw-r--r--meta/recipes-bsp/libacpi/libacpi_0.2.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-bsp/libacpi/libacpi_0.2.bb b/meta/recipes-bsp/libacpi/libacpi_0.2.bb
new file mode 100644
index 0000000000..bf302f3ce4
--- /dev/null
+++ b/meta/recipes-bsp/libacpi/libacpi_0.2.bb
@@ -0,0 +1,30 @@
1SUMMARY = "ACPI data gathering library"
2DESCRIPTION = "General purpose shared library for programs gathering ACPI data on Linux. \
3Thermal zones, battery infomration, fan information and AC states are implemented."
4SECTION = "base"
5HOMEPAGE = "http://www.ngolde.de/libacpi.html"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=fec17f82f16630adf2dfb7d2a46f21c5"
8PR = "r6"
9
10SRC_URI = "http://www.ngolde.de/download/libacpi-${PV}.tar.gz \
11 file://makefile-fix.patch \
12 file://libacpi_fix_for_x32.patch \
13 file://use_correct_strip_in_cross_environment.patch \
14 file://ldflags.patch "
15
16SRC_URI[md5sum] = "05b53dd7bead66dda35fec502b91066c"
17SRC_URI[sha256sum] = "13086e31d428b9c125954d48ac497b754bbbce2ef34ea29ecd903e82e25bad29"
18
19inherit lib_package
20
21COMPATIBLE_HOST = '(x86_64|i.86).*-(linux|freebsd.*)'
22
23CFLAGS += "-fPIC"
24EXTRA_OEMAKE += 'STRIP="echo"'
25
26TARGET_CC_ARCH += "${LDFLAGS}"
27
28do_install() {
29 oe_runmake install DESTDIR=${D} PREFIX=${exec_prefix}
30}