summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/hostap/hostap-conf_1.0.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:11 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:57 +0100
commitd62ee7eaf2ba025c3f64b2d4e10dc7cec4637612 (patch)
treef36fe3008f36ff75cbdd31b630f8f13f1f205ebb /meta/recipes-bsp/hostap/hostap-conf_1.0.bb
parentcaab7fc509bf27706ff3248689f6afd04225cfda (diff)
downloadpoky-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.gz
packages: Separate out most of the remaining packages into recipes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-bsp/hostap/hostap-conf_1.0.bb')
-rw-r--r--meta/recipes-bsp/hostap/hostap-conf_1.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-bsp/hostap/hostap-conf_1.0.bb b/meta/recipes-bsp/hostap/hostap-conf_1.0.bb
new file mode 100644
index 0000000000..ce069662c7
--- /dev/null
+++ b/meta/recipes-bsp/hostap/hostap-conf_1.0.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "PCMCIA-cs configuration files for wireless LAN cards based on Intersil's Prism2/2.5/3 chipset"
2SECTION = "kernel/modules"
3PRIORITY = "optional"
4LICENSE = "GPL"
5RDEPENDS = "update-modules"
6PACKAGE_ARCH = "all"
7PR = "r10"
8
9SRC_URI = "file://hostap_cs.modalias"
10
11do_compile() {
12}
13
14do_install() {
15 install -d ${D}${sysconfdir}/modutils
16
17 install -m 0644 ${WORKDIR}/hostap_cs.modalias ${D}${sysconfdir}/modutils/hostap_cs.conf
18}
19
20pkg_postinst () {
21 if [ -n "$D" ]; then
22 exit 1
23 fi
24 update-modules || true
25}
26
27pkg_postrm () {
28 update-modules || true
29}