summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub_2.02.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-01-17 03:25:58 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-19 12:37:14 +0000
commit4e9bb03238af48c70075037a77094a8c1bddf284 (patch)
tree10da8ca3b125bdce90889612cccef8e5f532fb20 /meta/recipes-bsp/grub/grub_2.02.bb
parent975591a8d6cbea068d52417df0dfdd20aa586175 (diff)
downloadpoky-4e9bb03238af48c70075037a77094a8c1bddf284.tar.gz
grub/grub-efi: fix conflict
While installing grub and grub-efi, there are conflict files in ${sysconfdir} ${datadir} ${bindir} ${sbindir}. - Since all of the conflicted files are tools which is common for grub and grub-efi, we split them (except grub-editenv) to grub-common in grub. - The package grub-common runtime depends grub-editenv - The package grub-editenv runtime provides grub-efi-editenv - Remove SYSROOT_DIRS_BLACKLIST - The recipe grub-efi does not generate the duplicated files and use runtime depends grub-common to instead Debian and Fedora do the similar thing. Debian use a common package grub-common for both of pc bios and efi, and use package grub-pc-bin for pc bios, grub-efi-amd64-bin for efi. Both of grub-pc-bin and grub-efi-amd64-bin requires grub-common. https://packages.debian.org/sid/grub-common https://packages.debian.org/jessie/grub-pc-bin https://packages.debian.org/jessie/grub-efi-amd64-bin Fedora use a common package grub2-tools for both of pc bios and efi, and use package grub2 for pc bios, grub2-efi-modules for efi. Both of grub2 and grub2-efi-modules requires grub2-tools. https://www.rpmfind.net/linux/RPM/fedora/devel/rawhide/x86_64/g/grub2-tools-2.02-0.34.fc24.x86_64.html https://www.rpmfind.net/linux/RPM/fedora/devel/rawhide/x86_64/g/grub2-2.02-0.34.fc24.x86_64.html https://www.rpmfind.net/linux/RPM/fedora/devel/rawhide/x86_64/g/grub2-efi-modules-2.02-0.34.fc24.x86_64.html [YOCTO #11639] (From OE-Core rev: 6fd0bc313c6035b7de5b7a62cbbcd1d6f546c7f9) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/grub/grub_2.02.bb')
-rw-r--r--meta/recipes-bsp/grub/grub_2.02.bb14
1 files changed, 13 insertions, 1 deletions
diff --git a/meta/recipes-bsp/grub/grub_2.02.bb b/meta/recipes-bsp/grub/grub_2.02.bb
index 3e61f6a16d..e0973759fb 100644
--- a/meta/recipes-bsp/grub/grub_2.02.bb
+++ b/meta/recipes-bsp/grub/grub_2.02.bb
@@ -1,6 +1,18 @@
1require grub2.inc 1require grub2.inc
2 2
3RDEPENDS_${PN} += "diffutils freetype" 3RDEPENDS_${PN}-common += "${PN}-editenv"
4RDEPENDS_${PN} += "diffutils freetype ${PN}-common"
5
6RPROVIDES_${PN}-editenv += "${PN}-efi-editenv"
7
8PACKAGES =+ "${PN}-editenv ${PN}-common"
9FILES_${PN}-editenv = "${bindir}/grub-editenv"
10FILES_${PN}-common = " \
11 ${bindir} \
12 ${sysconfdir} \
13 ${sbindir} \
14 ${datadir}/grub \
15"
4 16
5do_install_append () { 17do_install_append () {
6 install -d ${D}${sysconfdir}/grub.d 18 install -d ${D}${sysconfdir}/grub.d