diff options
author | Robert Yang <liezhi.yang@windriver.com> | 2015-01-03 18:38:19 -0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2015-01-16 23:08:19 +0000 |
commit | ac867c3d4d1991e2e4f83cca2bad0ee31716796e (patch) | |
tree | fbcd2a23598423e58061623e058d602d000c0a75 /meta/recipes-bsp/grub/grub_2.00.bb | |
parent | 175d162b19b65a329163b0510d915ffae71af4de (diff) | |
download | poky-ac867c3d4d1991e2e4f83cca2bad0ee31716796e.tar.gz |
grub 2.0: several fixes
* Make grub, grub-efi grub_git use a grub2.inc to reduce the duplicated code.
* Make grub and grub-efi use the same patches since they use the same
source. (grub_git is different).
* grub-efi:
- Use autotools to replace autotools-brokensep
- Remove the DEPENDS of freetype, it should be a RDEPENDS.
- Remove grub-2.00-ignore-gnulib-gets-stupidity.patch since it is a
duplication of remove-gets.patch.
- Make grub-efi.rpm contain files rather than make an empty package.
* grub_git:
- Fix a SSE build failure.
[YOCTO #6310]
(From OE-Core rev: cf4aaed28a34cc652352f0817316187b72babc76)
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/grub/grub_2.00.bb')
-rw-r--r-- | meta/recipes-bsp/grub/grub_2.00.bb | 32 |
1 files changed, 1 insertions, 31 deletions
diff --git a/meta/recipes-bsp/grub/grub_2.00.bb b/meta/recipes-bsp/grub/grub_2.00.bb index e2fcbb98f5..a11e960fe5 100644 --- a/meta/recipes-bsp/grub/grub_2.00.bb +++ b/meta/recipes-bsp/grub/grub_2.00.bb | |||
@@ -1,41 +1,11 @@ | |||
1 | SUMMARY = "GRUB2 is the next-generation GRand Unified Bootloader" | 1 | require grub2.inc |
2 | 2 | ||
3 | DESCRIPTION = "GRUB2 is the next generaion of a GPLed bootloader \ | ||
4 | intended to unify bootloading across x86 operating systems. In \ | ||
5 | addition to loading the Linux kernel, it implements the Multiboot \ | ||
6 | standard, which allows for flexible loading of multiple boot images." | ||
7 | |||
8 | HOMEPAGE = "http://www.gnu.org/software/grub/" | ||
9 | SECTION = "bootloaders" | ||
10 | |||
11 | LICENSE = "GPLv3" | ||
12 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
13 | |||
14 | DEPENDS = "autogen-native flex-native bison-native xz" | ||
15 | RDEPENDS_${PN} = "diffutils freetype" | 3 | RDEPENDS_${PN} = "diffutils freetype" |
16 | PR = "r1" | 4 | PR = "r1" |
17 | 5 | ||
18 | SRC_URI = "ftp://ftp.gnu.org/gnu/grub/grub-${PV}.tar.gz \ | ||
19 | file://grub-install.in.patch \ | ||
20 | file://grub-2.00-fpmath-sse-387-fix.patch \ | ||
21 | file://remove-gets.patch \ | ||
22 | file://check-if-liblzma-is-disabled.patch \ | ||
23 | file://fix-issue-with-flex-2.5.37.patch \ | ||
24 | file://grub-2.00-add-oe-kernel.patch \ | ||
25 | file://fix-endianness-problem.patch \ | ||
26 | file://grub2-remove-sparc64-setup-from-x86-builds.patch \ | ||
27 | " | ||
28 | |||
29 | SRC_URI[md5sum] = "e927540b6eda8b024fb0391eeaa4091c" | ||
30 | SRC_URI[sha256sum] = "65b39a0558f8c802209c574f4d02ca263a804e8a564bc6caf1cd0fd3b3cc11e3" | ||
31 | |||
32 | COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)' | ||
33 | |||
34 | FILES_${PN}-dbg += "${libdir}/${BPN}/i386-pc/.debug" | 6 | FILES_${PN}-dbg += "${libdir}/${BPN}/i386-pc/.debug" |
35 | 7 | ||
36 | 8 | ||
37 | inherit autotools gettext texinfo | ||
38 | |||
39 | PACKAGECONFIG ??= "" | 9 | PACKAGECONFIG ??= "" |
40 | PACKAGECONFIG[grub-mount] = "--enable-grub-mount,--disable-grub-mount,fuse" | 10 | PACKAGECONFIG[grub-mount] = "--enable-grub-mount,--disable-grub-mount,fuse" |
41 | PACKAGECONFIG[device-mapper] = "--enable-device-mapper,--disable-device-mapper,lvm2" | 11 | PACKAGECONFIG[device-mapper] = "--enable-device-mapper,--disable-device-mapper,lvm2" |