diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-11-09 15:00:01 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-11-10 11:51:19 +0000 |
commit | c8dee9b92dfd545852ecac8dc2adfc95ac02e957 (patch) | |
tree | 5f1b86954646a0f3bb914407994388a6a4346769 /meta/recipes-bsp/grub/grub_1.99.bb | |
parent | 5d3860f4a8abb8e95442b04f8b84a333af362fcd (diff) | |
download | poky-c8dee9b92dfd545852ecac8dc2adfc95ac02e957.tar.gz |
Convert to use direct access to the data store (instead of bb.data.*Var*())
This is the result of running the following over the metadata:
sed \
-e 's:bb.data.\(setVar([^,()]*,[^,()]*\), *\([^ )]*\) *):\2.\1):g' \
-e 's:bb.data.\(setVarFlag([^,()]*,[^,()]*,[^,()]*\), *\([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(getVar([^,()]*\), *\([^(), ]*\) *,\([^)]*\)):\2.\1,\3):g' \
-e 's:bb.data.\(getVarFlag([^,()]*,[^,()]*\), *\([^(), ]*\) *,\([^)]*\)):\2.\1,\3):g' \
-e 's:bb.data.\(getVarFlag([^,()]*,[^,()]*\), *\([^() ]*\) *):\2.\1):g' \
-e 's:bb.data.\(getVar([^,()]*\), *\([^) ]*\) *):\2.\1):g' \
-i `grep -ril bb.data *`
(From OE-Core rev: b22831fd63164c4db9c0b72934d7d734a6585251)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/grub/grub_1.99.bb')
-rw-r--r-- | meta/recipes-bsp/grub/grub_1.99.bb | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-bsp/grub/grub_1.99.bb b/meta/recipes-bsp/grub/grub_1.99.bb index afd10f473f..b6aa827a5b 100644 --- a/meta/recipes-bsp/grub/grub_1.99.bb +++ b/meta/recipes-bsp/grub/grub_1.99.bb | |||
@@ -33,7 +33,7 @@ do_configure() { | |||
33 | 33 | ||
34 | python __anonymous () { | 34 | python __anonymous () { |
35 | import re | 35 | import re |
36 | host = bb.data.getVar('HOST_SYS', d, 1) | 36 | host = d.getVar('HOST_SYS', 1) |
37 | if not re.match('x86.64.*-linux', host) and not re.match('i.86.*-linux', host): | 37 | if not re.match('x86.64.*-linux', host) and not re.match('i.86.*-linux', host): |
38 | raise bb.parse.SkipPackage("incompatible with host %s" % host) | 38 | raise bb.parse.SkipPackage("incompatible with host %s" % host) |
39 | } | 39 | } |