summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub_1.99.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2012-04-14 01:59:06 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-14 13:26:01 +0100
commit53d629496f344d07e7ab261d789918cd80308b45 (patch)
treee73b3c864dee63c468ca5699692210eac5fd6a77 /meta/recipes-bsp/grub/grub_1.99.bb
parent7503db67134cf5007d080eed6771cf88bebbe9bd (diff)
downloadpoky-53d629496f344d07e7ab261d789918cd80308b45.tar.gz
grub-1.99: use gcc-cross for building the target binaries
It was using distro gcc to build binaries for target. This got detected on fedora 17 alpha, on which it hit an gcc-4.7 issue. This Fixes Bug: [Yocto #2291] More information in the patch header Thanks to Saul Wold for suggesting to remove the --target parameter from EXTRA_OECONF var. (From OE-Core rev: 26ae0e53411c1ea3afbb2e0c6d9dc2f1b0690751) Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/grub/grub_1.99.bb')
-rw-r--r--meta/recipes-bsp/grub/grub_1.99.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-bsp/grub/grub_1.99.bb b/meta/recipes-bsp/grub/grub_1.99.bb
index ac66e830bf..e61147f26e 100644
--- a/meta/recipes-bsp/grub/grub_1.99.bb
+++ b/meta/recipes-bsp/grub/grub_1.99.bb
@@ -12,10 +12,11 @@ LICENSE = "GPLv3"
12LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" 12LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
13 13
14RDEPENDS_${PN} = "diffutils freetype" 14RDEPENDS_${PN} = "diffutils freetype"
15PR = "r3" 15PR = "r5"
16 16
17SRC_URI = "ftp://ftp.gnu.org/gnu/grub/grub-${PV}.tar.gz \ 17SRC_URI = "ftp://ftp.gnu.org/gnu/grub/grub-${PV}.tar.gz \
18 file://grub-install.in.patch \ 18 file://grub-install.in.patch \
19 file://grub-1.99-fpmath-sse-387-fix.patch \
19 file://40_custom" 20 file://40_custom"
20 21
21SRC_URI[md5sum] = "ca9f2a2d571b57fc5c53212d1d22e2b5" 22SRC_URI[md5sum] = "ca9f2a2d571b57fc5c53212d1d22e2b5"
@@ -26,7 +27,7 @@ COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'
26inherit autotools 27inherit autotools
27inherit gettext 28inherit gettext
28 29
29EXTRA_OECONF = "--with-platform=pc --disable-grub-mkfont --target=${TARGET_ARCH} --program-prefix=""" 30EXTRA_OECONF = "--with-platform=pc --disable-grub-mkfont --program-prefix="""
30 31
31do_configure() { 32do_configure() {
32 oe_runconf 33 oe_runconf