summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub-efi_2.02.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-21 20:36:06 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-23 17:45:36 +0100
commit67d7ea7c675910f4da548639cdee31073cdf59fa (patch)
tree906556c4b75c4d25ccf78c245f522e771e5f55cb /meta/recipes-bsp/grub/grub-efi_2.02.bb
parentf0ff93c2a5c709cada5fc34b328204a79a5d642f (diff)
downloadpoky-67d7ea7c675910f4da548639cdee31073cdf59fa.tar.gz
grub: Update to 2.02
Drop git recipe, add arm bits to 2.02 itself (From OE-Core rev: 4f27e4042dfb39caa71c7c6eb0a327de6af4d563) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/grub/grub-efi_2.02.bb')
-rw-r--r--meta/recipes-bsp/grub/grub-efi_2.02.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub-efi_2.02.bb b/meta/recipes-bsp/grub/grub-efi_2.02.bb
new file mode 100644
index 0000000000..9d494d5d12
--- /dev/null
+++ b/meta/recipes-bsp/grub/grub-efi_2.02.bb
@@ -0,0 +1,69 @@
1require grub2.inc
2
3GRUBPLATFORM = "efi"
4
5DEPENDS_class-target = "grub-efi-native"
6RDEPENDS_${PN}_class-target = "diffutils freetype"
7
8SRC_URI += " \
9 file://cfg \
10 "
11
12S = "${WORKDIR}/grub-${PV}"
13
14# Determine the target arch for the grub modules
15python __anonymous () {
16 import re
17 target = d.getVar('TARGET_ARCH')
18 if target == "x86_64":
19 grubtarget = 'x86_64'
20 grubimage = "grub-efi-bootx64.efi"
21 elif re.match('i.86', target):
22 grubtarget = 'i386'
23 grubimage = "grub-efi-bootia32.efi"
24 else:
25 raise bb.parse.SkipPackage("grub-efi is incompatible with target %s" % target)
26 d.setVar("GRUB_TARGET", grubtarget)
27 d.setVar("GRUB_IMAGE", grubimage)
28}
29
30inherit deploy
31
32CACHED_CONFIGUREVARS += "ac_cv_path_HELP2MAN="
33EXTRA_OECONF += "--enable-efiemu=no"
34
35# ldm.c:114:7: error: trampoline generated for nested function 'hook' [-Werror=trampolines]
36# and many other places in the grub code when compiled with some native gcc compilers (specifically, gentoo)
37CFLAGS_append_class-native = " -Wno-error=trampolines"
38
39do_install_class-native() {
40 install -d ${D}${bindir}
41 install -m 755 grub-mkimage ${D}${bindir}
42}
43
44GRUB_BUILDIN ?= "boot linux ext2 fat serial part_msdos part_gpt normal efi_gop iso9660 search"
45
46do_deploy() {
47 # Search for the grub.cfg on the local boot media by using the
48 # built in cfg file provided via this recipe
49 grub-mkimage -c ../cfg -p /EFI/BOOT -d ./grub-core/ \
50 -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE} \
51 ${GRUB_BUILDIN}
52 install -m 644 ${B}/${GRUB_IMAGE} ${DEPLOYDIR}
53}
54
55do_deploy_class-native() {
56 :
57}
58
59addtask deploy after do_install before do_build
60
61FILES_${PN} += "${libdir}/grub/${GRUB_TARGET}-efi \
62 ${datadir}/grub \
63 "
64
65# 64-bit binaries are expected for the bootloader with an x32 userland
66INSANE_SKIP_${PN}_append_linux-gnux32 = " arch"
67INSANE_SKIP_${PN}-dbg_append_linux-gnux32 = " arch"
68
69BBCLASSEXTEND = "native"