diff options
author | Robert Yang <liezhi.yang@windriver.com> | 2015-01-03 18:38:19 -0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2015-01-16 23:08:19 +0000 |
commit | ac867c3d4d1991e2e4f83cca2bad0ee31716796e (patch) | |
tree | fbcd2a23598423e58061623e058d602d000c0a75 /meta/recipes-bsp/grub/grub-efi_2.00.bb | |
parent | 175d162b19b65a329163b0510d915ffae71af4de (diff) | |
download | poky-ac867c3d4d1991e2e4f83cca2bad0ee31716796e.tar.gz |
grub 2.0: several fixes
* Make grub, grub-efi grub_git use a grub2.inc to reduce the duplicated code.
* Make grub and grub-efi use the same patches since they use the same
source. (grub_git is different).
* grub-efi:
- Use autotools to replace autotools-brokensep
- Remove the DEPENDS of freetype, it should be a RDEPENDS.
- Remove grub-2.00-ignore-gnulib-gets-stupidity.patch since it is a
duplication of remove-gets.patch.
- Make grub-efi.rpm contain files rather than make an empty package.
* grub_git:
- Fix a SSE build failure.
[YOCTO #6310]
(From OE-Core rev: cf4aaed28a34cc652352f0817316187b72babc76)
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/grub/grub-efi_2.00.bb')
-rw-r--r-- | meta/recipes-bsp/grub/grub-efi_2.00.bb | 48 |
1 files changed, 11 insertions, 37 deletions
diff --git a/meta/recipes-bsp/grub/grub-efi_2.00.bb b/meta/recipes-bsp/grub/grub-efi_2.00.bb index d213f31a20..a337d3d4cb 100644 --- a/meta/recipes-bsp/grub/grub-efi_2.00.bb +++ b/meta/recipes-bsp/grub/grub-efi_2.00.bb | |||
@@ -1,39 +1,12 @@ | |||
1 | SUMMARY = "GRUB2 is the next-generation GRand Unified Bootloader" | 1 | require grub2.inc |
2 | 2 | ||
3 | DESCRIPTION = "GRUB2 is the next generaion of a GPLed bootloader \ | ||
4 | intended to unify bootloading across x86 operating systems. In \ | ||
5 | addition to loading the Linux kernel, it implements the Multiboot \ | ||
6 | standard, which allows for flexible loading of multiple boot images. \ | ||
7 | This recipe builds an EFI binary for the target. It does not install \ | ||
8 | or package anything, it only deploys a target-arch GRUB EFI image." | ||
9 | |||
10 | HOMEPAGE = "http://www.gnu.org/software/grub/" | ||
11 | SECTION = "bootloaders" | ||
12 | |||
13 | LICENSE = "GPLv3" | ||
14 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
15 | |||
16 | # FIXME: We should be able to optionally drop freetype as a dependency | ||
17 | DEPENDS = "autogen-native flex-native bison-native" | ||
18 | DEPENDS_class-target = "grub-efi-native" | 3 | DEPENDS_class-target = "grub-efi-native" |
4 | RDEPENDS_${PN}_class-target = "diffutils freetype" | ||
19 | PR = "r2" | 5 | PR = "r2" |
20 | 6 | ||
21 | SRC_URI = "ftp://ftp.gnu.org/gnu/grub/grub-${PV}.tar.gz \ | 7 | SRC_URI += " \ |
22 | file://cfg \ | 8 | file://cfg \ |
23 | file://grub-2.00-fpmath-sse-387-fix.patch \ | ||
24 | file://grub-2.00-fix-enable_execute_stack-check.patch \ | ||
25 | file://check-if-liblzma-is-disabled.patch \ | ||
26 | file://grub-no-unused-result.patch \ | ||
27 | file://grub-2.00-ignore-gnulib-gets-stupidity.patch \ | ||
28 | file://fix-issue-with-flex-2.5.37.patch \ | ||
29 | file://grub-efi-allow-a-compilation-without-mcmodel-large.patch \ | ||
30 | file://grub-2.00-add-oe-kernel.patch \ | ||
31 | file://grub-efi-fix-with-glibc-2.20.patch \ | ||
32 | " | 9 | " |
33 | SRC_URI[md5sum] = "e927540b6eda8b024fb0391eeaa4091c" | ||
34 | SRC_URI[sha256sum] = "65b39a0558f8c802209c574f4d02ca263a804e8a564bc6caf1cd0fd3b3cc11e3" | ||
35 | |||
36 | COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)' | ||
37 | 10 | ||
38 | S = "${WORKDIR}/grub-${PV}" | 11 | S = "${WORKDIR}/grub-${PV}" |
39 | 12 | ||
@@ -53,17 +26,13 @@ python __anonymous () { | |||
53 | d.setVar("GRUB_IMAGE", grubimage) | 26 | d.setVar("GRUB_IMAGE", grubimage) |
54 | } | 27 | } |
55 | 28 | ||
56 | inherit autotools-brokensep gettext texinfo deploy | 29 | inherit deploy |
57 | 30 | ||
58 | CACHED_CONFIGUREVARS += "ac_cv_path_HELP2MAN=" | 31 | CACHED_CONFIGUREVARS += "ac_cv_path_HELP2MAN=" |
59 | EXTRA_OECONF = "--with-platform=efi --disable-grub-mkfont \ | 32 | EXTRA_OECONF = "--with-platform=efi --disable-grub-mkfont \ |
60 | --enable-efiemu=no --program-prefix='' \ | 33 | --enable-efiemu=no --program-prefix='' \ |
61 | --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no" | 34 | --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no" |
62 | 35 | ||
63 | do_install_class-target() { | ||
64 | : | ||
65 | } | ||
66 | |||
67 | do_install_class-native() { | 36 | do_install_class-native() { |
68 | install -d ${D}${bindir} | 37 | install -d ${D}${bindir} |
69 | install -m 755 grub-mkimage ${D}${bindir} | 38 | install -m 755 grub-mkimage ${D}${bindir} |
@@ -86,7 +55,12 @@ do_deploy_class-native() { | |||
86 | 55 | ||
87 | addtask deploy after do_install before do_build | 56 | addtask deploy after do_install before do_build |
88 | 57 | ||
89 | FILES_${PN}-dbg += "${libdir}/${BPN}/${GRUB_TARGET}-efi/.debug" | 58 | FILES_${PN}-dbg += "${libdir}/grub/${GRUB_TARGET}-efi/.debug \ |
59 | /boot/efi/EFI/BOOT/${GRUB_TARGET}-efi/.debug \ | ||
60 | " | ||
61 | FILES_${PN} += "${libdir}/grub/${GRUB_TARGET}-efi \ | ||
62 | ${datadir}/grub \ | ||
63 | " | ||
90 | 64 | ||
91 | BBCLASSEXTEND = "native" | 65 | BBCLASSEXTEND = "native" |
92 | ALLOW_EMPTY_${PN} = "1" | 66 | |