summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub-efi_2.00.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-bsp/grub/grub-efi_2.00.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-bsp/grub/grub-efi_2.00.bb')
-rw-r--r--meta/recipes-bsp/grub/grub-efi_2.00.bb91
1 files changed, 91 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub-efi_2.00.bb b/meta/recipes-bsp/grub/grub-efi_2.00.bb
new file mode 100644
index 0000000000..6944cb280e
--- /dev/null
+++ b/meta/recipes-bsp/grub/grub-efi_2.00.bb
@@ -0,0 +1,91 @@
1SUMMARY = "GRUB2 is the next-generation GRand Unified Bootloader"
2
3DESCRIPTION = "GRUB2 is the next generaion of a GPLed bootloader \
4intended to unify bootloading across x86 operating systems. In \
5addition to loading the Linux kernel, it implements the Multiboot \
6standard, which allows for flexible loading of multiple boot images. \
7This recipe builds an EFI binary for the target. It does not install \
8or package anything, it only deploys a target-arch GRUB EFI image."
9
10HOMEPAGE = "http://www.gnu.org/software/grub/"
11SECTION = "bootloaders"
12
13LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
15
16# FIXME: We should be able to optionally drop freetype as a dependency
17DEPENDS = "autogen-native flex-native bison-native"
18DEPENDS_class-target = "grub-efi-native"
19PR = "r2"
20
21SRC_URI = "ftp://ftp.gnu.org/gnu/grub/grub-${PV}.tar.gz \
22 file://cfg \
23 file://grub-2.00-fpmath-sse-387-fix.patch \
24 file://grub-2.00-fix-enable_execute_stack-check.patch \
25 file://check-if-liblzma-is-disabled.patch \
26 file://grub-no-unused-result.patch \
27 file://grub-2.00-ignore-gnulib-gets-stupidity.patch \
28 file://fix-issue-with-flex-2.5.37.patch \
29 file://grub-efi-allow-a-compilation-without-mcmodel-large.patch \
30 file://grub-2.00-add-oe-kernel.patch \
31 "
32SRC_URI[md5sum] = "e927540b6eda8b024fb0391eeaa4091c"
33SRC_URI[sha256sum] = "65b39a0558f8c802209c574f4d02ca263a804e8a564bc6caf1cd0fd3b3cc11e3"
34
35COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'
36
37S = "${WORKDIR}/grub-${PV}"
38
39# Determine the target arch for the grub modules
40python __anonymous () {
41 import re
42 target = d.getVar('TARGET_ARCH', True)
43 if target == "x86_64":
44 grubtarget = 'x86_64'
45 grubimage = "bootx64.efi"
46 elif re.match('i.86', target):
47 grubtarget = 'i386'
48 grubimage = "bootia32.efi"
49 else:
50 raise bb.parse.SkipPackage("grub-efi is incompatible with target %s" % target)
51 d.setVar("GRUB_TARGET", grubtarget)
52 d.setVar("GRUB_IMAGE", grubimage)
53}
54
55inherit autotools-brokensep
56inherit gettext
57inherit deploy
58
59CACHED_CONFIGUREVARS += "ac_cv_path_HELP2MAN="
60EXTRA_OECONF = "--with-platform=efi --disable-grub-mkfont \
61 --enable-efiemu=no --program-prefix='' \
62 --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no"
63
64do_install_class-target() {
65 :
66}
67
68do_install_class-native() {
69 install -d ${D}${bindir}
70 install -m 755 grub-mkimage ${D}${bindir}
71}
72
73do_deploy() {
74 # Search for the grub.cfg on the local boot media by using the
75 # built in cfg file provided via this recipe
76 grub-mkimage -c ../cfg -p /EFI/BOOT -d ./grub-core/ \
77 -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE} \
78 boot linux ext2 fat serial part_msdos part_gpt normal efi_gop iso9660 search
79 install -m 644 ${B}/${GRUB_IMAGE} ${DEPLOYDIR}
80}
81
82do_deploy_class-native() {
83 :
84}
85
86addtask deploy after do_install before do_build
87
88FILES_${PN}-dbg += "${libdir}/${BPN}/${GRUB_TARGET}-efi/.debug"
89
90BBCLASSEXTEND = "native"
91ALLOW_EMPTY_${PN} = "1"