summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb')
-rw-r--r--meta/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb b/meta/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb
new file mode 100644
index 0000000000..dbf2a07a8a
--- /dev/null
+++ b/meta/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Libraries for producing EFI binaries"
2HOMEPAGE = "http://sourceforge.net/projects/gnu-efi/"
3SECTION = "devel"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://debian/copyright;md5=5fb358a180f484b285b0d99acdc29666"
6
7SRC_URI = "http://downloads.sourceforge.net/gnu-efi/gnu-efi_3.0u.orig.tar.gz \
8 file://parallel-make.patch \
9 file://parallel-make-archives.patch \
10 "
11SRC_URI[md5sum] = "d15d3c700e79a1e2938544d73edc572d"
12SRC_URI[sha256sum] = "3c0d450d5829204ca05dcb3b2aae772e52c379b7c7e09146759c6315606f934e"
13
14COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
15
16S = "${WORKDIR}/gnu-efi-3.0"
17
18def gnu_efi_arch(d):
19 import re
20 tarch = d.getVar("TARGET_ARCH", True)
21 if re.match("i[3456789]86", tarch):
22 return "ia32"
23 return tarch
24
25EXTRA_OEMAKE = "'ARCH=${@gnu_efi_arch(d)}' 'CC=${CC}' 'AS=${AS}' 'LD=${LD}' 'AR=${AR}' \
26 'RANLIB=${RANLIB}' 'OBJCOPY=${OBJCOPY}' 'PREFIX=${prefix}' 'LIBDIR=${libdir}' \
27 "
28
29do_install() {
30 oe_runmake install INSTALLROOT="${D}"
31}
32
33FILES_${PN} += "${libdir}/*.lds"