summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/formfactor/formfactor_0.0.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-bsp/formfactor/formfactor_0.0.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-bsp/formfactor/formfactor_0.0.bb')
-rw-r--r--meta/recipes-bsp/formfactor/formfactor_0.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-bsp/formfactor/formfactor_0.0.bb b/meta/recipes-bsp/formfactor/formfactor_0.0.bb
new file mode 100644
index 0000000000..29d14350a7
--- /dev/null
+++ b/meta/recipes-bsp/formfactor/formfactor_0.0.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Device formfactor information"
2SECTION = "base"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
5 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
6PR = "r44"
7
8SRC_URI = "file://config file://machconfig"
9S = "${WORKDIR}"
10
11PACKAGE_ARCH = "${MACHINE_ARCH}"
12INHIBIT_DEFAULT_DEPS = "1"
13
14do_install() {
15 # Only install file if it has a contents
16 install -d ${D}${sysconfdir}/formfactor/
17 install -m 0644 ${S}/config ${D}${sysconfdir}/formfactor/
18 if [ -s "${S}/machconfig" ]; then
19 install -m 0644 ${S}/machconfig ${D}${sysconfdir}/formfactor/
20 fi
21}