diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-09-01 19:09:11 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-09-01 19:09:57 +0100 |
commit | d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612 (patch) | |
tree | f36fe3008f36ff75cbdd31b630f8f13f1f205ebb /meta/recipes-bsp/apmd/apmd_3.2.2-14.bb | |
parent | caab7fc509bf27706ff3248689f6afd04225cfda (diff) | |
download | poky-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.gz |
packages: Separate out most of the remaining packages into recipes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-bsp/apmd/apmd_3.2.2-14.bb')
-rw-r--r-- | meta/recipes-bsp/apmd/apmd_3.2.2-14.bb | 63 |
1 files changed, 63 insertions, 0 deletions
diff --git a/meta/recipes-bsp/apmd/apmd_3.2.2-14.bb b/meta/recipes-bsp/apmd/apmd_3.2.2-14.bb new file mode 100644 index 0000000000..2778cc69e8 --- /dev/null +++ b/meta/recipes-bsp/apmd/apmd_3.2.2-14.bb | |||
@@ -0,0 +1,63 @@ | |||
1 | DESCRIPTION = "Set of tools for managing notebook power consumption." | ||
2 | SECTION = "base" | ||
3 | PRIORITY = "required" | ||
4 | LICENSE = "GPLv2+" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
6 | file://apm.h;firstline=6;endline=18;md5=c9a1f79036ab14aa157e15ed75ffd769" | ||
7 | DEPENDS = "libtool-cross" | ||
8 | PR = "r1" | ||
9 | |||
10 | SRC_URI = "${DEBIAN_MIRROR}/main/a/apmd/apmd_3.2.2.orig.tar.gz \ | ||
11 | ${DEBIAN_MIRROR}/main/a/apmd/apmd_${PV}.diff.gz \ | ||
12 | file://libtool.patch \ | ||
13 | file://unlinux.patch \ | ||
14 | file://init \ | ||
15 | file://default \ | ||
16 | file://apmd_proxy \ | ||
17 | file://apmd_proxy.conf" | ||
18 | |||
19 | S = "${WORKDIR}/apmd-3.2.2.orig" | ||
20 | |||
21 | inherit update-rc.d | ||
22 | |||
23 | INITSCRIPT_NAME = "apmd" | ||
24 | INITSCRIPT_PARAMS = "defaults" | ||
25 | |||
26 | do_compile() { | ||
27 | # apmd doesn't use whole autotools. Just libtool for installation | ||
28 | oe_runmake "LIBTOOL=${STAGING_BINDIR_CROSS}/${TARGET_PREFIX}libtool" apm apmd | ||
29 | } | ||
30 | |||
31 | do_install() { | ||
32 | install -d ${D}${sysconfdir} | ||
33 | install -d ${D}${sysconfdir}/apm | ||
34 | install -d ${D}${sysconfdir}/apm/event.d | ||
35 | install -d ${D}${sysconfdir}/apm/other.d | ||
36 | install -d ${D}${sysconfdir}/apm/suspend.d | ||
37 | install -d ${D}${sysconfdir}/apm/resume.d | ||
38 | install -d ${D}${sysconfdir}/apm/scripts.d | ||
39 | install -d ${D}${sysconfdir}/default | ||
40 | install -d ${D}${sysconfdir}/init.d | ||
41 | install -d ${D}${sbindir} | ||
42 | install -d ${D}${bindir} | ||
43 | install -d ${D}${libdir} | ||
44 | install -d ${D}${datadir}/apmd | ||
45 | install -d ${D}${includedir} | ||
46 | |||
47 | install -m 4755 ${S}/.libs/apm ${D}${bindir}/apm | ||
48 | install -m 0755 ${S}/.libs/apmd ${D}${sbindir}/apmd | ||
49 | install -m 0755 ${WORKDIR}/apmd_proxy ${D}${sysconfdir}/apm/ | ||
50 | install -m 0644 ${WORKDIR}/apmd_proxy.conf ${D}${datadir}/apmd/ | ||
51 | install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/apmd | ||
52 | oe_libinstall -so libapm ${D}${libdir} | ||
53 | install -m 0644 apm.h ${D}${includedir} | ||
54 | |||
55 | cat ${WORKDIR}/init | sed -e 's,/usr/sbin,${sbindir},g; s,/etc,${sysconfdir},g;' > ${D}${sysconfdir}/init.d/apmd | ||
56 | chmod 755 ${D}${sysconfdir}/init.d/apmd | ||
57 | } | ||
58 | |||
59 | PACKAGES =+ "libapm libapm-dev apm" | ||
60 | |||
61 | FILES_libapm = "${libdir}/libapm.so.*" | ||
62 | FILES_libapm-dev = "${libdir}/libapm.* ${includedir}" | ||
63 | FILES_apm = "${bindir}/apm*" | ||