diff options
author | Muhammad Shakeel <muhammad_shakeel@mentor.com> | 2013-09-12 06:31:19 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2013-09-14 08:29:41 +0100 |
commit | 5fb63f685c7c06a3940731128856b63e4429de80 (patch) | |
tree | ac2a225fb4d7703b3836ec3a6620c870c61bd347 /meta/recipes-bsp/apmd/apmd_3.2.2-14.bb | |
parent | 27bb9d0a9025043250edd09a334e6657073f26a3 (diff) | |
download | poky-5fb63f685c7c06a3940731128856b63e4429de80.tar.gz |
apmd: Add systemd support
-Remove dependency on meta-systemd
(From OE-Core rev: 9e963fe587dda3ce77707194fc5dd029188c76d8)
Signed-off-by: Muhammad Shakeel <muhammad_shakeel@mentor.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/apmd/apmd_3.2.2-14.bb')
-rw-r--r-- | meta/recipes-bsp/apmd/apmd_3.2.2-14.bb | 13 |
1 files changed, 11 insertions, 2 deletions
diff --git a/meta/recipes-bsp/apmd/apmd_3.2.2-14.bb b/meta/recipes-bsp/apmd/apmd_3.2.2-14.bb index d025387c3d..8c4b75eb6d 100644 --- a/meta/recipes-bsp/apmd/apmd_3.2.2-14.bb +++ b/meta/recipes-bsp/apmd/apmd_3.2.2-14.bb | |||
@@ -17,7 +17,8 @@ SRC_URI = "${DEBIAN_MIRROR}/main/a/apmd/apmd_3.2.2.orig.tar.gz;name=tarball \ | |||
17 | file://init \ | 17 | file://init \ |
18 | file://default \ | 18 | file://default \ |
19 | file://apmd_proxy \ | 19 | file://apmd_proxy \ |
20 | file://apmd_proxy.conf" | 20 | file://apmd_proxy.conf \ |
21 | file://apmd.service" | ||
21 | 22 | ||
22 | SRC_URI[tarball.md5sum] = "b1e6309e8331e0f4e6efd311c2d97fa8" | 23 | SRC_URI[tarball.md5sum] = "b1e6309e8331e0f4e6efd311c2d97fa8" |
23 | SRC_URI[tarball.sha256sum] = "7f7d9f60b7766b852881d40b8ff91d8e39fccb0d1d913102a5c75a2dbb52332d" | 24 | SRC_URI[tarball.sha256sum] = "7f7d9f60b7766b852881d40b8ff91d8e39fccb0d1d913102a5c75a2dbb52332d" |
@@ -27,11 +28,14 @@ SRC_URI[patch.sha256sum] = "7905ff96be93d725544d0040e425c42f9c05580db3c272f11cff | |||
27 | 28 | ||
28 | S = "${WORKDIR}/apmd-3.2.2.orig" | 29 | S = "${WORKDIR}/apmd-3.2.2.orig" |
29 | 30 | ||
30 | inherit update-rc.d | 31 | inherit update-rc.d systemd |
31 | 32 | ||
32 | INITSCRIPT_NAME = "apmd" | 33 | INITSCRIPT_NAME = "apmd" |
33 | INITSCRIPT_PARAMS = "defaults" | 34 | INITSCRIPT_PARAMS = "defaults" |
34 | 35 | ||
36 | SYSTEMD_SERVICE_${PN} = "apmd.service" | ||
37 | SYSTEMD_AUTO_ENABLE = "disable" | ||
38 | |||
35 | do_compile() { | 39 | do_compile() { |
36 | # apmd doesn't use whole autotools. Just libtool for installation | 40 | # apmd doesn't use whole autotools. Just libtool for installation |
37 | oe_runmake "LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool" apm apmd | 41 | oe_runmake "LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool" apm apmd |
@@ -63,6 +67,11 @@ do_install() { | |||
63 | 67 | ||
64 | cat ${WORKDIR}/init | sed -e 's,/usr/sbin,${sbindir},g; s,/etc,${sysconfdir},g;' > ${D}${sysconfdir}/init.d/apmd | 68 | cat ${WORKDIR}/init | sed -e 's,/usr/sbin,${sbindir},g; s,/etc,${sysconfdir},g;' > ${D}${sysconfdir}/init.d/apmd |
65 | chmod 755 ${D}${sysconfdir}/init.d/apmd | 69 | chmod 755 ${D}${sysconfdir}/init.d/apmd |
70 | |||
71 | install -d ${D}${systemd_unitdir}/system | ||
72 | install -m 0644 ${WORKDIR}/apmd.service ${D}${systemd_unitdir}/system/ | ||
73 | sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' \ | ||
74 | -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/apmd.service | ||
66 | } | 75 | } |
67 | 76 | ||
68 | PACKAGES =+ "libapm libapm-dev libapm-staticdev apm" | 77 | PACKAGES =+ "libapm libapm-dev libapm-staticdev apm" |