summaryrefslogtreecommitdiffstats
path: root/meta/recipes-benchmark/bonnie++/bonnie++_1.03e.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2013-12-12 13:38:32 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2013-12-12 13:50:20 +0100
commite2e6f6fe07049f33cb6348780fa975162752e421 (patch)
treeb1813295411235d1297a0ed642b1346b24fdfb12 /meta/recipes-benchmark/bonnie++/bonnie++_1.03e.bb
downloadpoky-e2e6f6fe07049f33cb6348780fa975162752e421.tar.gz
initial commit of Enea Linux 3.1
Migrated from the internal git server on the dora-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'meta/recipes-benchmark/bonnie++/bonnie++_1.03e.bb')
-rw-r--r--meta/recipes-benchmark/bonnie++/bonnie++_1.03e.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-benchmark/bonnie++/bonnie++_1.03e.bb b/meta/recipes-benchmark/bonnie++/bonnie++_1.03e.bb
new file mode 100644
index 0000000000..8a292c3755
--- /dev/null
+++ b/meta/recipes-benchmark/bonnie++/bonnie++_1.03e.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "Tests large file IO and creation/deletion of small files."
2HOMEPAGE = "http://www.coker.com.au/bonnie++/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://copyright.txt;md5=cd4dde95a6b9d122f0a9150ae9cc3ee0"
5
6SRC_URI = "http://www.coker.com.au/bonnie++/bonnie++-${PV}.tgz \
7 "
8SRC_URI[md5sum] = "750aa5b5051263a99c6c195888c74968"
9SRC_URI[sha256sum] = "cb3866116634bf65760b6806be4afa7e24a1cad6f145c876df8721f01ba2e2cb"
10
11inherit autotools
12
13SCRIPTS = "bon_csv2html bon_csv2txt"
14EXES = "bonnie++ zcav"
15
16TARGET_CC_ARCH += "${LDFLAGS}"
17
18do_install () {
19 install -d ${D}/usr/bin
20 install -d ${D}/usr/sbin
21 install -m 0755 ${EXES} ${D}/usr/sbin
22 install -m 0755 ${SCRIPTS} ${D}/usr/bin
23}
24
25PACKAGES =+ "bonnie-scripts"
26
27FILES_${PN} = "${sbindir}"
28FILES_bonnie-scripts = "${bindir}"