diff options
author | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
commit | b2f192faabe412adce79534e22efe9fb69ee40e2 (patch) | |
tree | 7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/zlib/zlib_1.2.2.bb | |
parent | 2cf0eadf9f730027833af802d7e6c90b44248f80 (diff) | |
download | poky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz |
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/zlib/zlib_1.2.2.bb')
-rw-r--r-- | meta/packages/zlib/zlib_1.2.2.bb | 38 |
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/packages/zlib/zlib_1.2.2.bb b/meta/packages/zlib/zlib_1.2.2.bb new file mode 100644 index 0000000000..08c97c2f25 --- /dev/null +++ b/meta/packages/zlib/zlib_1.2.2.bb | |||
@@ -0,0 +1,38 @@ | |||
1 | DESCRIPTION = "Zlib Compression Library" | ||
2 | SECTION = "libs" | ||
3 | PRIORITY = "required" | ||
4 | MAINTAINER = "Chris Larson <kergoth@handhelds.org>" | ||
5 | HOMEPAGE = "http://www.gzip.org/zlib/" | ||
6 | LICENSE = "zlib" | ||
7 | PR = "r6" | ||
8 | |||
9 | SRC_URI = "http://www.libpng.org/pub/png/src/zlib-${PV}.tar.gz \ | ||
10 | file://visibility.patch;patch=1 \ | ||
11 | file://zlib_1.2.2-8.diff.gz;patch=1 " | ||
12 | S = "${WORKDIR}/zlib-${PV}" | ||
13 | |||
14 | export LDSHARED = "${CC} -shared -Wl,-soname,libz.so.1" | ||
15 | LDFLAGS_append = " -L. -lz" | ||
16 | CFLAGS_prepend = "-fPIC -DZLIB_DLL " | ||
17 | AR_append = " rc" | ||
18 | EXTRA_OEMAKE = "" | ||
19 | |||
20 | do_compile() { | ||
21 | ./configure --prefix=${prefix} --exec_prefix=${exec_prefix} --shared --libdir=${libdir} --includedir=${includedir} | ||
22 | oe_runmake -e MAKEFLAGS="" libz.so.${PV} libz.a | ||
23 | } | ||
24 | |||
25 | do_stage() { | ||
26 | install -m 0644 zlib.h ${STAGING_INCDIR}/zlib.h | ||
27 | install -m 0644 zconf.h ${STAGING_INCDIR}/zconf.h | ||
28 | oe_libinstall -a -so libz ${STAGING_LIBDIR} | ||
29 | } | ||
30 | |||
31 | do_install() { | ||
32 | install -d ${D}${prefix} ${D}${includedir} ${D}${libdir} | ||
33 | oe_runmake "prefix=${D}${prefix}" \ | ||
34 | "exec_prefix=${D}${exec_prefix}" \ | ||
35 | "man3dir=${D}${mandir}/man3" \ | ||
36 | "includedir=${D}${includedir}" \ | ||
37 | "libdir=${D}${libdir}" install | ||
38 | } | ||