summaryrefslogtreecommitdiffstats
path: root/meta/packages/zlib/files/configure.ac
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-06-11 13:02:35 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-06-30 13:19:02 +0100
commitafe4dec809644c8e070dd8df929fb784e1cf37ed (patch)
treef339c40e0edb6eb1cd4e7fb24fdac3575df5a74c /meta/packages/zlib/files/configure.ac
parent86171831d625073385c45dc59c4214bea0d9c963 (diff)
downloadpoky-afe4dec809644c8e070dd8df929fb784e1cf37ed.tar.gz
zlib: upgrade to version 1.2.5
from 1.2.3 update homepage and license changes: - remove 1.2.3.3 patch - breakdown autotools.patch to configure.ac and Makefile.am, update src in Makefile.am and use do_configure_prepend instead - remove README from LIC_FILES_CHKSUM because it duplicates zlib.h and also causes checksum to change for every release - remove visibility.patch: the purpose of the patch was to change "<type> ZEXPORT" to "ZEXPORT <type>", however: 1. the use of ZEXPORT and ZEXTERN have been changed a lot in zlib, there is no changelog to indicate which version was the patch based on and its rationale 2. zlib used to set default visibility to `hidden' (-fvisibility=hidden), and override external symbols with `default' visibility, it had caused a lot of problems on different platforms. But starting from 1.2.5, default visibility is now `default', `hidden' visibility override has effect only for the correct GCC versions, most visibility related issues should have already been fixed http://mail.madler.net/pipermail/zlib-devel_madler.net/2010-April/002045.html 3. as for now, ZEXPORT is used in Win/BeOS only, and can expand to WINAPI or __declspec(dllexport), both of which should be put behind return type, so there is no need to patch In conclusion, the patch is not applicable for the current release, so it's removed Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/packages/zlib/files/configure.ac')
-rw-r--r--meta/packages/zlib/files/configure.ac48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/packages/zlib/files/configure.ac b/meta/packages/zlib/files/configure.ac
new file mode 100644
index 0000000000..4761b7ef28
--- /dev/null
+++ b/meta/packages/zlib/files/configure.ac
@@ -0,0 +1,48 @@
1AC_INIT(zlib,1.2.5)
2AC_CONFIG_SRCDIR(adler32.c)
3AM_INIT_AUTOMAKE(zlibs,1.2.5)
4
5AC_PREREQ([2.59])
6
7AC_PROG_CC([gcc])
8AC_PROG_LIBTOOL
9
10AC_HEADER_STDC
11
12zlib_save_CPPFLAGS=$CPPFLAGS
13CPPFLAGS="$CPPFLAGS -D_LARGEFILE64_SOURCE"
14AC_CHECK_TYPES(off64_t)
15CPPFLAGS=$zlib_save_CPPFLAGS
16
17AC_CACHE_CHECK([whether to enable -D_LARGEFILE64_SOURCE], [zlib_cv_use_lfs64], [
18 zlib_cv_use_lfs64=no
19 if test "$ac_cv_type_off64_t" = "yes"; then
20 zlib_cv_use_lfs64=yes
21 fi
22])
23
24if test "$zlib_cv_use_lfs64" = "yes"; then
25 CPPFLAGS="$CPPFLAGS -D_LARGEFILE64_SOURCE"
26
27 #APR_ADDTO(CPPFLAGS, [-D_LARGEFILE64_SOURCE])
28fi
29
30cat > zlibdefs.h << EOF
31/* zlibdefs.h -- compile-time definitions for the zlib compression library
32 * Copyright (C) 1995-2006 Jean-loup Gailly.
33 * For conditions of distribution and use, see copyright notice in zlib.h
34 */
35
36#include <sys/types.h> /* for off_t */
37#include <unistd.h> /* for SEEK_* and off_t */
38#ifdef VMS
39# include <unixio.h> /* for off_t */
40#endif
41#ifndef z_off_t
42# define z_off_t off_t
43#endif
44EOF
45
46AC_CONFIG_FILES([Makefile])
47
48AC_OUTPUT