summaryrefslogtreecommitdiffstats
path: root/meta/packages/zip/zip_2.31.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
commitb2f192faabe412adce79534e22efe9fb69ee40e2 (patch)
tree7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/zip/zip_2.31.bb
parent2cf0eadf9f730027833af802d7e6c90b44248f80 (diff)
downloadpoky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/zip/zip_2.31.bb')
-rw-r--r--meta/packages/zip/zip_2.31.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/packages/zip/zip_2.31.bb b/meta/packages/zip/zip_2.31.bb
new file mode 100644
index 0000000000..6c588a55e5
--- /dev/null
+++ b/meta/packages/zip/zip_2.31.bb
@@ -0,0 +1,17 @@
1SECTION = "console/utils"
2SRC_URI = "http://ftp.info-zip.org/pub/infozip/src/zip231.tar.gz"
3LICENSE = "Info-ZIP"
4EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
5 'CFLAGS=-I. -DUNIX ${CFLAGS}' 'INSTALL=install' \
6 'BINFLAGS=0755' 'INSTALL_D=install -d'"
7
8do_compile() {
9 oe_runmake -f unix/Makefile generic
10}
11
12do_install() {
13 oe_runmake -f unix/Makefile prefix=${D}${prefix} \
14 BINDIR=${D}${bindir} MANDIR=${D}${mandir}/man1 \
15 install
16}
17