diff options
author | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
commit | b2f192faabe412adce79534e22efe9fb69ee40e2 (patch) | |
tree | 7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/zile/files | |
parent | 2cf0eadf9f730027833af802d7e6c90b44248f80 (diff) | |
download | poky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz |
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/zile/files')
-rw-r--r-- | meta/packages/zile/files/for_build.patch | 64 |
1 files changed, 64 insertions, 0 deletions
diff --git a/meta/packages/zile/files/for_build.patch b/meta/packages/zile/files/for_build.patch new file mode 100644 index 0000000000..96380fa220 --- /dev/null +++ b/meta/packages/zile/files/for_build.patch | |||
@@ -0,0 +1,64 @@ | |||
1 | Index: zile-2.0beta6/acinclude.m4 | ||
2 | =================================================================== | ||
3 | --- zile-2.0beta6.orig/acinclude.m4 2004-12-20 19:13:07.000000000 -0500 | ||
4 | +++ zile-2.0beta6/acinclude.m4 2005-01-21 20:38:28.982166344 -0500 | ||
5 | @@ -35,3 +35,29 @@ | ||
6 | t} | ||
7 | fi | ||
8 | AC_SUBST(EXEEXT_FOR_BUILD)])dnl | ||
9 | + | ||
10 | +dnl Get a default for CFLAGS_FOR_BUILD to put into Makefile. | ||
11 | +AC_DEFUN([BFD_CFLAGS_FOR_BUILD], | ||
12 | +[ac_test_CFLAGS=${CFLAGS+set} | ||
13 | +# Put a plausible default for CFLAGS_FOR_BUILD in Makefile. | ||
14 | +if test -z "$CFLAGS_FOR_BUILD"; then | ||
15 | + if test "x$cross_compiling" = "xyes"; then | ||
16 | + CFLAGS_FOR_BUILD="-O2" | ||
17 | + else | ||
18 | + CFLAGS_FOR_BUILD='$(CFLAGS)' | ||
19 | + fi | ||
20 | +fi | ||
21 | +AC_SUBST(CFLAGS_FOR_BUILD)])dnl | ||
22 | + | ||
23 | +dnl Get a default for LDFLAGS_FOR_BUILD to put into Makefile. | ||
24 | +AC_DEFUN([BFD_LDFLAGS_FOR_BUILD], | ||
25 | +[ac_test_LDFLAGS=${LDFLAGS+set} | ||
26 | +# Put a plausible default for LDFLAGS_FOR_BUILD in Makefile. | ||
27 | +if test -z "$LDFLAGS_FOR_BUILD"; then | ||
28 | + if test "x$cross_compiling" = "xyes"; then | ||
29 | + LDFLAGS_FOR_BUILD="" | ||
30 | + else | ||
31 | + LDFLAGS_FOR_BUILD='$(LDFLAGS)' | ||
32 | + fi | ||
33 | +fi | ||
34 | +AC_SUBST(LDFLAGS_FOR_BUILD)])dnl | ||
35 | Index: zile-2.0beta6/configure.ac | ||
36 | =================================================================== | ||
37 | --- zile-2.0beta6.orig/configure.ac 2005-01-12 07:56:19.000000000 -0500 | ||
38 | +++ zile-2.0beta6/configure.ac 2005-01-21 20:26:58.178184512 -0500 | ||
39 | @@ -19,6 +19,8 @@ | ||
40 | |||
41 | AC_PROG_CC | ||
42 | BFD_CC_FOR_BUILD | ||
43 | +BFD_CFLAGS_FOR_BUILD | ||
44 | +BFD_LDFLAGS_FOR_BUILD | ||
45 | AC_C_INLINE | ||
46 | AC_PROG_INSTALL | ||
47 | AC_PROG_RANLIB | ||
48 | Index: zile-2.0beta6/doc/Makefile.am | ||
49 | =================================================================== | ||
50 | --- zile-2.0beta6.orig/doc/Makefile.am 2005-01-03 06:11:32.000000000 -0500 | ||
51 | +++ zile-2.0beta6/doc/Makefile.am 2005-01-21 20:27:17.271281920 -0500 | ||
52 | @@ -27,10 +27,10 @@ | ||
53 | AM_CFLAGS = -I$(top_srcdir) -I$(top_srcdir)/lib -I$(top_srcdir)/src | ||
54 | |||
55 | mkdoc$(EXEEXT_FOR_BUILD): mkdoc.o config.h | ||
56 | - $(CC_FOR_BUILD) $(CFLAGS) $(LDFLAGS) -o $@ mkdoc.o | ||
57 | + $(CC_FOR_BUILD) $(CFLAGS_FOR_BUILD) $(LDFLAGS_FOR_BUILD) -o $@ mkdoc.o | ||
58 | |||
59 | mkdoc.o: mkdoc.c | ||
60 | - $(CC_FOR_BUILD) -c -I$(top_srcdir)/doc -I$(top_srcdir) -I$(top_srcdir)/src $(CFLAGS) $(srcdir)/mkdoc.c | ||
61 | + $(CC_FOR_BUILD) -c -I$(top_srcdir)/doc -I$(top_srcdir) -I$(top_srcdir)/src $(CFLAGS_FOR_BUILD) $(srcdir)/mkdoc.c | ||
62 | |||
63 | AUTODOC: $(AUTODOCSRCS) mkdoc | ||
64 | ./mkdoc $(AUTODOCSRCS) >AUTODOC | ||