diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2009-09-04 10:07:29 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2009-09-04 10:07:29 +0100 |
commit | 0e842cf1b5356090005ddb301e86bee7b1a180fb (patch) | |
tree | 0024ab53d324a17a6fdd224e551d09aeccb3f876 /meta/packages/zeroconf | |
parent | a340d3cda7c5716376ae3b6a1e3d96139704cbfd (diff) | |
download | poky-0e842cf1b5356090005ddb301e86bee7b1a180fb.tar.gz |
zeroconf: Fix compile issue
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/zeroconf')
-rw-r--r-- | meta/packages/zeroconf/zeroconf/compilefix.patch | 17 | ||||
-rw-r--r-- | meta/packages/zeroconf/zeroconf/debian-zeroconf (renamed from meta/packages/zeroconf/files/debian-zeroconf) | 0 | ||||
-rw-r--r-- | meta/packages/zeroconf/zeroconf/zeroconf-default (renamed from meta/packages/zeroconf/files/zeroconf-default) | 0 | ||||
-rw-r--r-- | meta/packages/zeroconf/zeroconf_0.9.bb | 7 |
4 files changed, 21 insertions, 3 deletions
diff --git a/meta/packages/zeroconf/zeroconf/compilefix.patch b/meta/packages/zeroconf/zeroconf/compilefix.patch new file mode 100644 index 0000000000..b7b917dc2b --- /dev/null +++ b/meta/packages/zeroconf/zeroconf/compilefix.patch | |||
@@ -0,0 +1,17 @@ | |||
1 | | zeroconf.c: In function 'main': | ||
2 | | zeroconf.c:145: error: 'PATH_MAX' undeclared (first use in this function) | ||
3 | |||
4 | RP - 4/9/09 | ||
5 | |||
6 | Index: zeroconf-0.9/zeroconf.c | ||
7 | =================================================================== | ||
8 | --- zeroconf-0.9.orig/zeroconf.c 2009-09-04 10:05:25.000000000 +0100 | ||
9 | +++ zeroconf-0.9/zeroconf.c 2009-09-04 10:05:42.000000000 +0100 | ||
10 | @@ -33,6 +33,7 @@ | ||
11 | #include <net/if_arp.h> | ||
12 | #include <sys/time.h> | ||
13 | #include <signal.h> | ||
14 | +#include <limits.h> | ||
15 | |||
16 | #include "delay.h" | ||
17 | |||
diff --git a/meta/packages/zeroconf/files/debian-zeroconf b/meta/packages/zeroconf/zeroconf/debian-zeroconf index c3705d2788..c3705d2788 100644 --- a/meta/packages/zeroconf/files/debian-zeroconf +++ b/meta/packages/zeroconf/zeroconf/debian-zeroconf | |||
diff --git a/meta/packages/zeroconf/files/zeroconf-default b/meta/packages/zeroconf/zeroconf/zeroconf-default index cc07b275f1..cc07b275f1 100644 --- a/meta/packages/zeroconf/files/zeroconf-default +++ b/meta/packages/zeroconf/zeroconf/zeroconf-default | |||
diff --git a/meta/packages/zeroconf/zeroconf_0.9.bb b/meta/packages/zeroconf/zeroconf_0.9.bb index c8f7ddfa3a..f22466eea7 100644 --- a/meta/packages/zeroconf/zeroconf_0.9.bb +++ b/meta/packages/zeroconf/zeroconf_0.9.bb | |||
@@ -5,11 +5,12 @@ LICENSE = "GPL" | |||
5 | SECTION = "net" | 5 | SECTION = "net" |
6 | PRIORITY = "optional" | 6 | PRIORITY = "optional" |
7 | 7 | ||
8 | PR = "r0" | 8 | PR = "r1" |
9 | 9 | ||
10 | SRC_URI = "http://www.progsoc.org/~wildfire/zeroconf/download/${PN}-${PV}.tar.gz \ | 10 | SRC_URI = "http://www.progsoc.org/~wildfire/zeroconf/download/${PN}-${PV}.tar.gz \ |
11 | file://zeroconf-default \ | 11 | file://compilefix.patch;patch=1 \ |
12 | file://debian-zeroconf" | 12 | file://zeroconf-default \ |
13 | file://debian-zeroconf" | ||
13 | 14 | ||
14 | do_install () { | 15 | do_install () { |
15 | install -d ${D}${sbindir} | 16 | install -d ${D}${sbindir} |