diff options
author | Joshua Lock <josh@linux.intel.com> | 2010-03-24 17:29:02 +0000 |
---|---|---|
committer | Joshua Lock <josh@linux.intel.com> | 2010-03-26 10:29:18 +0000 |
commit | 555f60faa0bcaa0d3faab7ccf12e8c663f9ba51c (patch) | |
tree | 1c9445dfe693bc04fec31f66a0b2cf7f9f6fca7e /meta/packages/yum | |
parent | 9b3a51fbd8ad4f9a27f561b7ee65d3babfdc6a9e (diff) | |
download | poky-555f60faa0bcaa0d3faab7ccf12e8c663f9ba51c.tar.gz |
yum: Fix installation of python modules
Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta/packages/yum')
-rw-r--r-- | meta/packages/yum/files/paths2.patch | 30 | ||||
-rw-r--r-- | meta/packages/yum/yum_3.2.27.bb | 2 |
2 files changed, 17 insertions, 15 deletions
diff --git a/meta/packages/yum/files/paths2.patch b/meta/packages/yum/files/paths2.patch index 08c9c8312e..8fe6d0c983 100644 --- a/meta/packages/yum/files/paths2.patch +++ b/meta/packages/yum/files/paths2.patch | |||
@@ -3,31 +3,33 @@ | |||
3 | yum/Makefile | 2 +- | 3 | yum/Makefile | 2 +- |
4 | 2 files changed, 2 insertions(+), 2 deletions(-) | 4 | 2 files changed, 2 insertions(+), 2 deletions(-) |
5 | 5 | ||
6 | --- yum-3.2.18.orig/rpmUtils/Makefile | 6 | Index: yum-3.2.27/rpmUtils/Makefile |
7 | +++ yum-3.2.18/rpmUtils/Makefile | 7 | =================================================================== |
8 | @@ -1,10 +1,10 @@ | 8 | --- yum-3.2.27.orig/rpmUtils/Makefile 2010-03-24 17:26:39.759798777 +0000 |
9 | PYTHON=python | 9 | +++ yum-3.2.27/rpmUtils/Makefile 2010-03-24 17:26:54.835863845 +0000 |
10 | @@ -2,8 +2,8 @@ | ||
10 | PACKAGE = $(shell basename `pwd`) | 11 | PACKAGE = $(shell basename `pwd`) |
11 | PYFILES = $(wildcard *.py) | 12 | PYFILES = $(wildcard *.py) |
12 | PYVER := $(shell $(PYTHON) -c 'import sys; print "%.3s" %(sys.version)') | 13 | PYVER := $(shell $(PYTHON) -c 'import sys; print "%.3s" %(sys.version)') |
13 | -PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix') | 14 | -PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix') |
14 | +PYSYSDIR = /usr | 15 | -PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER) |
15 | PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER) | 16 | +PYSYSDIR = $(libdir) |
17 | +PYLIBDIR = $(PYSYSDIR)/python$(PYVER) | ||
16 | PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE) | 18 | PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE) |
17 | 19 | ||
18 | all: | 20 | all: |
19 | echo "Nothing to do" | 21 | Index: yum-3.2.27/yum/Makefile |
20 | --- yum-3.2.18.orig/yum/Makefile | 22 | =================================================================== |
21 | +++ yum-3.2.18/yum/Makefile | 23 | --- yum-3.2.27.orig/yum/Makefile 2010-03-24 17:26:39.759798777 +0000 |
22 | @@ -1,10 +1,10 @@ | 24 | +++ yum-3.2.27/yum/Makefile 2010-03-24 17:26:43.726773783 +0000 |
23 | PYTHON=python | 25 | @@ -2,8 +2,8 @@ |
24 | PACKAGE = $(shell basename `pwd`) | 26 | PACKAGE = $(shell basename `pwd`) |
25 | PYFILES = $(wildcard *.py) | 27 | PYFILES = $(wildcard *.py) |
26 | PYVER := $(shell $(PYTHON) -c 'import sys; print "%.3s" %(sys.version)') | 28 | PYVER := $(shell $(PYTHON) -c 'import sys; print "%.3s" %(sys.version)') |
27 | -PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix') | 29 | -PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix') |
28 | +PYSYSDIR = /usr | 30 | -PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER) |
29 | PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER) | 31 | +PYSYSDIR = $(libdir) |
32 | +PYLIBDIR = $(PYSYSDIR)/python$(PYVER) | ||
30 | PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE) | 33 | PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE) |
31 | 34 | ||
32 | all: | 35 | all: |
33 | echo "Nothing to do" | ||
diff --git a/meta/packages/yum/yum_3.2.27.bb b/meta/packages/yum/yum_3.2.27.bb index e51aacd562..75669af448 100644 --- a/meta/packages/yum/yum_3.2.27.bb +++ b/meta/packages/yum/yum_3.2.27.bb | |||
@@ -1,5 +1,5 @@ | |||
1 | HOMEPAGE = "http://linux.duke.edu/projects/yum/" | 1 | HOMEPAGE = "http://linux.duke.edu/projects/yum/" |
2 | PR = "r7" | 2 | PR = "r8" |
3 | 3 | ||
4 | SRC_URI = "http://linux.duke.edu/projects/yum/download/3.2/yum-${PV}.tar.gz \ | 4 | SRC_URI = "http://linux.duke.edu/projects/yum/download/3.2/yum-${PV}.tar.gz \ |
5 | file://paths.patch;patch=1 \ | 5 | file://paths.patch;patch=1 \ |