diff options
author | Richard Purdie <richard@openedhand.com> | 2008-09-03 20:58:22 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2008-09-03 20:58:22 +0000 |
commit | aae958d719c9c54c7f4d22ef94954be54cb30c6e (patch) | |
tree | 511b23a09610284ade4f839ac60029ff1f2f1e1c /meta/packages/yum | |
parent | 6269c57167cd172d1fadb0d0efd50b953755e0cc (diff) | |
download | poky-aae958d719c9c54c7f4d22ef94954be54cb30c6e.tar.gz |
yum-native: Add NOPOST and NOTRIGGERS flags when installing packages
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5130 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/yum')
-rw-r--r-- | meta/packages/yum/yum-native/hacks.patch | 32 | ||||
-rw-r--r-- | meta/packages/yum/yum-native_3.2.18.bb | 2 |
2 files changed, 20 insertions, 14 deletions
diff --git a/meta/packages/yum/yum-native/hacks.patch b/meta/packages/yum/yum-native/hacks.patch index 0486b5f4e5..d0232ec9be 100644 --- a/meta/packages/yum/yum-native/hacks.patch +++ b/meta/packages/yum/yum-native/hacks.patch | |||
@@ -7,9 +7,9 @@ | |||
7 | 7 | ||
8 | Index: yum-3.2.18/rpmUtils/arch.py | 8 | Index: yum-3.2.18/rpmUtils/arch.py |
9 | =================================================================== | 9 | =================================================================== |
10 | --- yum-3.2.18.orig/rpmUtils/arch.py 2008-08-26 12:43:14.000000000 +0100 | 10 | --- yum-3.2.18.orig/rpmUtils/arch.py 2008-06-17 14:05:42.000000000 +0100 |
11 | +++ yum-3.2.18/rpmUtils/arch.py 2008-08-26 12:50:11.000000000 +0100 | 11 | +++ yum-3.2.18/rpmUtils/arch.py 2008-09-01 15:47:11.000000000 +0100 |
12 | @@ -275,6 +275,7 @@ def getCanonX86_64Arch(arch): | 12 | @@ -275,6 +275,7 @@ |
13 | return arch | 13 | return arch |
14 | 14 | ||
15 | def getCanonArch(skipRpmPlatform = 0): | 15 | def getCanonArch(skipRpmPlatform = 0): |
@@ -17,7 +17,7 @@ Index: yum-3.2.18/rpmUtils/arch.py | |||
17 | if not skipRpmPlatform and os.access("/etc/rpm/platform", os.R_OK): | 17 | if not skipRpmPlatform and os.access("/etc/rpm/platform", os.R_OK): |
18 | try: | 18 | try: |
19 | f = open("/etc/rpm/platform", "r") | 19 | f = open("/etc/rpm/platform", "r") |
20 | @@ -331,6 +332,8 @@ def getBaseArch(myarch=None): | 20 | @@ -331,6 +332,8 @@ |
21 | base arch is the arch before noarch in the arches dict if myarch is not | 21 | base arch is the arch before noarch in the arches dict if myarch is not |
22 | a key in the multilibArches.""" | 22 | a key in the multilibArches.""" |
23 | 23 | ||
@@ -28,9 +28,9 @@ Index: yum-3.2.18/rpmUtils/arch.py | |||
28 | 28 | ||
29 | Index: yum-3.2.18/rpmUtils/transaction.py | 29 | Index: yum-3.2.18/rpmUtils/transaction.py |
30 | =================================================================== | 30 | =================================================================== |
31 | --- yum-3.2.18.orig/rpmUtils/transaction.py 2008-08-26 13:03:13.000000000 +0100 | 31 | --- yum-3.2.18.orig/rpmUtils/transaction.py 2008-06-17 14:05:42.000000000 +0100 |
32 | +++ yum-3.2.18/rpmUtils/transaction.py 2008-08-26 13:10:52.000000000 +0100 | 32 | +++ yum-3.2.18/rpmUtils/transaction.py 2008-09-03 17:55:27.000000000 +0100 |
33 | @@ -43,6 +43,7 @@ class TransactionWrapper: | 33 | @@ -43,6 +43,7 @@ |
34 | 'clean'] | 34 | 'clean'] |
35 | self.tsflags = [] | 35 | self.tsflags = [] |
36 | self.open = True | 36 | self.open = True |
@@ -40,9 +40,9 @@ Index: yum-3.2.18/rpmUtils/transaction.py | |||
40 | # Automatically close the rpm transaction when the reference is lost | 40 | # Automatically close the rpm transaction when the reference is lost |
41 | Index: yum-3.2.18/yum/constants.py | 41 | Index: yum-3.2.18/yum/constants.py |
42 | =================================================================== | 42 | =================================================================== |
43 | --- yum-3.2.18.orig/yum/constants.py 2008-08-26 13:12:39.000000000 +0100 | 43 | --- yum-3.2.18.orig/yum/constants.py 2008-07-21 16:56:54.000000000 +0100 |
44 | +++ yum-3.2.18/yum/constants.py 2008-08-26 13:12:46.000000000 +0100 | 44 | +++ yum-3.2.18/yum/constants.py 2008-09-01 15:47:11.000000000 +0100 |
45 | @@ -17,7 +17,7 @@ Yum constants. Usually dealing with rpm | 45 | @@ -17,7 +17,7 @@ |
46 | """ | 46 | """ |
47 | 47 | ||
48 | #Constants | 48 | #Constants |
@@ -53,9 +53,15 @@ Index: yum-3.2.18/yum/constants.py | |||
53 | TS_UPDATE = 10 | 53 | TS_UPDATE = 10 |
54 | Index: yum-3.2.18/yum/depsolve.py | 54 | Index: yum-3.2.18/yum/depsolve.py |
55 | =================================================================== | 55 | =================================================================== |
56 | --- yum-3.2.18.orig/yum/depsolve.py 2008-08-26 12:44:37.000000000 +0100 | 56 | --- yum-3.2.18.orig/yum/depsolve.py 2008-08-06 17:05:16.000000000 +0100 |
57 | +++ yum-3.2.18/yum/depsolve.py 2008-08-26 13:17:45.000000000 +0100 | 57 | +++ yum-3.2.18/yum/depsolve.py 2008-09-03 21:05:52.000000000 +0100 |
58 | @@ -144,6 +144,8 @@ class Depsolve(object): | 58 | @@ -141,9 +141,14 @@ |
59 | else: | ||
60 | self.logger.critical(_('Invalid tsflag in config file: %s'), flag) | ||
61 | |||
62 | + self._ts.addTsFlag(rpm.RPMTRANS_FLAG_NOPOST) | ||
63 | + self._ts.addTsFlag(rpm.RPMTRANS_FLAG_NOTRIGGERS) | ||
64 | + | ||
59 | probfilter = 0 | 65 | probfilter = 0 |
60 | for flag in self.tsInfo.probFilterFlags: | 66 | for flag in self.tsInfo.probFilterFlags: |
61 | probfilter |= flag | 67 | probfilter |= flag |
diff --git a/meta/packages/yum/yum-native_3.2.18.bb b/meta/packages/yum/yum-native_3.2.18.bb index fcb5680038..d90f158cd6 100644 --- a/meta/packages/yum/yum-native_3.2.18.bb +++ b/meta/packages/yum/yum-native_3.2.18.bb | |||
@@ -3,7 +3,7 @@ HOMEPAGE = "http://linux.duke.edu/projects/yum/" | |||
3 | SRC_URI = "http://linux.duke.edu/projects/yum/download/3.2/yum-${PV}.tar.gz \ | 3 | SRC_URI = "http://linux.duke.edu/projects/yum/download/3.2/yum-${PV}.tar.gz \ |
4 | file://hacks.patch;patch=1 \ | 4 | file://hacks.patch;patch=1 \ |
5 | file://paths.patch;patch=1" | 5 | file://paths.patch;patch=1" |
6 | PR = "r3" | 6 | PR = "r4" |
7 | 7 | ||
8 | DEPENDS = "rpm-native python-native python-iniparse-native python-urlgrabber-native yum-metadata-parser-native libxml2-native" | 8 | DEPENDS = "rpm-native python-native python-iniparse-native python-urlgrabber-native yum-metadata-parser-native libxml2-native" |
9 | 9 | ||