diff options
author | Richard Purdie <richard@openedhand.com> | 2008-08-26 12:24:26 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2008-08-26 12:24:26 +0000 |
commit | 8c33755bdda11d9d5b8a5b70f124278dd44d5dfd (patch) | |
tree | 02b0fde461f0f7c4b87df9d138decf31920dc5fb /meta/packages/yum | |
parent | 38d187038e93f3fee6144737a8f49a34ef49d757 (diff) | |
download | poky-8c33755bdda11d9d5b8a5b70f124278dd44d5dfd.tar.gz |
yum-native: Add some hacks to make yum work better in the cross build case
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5110 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/yum')
-rw-r--r-- | meta/packages/yum/yum-native/hacks.patch | 66 | ||||
-rw-r--r-- | meta/packages/yum/yum-native_3.2.18.bb | 3 |
2 files changed, 68 insertions, 1 deletions
diff --git a/meta/packages/yum/yum-native/hacks.patch b/meta/packages/yum/yum-native/hacks.patch new file mode 100644 index 0000000000..0486b5f4e5 --- /dev/null +++ b/meta/packages/yum/yum-native/hacks.patch | |||
@@ -0,0 +1,66 @@ | |||
1 | --- | ||
2 | rpmUtils/arch.py | 3 +++ | ||
3 | rpmUtils/transaction.py | 1 + | ||
4 | yum/constants.py | 2 +- | ||
5 | yum/depsolve.py | 2 ++ | ||
6 | 4 files changed, 7 insertions(+), 1 deletion(-) | ||
7 | |||
8 | Index: yum-3.2.18/rpmUtils/arch.py | ||
9 | =================================================================== | ||
10 | --- yum-3.2.18.orig/rpmUtils/arch.py 2008-08-26 12:43:14.000000000 +0100 | ||
11 | +++ yum-3.2.18/rpmUtils/arch.py 2008-08-26 12:50:11.000000000 +0100 | ||
12 | @@ -275,6 +275,7 @@ def getCanonX86_64Arch(arch): | ||
13 | return arch | ||
14 | |||
15 | def getCanonArch(skipRpmPlatform = 0): | ||
16 | + return "arm" | ||
17 | if not skipRpmPlatform and os.access("/etc/rpm/platform", os.R_OK): | ||
18 | try: | ||
19 | f = open("/etc/rpm/platform", "r") | ||
20 | @@ -331,6 +332,8 @@ def getBaseArch(myarch=None): | ||
21 | base arch is the arch before noarch in the arches dict if myarch is not | ||
22 | a key in the multilibArches.""" | ||
23 | |||
24 | + return "arm" | ||
25 | + | ||
26 | if not myarch: | ||
27 | myarch = canonArch | ||
28 | |||
29 | Index: yum-3.2.18/rpmUtils/transaction.py | ||
30 | =================================================================== | ||
31 | --- yum-3.2.18.orig/rpmUtils/transaction.py 2008-08-26 13:03:13.000000000 +0100 | ||
32 | +++ yum-3.2.18/rpmUtils/transaction.py 2008-08-26 13:10:52.000000000 +0100 | ||
33 | @@ -43,6 +43,7 @@ class TransactionWrapper: | ||
34 | 'clean'] | ||
35 | self.tsflags = [] | ||
36 | self.open = True | ||
37 | + self.ts.setProbFilter(rpm.RPMPROB_FILTER_IGNOREOS | rpm.RPMPROB_FILTER_IGNOREARCH) | ||
38 | |||
39 | def __del__(self): | ||
40 | # Automatically close the rpm transaction when the reference is lost | ||
41 | Index: yum-3.2.18/yum/constants.py | ||
42 | =================================================================== | ||
43 | --- yum-3.2.18.orig/yum/constants.py 2008-08-26 13:12:39.000000000 +0100 | ||
44 | +++ yum-3.2.18/yum/constants.py 2008-08-26 13:12:46.000000000 +0100 | ||
45 | @@ -17,7 +17,7 @@ Yum constants. Usually dealing with rpm | ||
46 | """ | ||
47 | |||
48 | #Constants | ||
49 | -YUM_PID_FILE = '/var/run/yum.pid' | ||
50 | +YUM_PID_FILE = '/var/run2/yum.pid' | ||
51 | |||
52 | #transaction set states | ||
53 | TS_UPDATE = 10 | ||
54 | Index: yum-3.2.18/yum/depsolve.py | ||
55 | =================================================================== | ||
56 | --- yum-3.2.18.orig/yum/depsolve.py 2008-08-26 12:44:37.000000000 +0100 | ||
57 | +++ yum-3.2.18/yum/depsolve.py 2008-08-26 13:17:45.000000000 +0100 | ||
58 | @@ -144,6 +144,8 @@ class Depsolve(object): | ||
59 | probfilter = 0 | ||
60 | for flag in self.tsInfo.probFilterFlags: | ||
61 | probfilter |= flag | ||
62 | + probfilter |= rpm.RPMPROB_FILTER_IGNOREOS | ||
63 | + probfilter |= rpm.RPMPROB_FILTER_IGNOREARCH | ||
64 | self._ts.setProbFilter(probfilter) | ||
65 | |||
66 | def whatProvides(self, name, flags, version): | ||
diff --git a/meta/packages/yum/yum-native_3.2.18.bb b/meta/packages/yum/yum-native_3.2.18.bb index d3098ccb91..03e54d5daa 100644 --- a/meta/packages/yum/yum-native_3.2.18.bb +++ b/meta/packages/yum/yum-native_3.2.18.bb | |||
@@ -1,8 +1,9 @@ | |||
1 | HOMEPAGE = "http://linux.duke.edu/projects/yum/" | 1 | HOMEPAGE = "http://linux.duke.edu/projects/yum/" |
2 | 2 | ||
3 | SRC_URI = "http://linux.duke.edu/projects/yum/download/3.2/yum-${PV}.tar.gz \ | 3 | SRC_URI = "http://linux.duke.edu/projects/yum/download/3.2/yum-${PV}.tar.gz \ |
4 | file://hacks.patch;patch=1 \ | ||
4 | file://paths.patch;patch=1" | 5 | file://paths.patch;patch=1" |
5 | PR = "r1" | 6 | PR = "r2" |
6 | 7 | ||
7 | DEPENDS = "rpm-native python-native python-iniparse-native python-urlgrabber-native yum-metadata-parser-native" | 8 | DEPENDS = "rpm-native python-native python-iniparse-native python-urlgrabber-native yum-metadata-parser-native" |
8 | 9 | ||