summaryrefslogtreecommitdiffstats
path: root/meta/packages/yum
diff options
context:
space:
mode:
authorKevin Tian <kevin.tian@intel.com>2010-08-11 13:34:54 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-12 15:39:24 +0100
commite101642a61fc418273c1cd4d58a9564b4bdecc5c (patch)
tree8890d90be0403bd1a9161f32ceb3d5cd1b7a27b5 /meta/packages/yum
parentcf1e754b3fee3c7ae907e7ae30233083d7892215 (diff)
downloadpoky-e101642a61fc418273c1cd4d58a9564b4bdecc5c.tar.gz
populate-volatile.sh: cleanup duplicated invocations and remove boot warning
For one, populate-volatile.sh is itself a rcS script which is invoked earlier than package's own postinst method (last one in rcS). If package has already installed their volatile files correctly, it doesn't make sense to update volatile again in postinst since nothing is changed. On the other hand, dbus/hal are special since their user/group are only created in the target. If they pre-install volatiles like others, populate-volatile.sh will report "undefined user" since at that time their user/group haven't been created. The better way solving this is to generate their volatile in the fly after user/group are created, and then update volatiles. This fix [BUGID #121] Signed-off-by: Kevin Tian <kevin.tian@intel.com>
Diffstat (limited to 'meta/packages/yum')
-rw-r--r--meta/packages/yum/yum_3.2.27.bb6
1 files changed, 1 insertions, 5 deletions
diff --git a/meta/packages/yum/yum_3.2.27.bb b/meta/packages/yum/yum_3.2.27.bb
index aff44ca6fe..acebc79dde 100644
--- a/meta/packages/yum/yum_3.2.27.bb
+++ b/meta/packages/yum/yum_3.2.27.bb
@@ -13,7 +13,7 @@ RDEPENDS = "python-rpm python-core python-iniparse python-urlgrabber \
13 python-textutils python-fcntl python-email \ 13 python-textutils python-fcntl python-email \
14 yum-metadata-parser" 14 yum-metadata-parser"
15 15
16PR = "r8" 16PR = "r9"
17 17
18SRC_URI = "http://yum.baseurl.org/download/3.2/yum-${PV}.tar.gz \ 18SRC_URI = "http://yum.baseurl.org/download/3.2/yum-${PV}.tar.gz \
19 file://paths.patch;apply=yes \ 19 file://paths.patch;apply=yes \
@@ -41,10 +41,6 @@ do_install_append () {
41 install -m 0644 ${WORKDIR}/98_yum ${D}/etc/default/volatiles 41 install -m 0644 ${WORKDIR}/98_yum ${D}/etc/default/volatiles
42} 42}
43 43
44pkg_postinst_yum () {
45 /etc/init.d/populate-volatile.sh update
46}
47
48FILES_${PN} += "${libdir}/python* ${datadir}/yum-cli" 44FILES_${PN} += "${libdir}/python* ${datadir}/yum-cli"
49 45
50BBCLASSEXTEND = "native" 46BBCLASSEXTEND = "native"