summaryrefslogtreecommitdiffstats
path: root/meta/packages/yum/files/paths.patch
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/packages/yum/files/paths.patch
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/yum/files/paths.patch')
-rw-r--r--meta/packages/yum/files/paths.patch106
1 files changed, 0 insertions, 106 deletions
diff --git a/meta/packages/yum/files/paths.patch b/meta/packages/yum/files/paths.patch
deleted file mode 100644
index 0175d05b34..0000000000
--- a/meta/packages/yum/files/paths.patch
+++ /dev/null
@@ -1,106 +0,0 @@
1---
2 Makefile | 18 +++++++++---------
3 docs/Makefile | 12 ++++++------
4 etc/Makefile | 20 ++++++++++----------
5 3 files changed, 25 insertions(+), 25 deletions(-)
6
7Index: yum-3.2.27/Makefile
8===================================================================
9--- yum-3.2.27.orig/Makefile 2010-03-04 01:10:20.000000000 +0000
10+++ yum-3.2.27/Makefile 2010-03-23 13:49:50.663912930 +0000
11@@ -22,19 +22,19 @@
12 for d in $(SUBDIRS); do make PYTHON=$(PYTHON) -C $$d; [ $$? = 0 ] || exit 1 ; done
13
14 install:
15- mkdir -p $(DESTDIR)/usr/share/yum-cli
16+ mkdir -p $(DESTDIR)$(datadir)/yum-cli
17 for p in $(PYFILES) ; do \
18- install -m 644 $$p $(DESTDIR)/usr/share/yum-cli/$$p; \
19+ install -m 644 $$p $(DESTDIR)$(datadir)/yum-cli/$$p; \
20 done
21- mv $(DESTDIR)/usr/share/yum-cli/yum-updatesd.py $(DESTDIR)/usr/share/yum-cli/yumupd.py
22- $(PYTHON) -c "import compileall; compileall.compile_dir('$(DESTDIR)/usr/share/yum-cli', 1, '$(PYDIR)', 1)"
23+ mv $(DESTDIR)$(datadir)/yum-cli/yum-updatesd.py $(DESTDIR)$(datadir)/yum-cli/yumupd.py
24+ $(PYTHON) -c "import compileall; compileall.compile_dir('$(DESTDIR)$(datadir)/yum-cli', 1, '$(PYDIR)', 1)"
25
26- mkdir -p $(DESTDIR)/usr/bin $(DESTDIR)/usr/sbin
27- install -m 755 bin/yum.py $(DESTDIR)/usr/bin/yum
28- install -m 755 bin/yum-updatesd.py $(DESTDIR)/usr/sbin/yum-updatesd
29+ mkdir -p $(DESTDIR)$(bindir) $(DESTDIR)$(sbindir)
30+ install -m 755 bin/yum.py $(DESTDIR)$(bindir)/yum
31+ install -m 755 bin/yum-updatesd.py $(DESTDIR)$(sbindir)/yum-updatesd
32
33- mkdir -p $(DESTDIR)/var/cache/yum
34- mkdir -p $(DESTDIR)/var/lib/yum
35+ mkdir -p $(DESTDIR)$(localstatedir)/cache/yum
36+ mkdir -p $(DESTDIR)$(localstatedir)/lib/yum
37
38 for d in $(SUBDIRS); do make PYTHON=$(PYTHON) DESTDIR=`cd $(DESTDIR); pwd` -C $$d install; [ $$? = 0 ] || exit 1; done
39
40Index: yum-3.2.27/docs/Makefile
41===================================================================
42--- yum-3.2.27.orig/docs/Makefile 2009-04-07 14:57:06.000000000 +0100
43+++ yum-3.2.27/docs/Makefile 2010-03-23 13:52:30.086667913 +0000
44@@ -6,10 +6,10 @@
45 rm -fr epydoc
46
47 install:
48- mkdir -p $(DESTDIR)/usr/share/man/man5
49- mkdir -p $(DESTDIR)/usr/share/man/man8
50- install -m 644 yum.8 $(DESTDIR)/usr/share/man/man8/yum.8
51- install -m 644 yum-shell.8 $(DESTDIR)/usr/share/man/man8/yum-shell.8
52- install -m 644 yum.conf.5 $(DESTDIR)/usr/share/man/man5/yum.conf.5
53- install -m 644 yum-updatesd.8 $(DESTDIR)/usr/share/man/man8/yum-updatesd.8
54- install -m 644 yum-updatesd.conf.5 $(DESTDIR)/usr/share/man/man5/yum-updatesd.conf.5
55+ mkdir -p $(DESTDIR)$(mandir)/man5
56+ mkdir -p $(DESTDIR)$(mandir)/man8
57+ install -m 644 yum.8 $(DESTDIR)$(mandir)/man8/yum.8
58+ install -m 644 yum-shell.8 $(DESTDIR)$(mandir)/man8/yum-shell.8
59+ install -m 644 yum.conf.5 $(DESTDIR)$(mandir)/man5/yum.conf.5
60+ install -m 644 yum-updatesd.8 $(DESTDIR)$(mandir)/man8/yum-updatesd.8
61+ install -m 644 yum-updatesd.conf.5 $(DESTDIR)$(mandir)/man5/yum-updatesd.conf.5
62Index: yum-3.2.27/etc/Makefile
63===================================================================
64--- yum-3.2.27.orig/etc/Makefile 2009-10-26 18:56:06.000000000 +0000
65+++ yum-3.2.27/etc/Makefile 2010-03-23 13:54:40.421912460 +0000
66@@ -1,4 +1,4 @@
67-YUMETC=$(DESTDIR)/etc/yum
68+YUMETC=$(DESTDIR)$(sysconfdir)/yum
69
70 all:
71 echo "Nothing to do"
72@@ -7,23 +7,23 @@
73 rm -f *.pyc *.pyo *~
74
75 install:
76- mkdir -p $(DESTDIR)/etc/yum/
77- mkdir -p $(DESTDIR)/etc/yum/repos.d
78+ mkdir -p $(DESTDIR)$(sysconfdir)/yum/
79+ mkdir -p $(DESTDIR)$(sysconfdir)/yum/repos.d
80
81 install -m 644 yum.conf $(YUMETC)/yum.conf
82
83 install -m 644 version-groups.conf $(YUMETC)/version-groups.conf
84
85- mkdir -p $(DESTDIR)/etc/logrotate.d
86- install -m 644 yum.logrotate $(DESTDIR)/etc/logrotate.d/yum
87+ mkdir -p $(DESTDIR)$(sysconfdir)/logrotate.d
88+ install -m 644 yum.logrotate $(DESTDIR)$(sysconfdir)/logrotate.d/yum
89
90- mkdir -p $(DESTDIR)/etc/rc.d/init.d
91- install -m 755 yum-updatesd.init $(DESTDIR)/etc/rc.d/init.d/yum-updatesd
92+ mkdir -p $(DESTDIR)$(sysconfdir)/rc.d/init.d
93+ install -m 755 yum-updatesd.init $(DESTDIR)$(sysconfdir)/rc.d/init.d/yum-updatesd
94
95- mkdir -p $(DESTDIR)/etc/dbus-1/system.d/
96- install -m 755 yum-updatesd-dbus.conf $(DESTDIR)/etc/dbus-1/system.d/yum-updatesd.conf
97+ mkdir -p $(DESTDIR)$(sysconfdir)/dbus-1/system.d/
98+ install -m 755 yum-updatesd-dbus.conf $(DESTDIR)$(sysconfdir)/dbus-1/system.d/yum-updatesd.conf
99
100- install -m 755 yum-updatesd.conf $(DESTDIR)/etc/yum/yum-updatesd.conf
101+ install -m 755 yum-updatesd.conf $(DESTDIR)$(sysconfdir)/yum/yum-updatesd.conf
102
103- mkdir -p $(DESTDIR)/etc/bash_completion.d
104- install -m 644 yum.bash $(DESTDIR)/etc/bash_completion.d
105+ mkdir -p $(DESTDIR)$(sysconfdir)/bash_completion.d
106+ install -m 644 yum.bash $(DESTDIR)$(sysconfdir)/bash_completion.d