diff options
author | Richard Purdie <richard@openedhand.com> | 2008-09-29 19:47:52 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2008-09-29 19:47:52 +0000 |
commit | 05107cfb6911b8bf7559d5e4da54f770d7790830 (patch) | |
tree | 50047df674a7a94ffebb26ab90c758543e6dc056 /meta/packages/xorg-xserver | |
parent | 897f19396598874fafe8ad9f966175b009b7deef (diff) | |
download | poky-05107cfb6911b8bf7559d5e4da54f770d7790830.tar.gz |
xserver-xf86-lite: Add a non-dri version of the server for use when dri/gl isn't appropriate
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5323 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/xorg-xserver')
5 files changed, 189 insertions, 0 deletions
diff --git a/meta/packages/xorg-xserver/xserver-xf86-lite.inc b/meta/packages/xorg-xserver/xserver-xf86-lite.inc new file mode 100644 index 0000000000..fe20d20c15 --- /dev/null +++ b/meta/packages/xorg-xserver/xserver-xf86-lite.inc | |||
@@ -0,0 +1,32 @@ | |||
1 | require xserver-xf86-common.inc | ||
2 | |||
3 | PROVIDES += "xserver-xf86-lite" | ||
4 | |||
5 | PROTO_DEPS = "randrproto renderproto fixesproto damageproto xextproto xproto xf86dgaproto xf86miscproto xf86rushproto xf86vidmodeproto xf86bigfontproto compositeproto recordproto resourceproto videoproto scrnsaverproto evieext trapproto xineramaproto fontsproto kbproto inputproto bigreqsproto xcmiscproto glproto" | ||
6 | |||
7 | LIB_DEPS = "pixman libxfont xtrans libxau libxext libxdmcp libdrm libxkbfile libpciaccess openssl" | ||
8 | |||
9 | DEPENDS = "${PROTO_DEPS} ${LIB_DEPS}" | ||
10 | |||
11 | RDEPENDS = "hal xorg-minimal-fonts" | ||
12 | |||
13 | FILES_${PN} += "${bindir}/Xorg " | ||
14 | |||
15 | EXTRA_OECONF += "--disable-cfb \ | ||
16 | --disable-afb \ | ||
17 | --disable-mfb \ | ||
18 | --disable-dga \ | ||
19 | --disable-xinerama \ | ||
20 | --disable-xf86misc \ | ||
21 | --disable-xorgcfg \ | ||
22 | --disable-dmx \ | ||
23 | --disable-xnest \ | ||
24 | --disable-xvfb \ | ||
25 | --enable-composite \ | ||
26 | --disable-dri \ | ||
27 | --disable-glx \ | ||
28 | --sysconfdir=/etc/X11 \ | ||
29 | --localstatedir=/var \ | ||
30 | --with-fontdir=/usr/share/fonts/X11 \ | ||
31 | --with-xkb-output=/var/lib/xkb \ | ||
32 | ac_cv_file__usr_share_sgml_X11_defs_ent=no" | ||
diff --git a/meta/packages/xorg-xserver/xserver-xf86-lite/drmfix.patch b/meta/packages/xorg-xserver/xserver-xf86-lite/drmfix.patch new file mode 100644 index 0000000000..a62a767f23 --- /dev/null +++ b/meta/packages/xorg-xserver/xserver-xf86-lite/drmfix.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | Index: xorg-server-1.4/hw/xfree86/os-support/linux/Makefile.am | ||
2 | =================================================================== | ||
3 | --- xorg-server-1.4.orig/hw/xfree86/os-support/linux/Makefile.am 2007-08-23 21:04:53.000000000 +0200 | ||
4 | +++ xorg-server-1.4/hw/xfree86/os-support/linux/Makefile.am 2008-03-13 18:27:23.000000000 +0100 | ||
5 | @@ -41,7 +41,7 @@ | ||
6 | |||
7 | AM_CFLAGS = -DUSESTDRES -DHAVE_SYSV_IPC $(DIX_CFLAGS) $(XORG_CFLAGS) $(PLATFORM_DEFINES) | ||
8 | |||
9 | -INCLUDES = $(XORG_INCS) $(PLATFORM_INCLUDES) -I/usr/include/drm # FIXME this last part is crack | ||
10 | +INCLUDES = $(XORG_INCS) $(PLATFORM_INCLUDES) $(LIBDRM_CFLAGS) | ||
11 | |||
12 | # FIXME: These need to be added to the build | ||
13 | LNX_EXTRA_SRCS = \ | ||
diff --git a/meta/packages/xorg-xserver/xserver-xf86-lite/libdri-xinerama-symbol.patch b/meta/packages/xorg-xserver/xserver-xf86-lite/libdri-xinerama-symbol.patch new file mode 100644 index 0000000000..db29da93ca --- /dev/null +++ b/meta/packages/xorg-xserver/xserver-xf86-lite/libdri-xinerama-symbol.patch | |||
@@ -0,0 +1,50 @@ | |||
1 | Index: xorg-server-1.5.0/hw/xfree86/dri/dri.c | ||
2 | =================================================================== | ||
3 | --- xorg-server-1.5.0.orig/hw/xfree86/dri/dri.c 2008-09-24 17:43:04.000000000 +0100 | ||
4 | +++ xorg-server-1.5.0/hw/xfree86/dri/dri.c 2008-09-24 17:46:38.000000000 +0100 | ||
5 | @@ -73,10 +73,6 @@ | ||
6 | |||
7 | #define PCI_BUS_NO_DOMAIN(bus) ((bus) & 0xffu) | ||
8 | |||
9 | -#if !defined(PANORAMIX) | ||
10 | -extern Bool noPanoramiXExtension; | ||
11 | -#endif | ||
12 | - | ||
13 | static int DRIEntPrivIndex = -1; | ||
14 | static DevPrivateKey DRIScreenPrivKey = &DRIScreenPrivKey; | ||
15 | static DevPrivateKey DRIWindowPrivKey = &DRIWindowPrivKey; | ||
16 | @@ -307,7 +303,6 @@ | ||
17 | drm_context_t * reserved; | ||
18 | int reserved_count; | ||
19 | int i; | ||
20 | - Bool xineramaInCore = FALSE; | ||
21 | DRIEntPrivPtr pDRIEntPriv; | ||
22 | ScrnInfoPtr pScrn = xf86Screens[pScreen->myNum]; | ||
23 | DRIContextFlags flags = 0; | ||
24 | @@ -320,20 +315,13 @@ | ||
25 | return FALSE; | ||
26 | } | ||
27 | |||
28 | - /* | ||
29 | - * If Xinerama is on, don't allow DRI to initialise. It won't be usable | ||
30 | - * anyway. | ||
31 | - */ | ||
32 | - if (xf86LoaderCheckSymbol("noPanoramiXExtension")) | ||
33 | - xineramaInCore = TRUE; | ||
34 | - | ||
35 | - if (xineramaInCore) { | ||
36 | - if (!noPanoramiXExtension) { | ||
37 | - DRIDrvMsg(pScreen->myNum, X_WARNING, | ||
38 | - "Direct rendering is not supported when Xinerama is enabled\n"); | ||
39 | - return FALSE; | ||
40 | - } | ||
41 | +#if defined(PANORAMIX) | ||
42 | + if (!noPanoramiXExtension) { | ||
43 | + DRIDrvMsg(pScreen->myNum, X_WARNING, | ||
44 | + "Direct rendering is not supported when Xinerama is enabled\n"); | ||
45 | + return FALSE; | ||
46 | } | ||
47 | +#endif | ||
48 | |||
49 | if (!DRIOpenDRMMaster(pScrn, pDRIInfo->SAREASize, | ||
50 | pDRIInfo->busIdString, | ||
diff --git a/meta/packages/xorg-xserver/xserver-xf86-lite/xorg.conf b/meta/packages/xorg-xserver/xserver-xf86-lite/xorg.conf new file mode 100644 index 0000000000..44a530e0f9 --- /dev/null +++ b/meta/packages/xorg-xserver/xserver-xf86-lite/xorg.conf | |||
@@ -0,0 +1,87 @@ | |||
1 | |||
2 | Section "Files" | ||
3 | EndSection | ||
4 | |||
5 | Section "InputDevice" | ||
6 | Identifier "Generic Keyboard" | ||
7 | Driver "kbd" | ||
8 | Option "CoreKeyboard" | ||
9 | Option "XkbRules" "xorg" | ||
10 | Option "XkbModel" "pc105" | ||
11 | Option "XkbLayout" "us" | ||
12 | EndSection | ||
13 | |||
14 | Section "InputDevice" | ||
15 | Identifier "Configured Mouse" | ||
16 | Driver "mouse" | ||
17 | Option "CorePointer" | ||
18 | Option "Device" "/dev/input/mice" | ||
19 | Option "Protocol" "ImPS/2" | ||
20 | Option "ZAxisMapping" "4 5" | ||
21 | Option "Emulate3Buttons" "true" | ||
22 | EndSection | ||
23 | |||
24 | Section "InputDevice" | ||
25 | Identifier "Synaptics Touchpad" | ||
26 | Driver "synaptics" | ||
27 | Option "SendCoreEvents" "true" | ||
28 | Option "Device" "/dev/psaux" | ||
29 | Option "Protocol" "auto-dev" | ||
30 | Option "HorizEdgeScroll" "0" | ||
31 | EndSection | ||
32 | |||
33 | Section "InputDevice" | ||
34 | Driver "wacom" | ||
35 | Identifier "stylus" | ||
36 | Option "Device" "/dev/input/wacom" | ||
37 | Option "Type" "stylus" | ||
38 | Option "ForceDevice" "ISDV4" # Tablet PC ONLY | ||
39 | EndSection | ||
40 | |||
41 | Section "InputDevice" | ||
42 | Driver "wacom" | ||
43 | Identifier "eraser" | ||
44 | Option "Device" "/dev/input/wacom" | ||
45 | Option "Type" "eraser" | ||
46 | Option "ForceDevice" "ISDV4" # Tablet PC ONLY | ||
47 | EndSection | ||
48 | |||
49 | Section "InputDevice" | ||
50 | Driver "wacom" | ||
51 | Identifier "cursor" | ||
52 | Option "Device" "/dev/input/wacom" | ||
53 | Option "Type" "cursor" | ||
54 | Option "ForceDevice" "ISDV4" # Tablet PC ONLY | ||
55 | EndSection | ||
56 | |||
57 | Section "Device" | ||
58 | Identifier "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller" | ||
59 | Driver "intel" | ||
60 | BusID "PCI:0:2:0" | ||
61 | EndSection | ||
62 | |||
63 | Section "Monitor" | ||
64 | Identifier "Generic Monitor" | ||
65 | Option "DPMS" | ||
66 | EndSection | ||
67 | |||
68 | Section "Screen" | ||
69 | Identifier "Default Screen" | ||
70 | Device "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller" | ||
71 | Monitor "Generic Monitor" | ||
72 | DefaultDepth 24 | ||
73 | EndSection | ||
74 | |||
75 | Section "ServerLayout" | ||
76 | Identifier "Default Layout" | ||
77 | Screen "Default Screen" | ||
78 | InputDevice "Generic Keyboard" | ||
79 | InputDevice "Configured Mouse" | ||
80 | |||
81 | # Uncomment if you have a wacom tablet | ||
82 | # InputDevice "stylus" "SendCoreEvents" | ||
83 | # InputDevice "cursor" "SendCoreEvents" | ||
84 | # InputDevice "eraser" "SendCoreEvents" | ||
85 | InputDevice "Synaptics Touchpad" | ||
86 | EndSection | ||
87 | |||
diff --git a/meta/packages/xorg-xserver/xserver-xf86-lite_1.5.0.bb b/meta/packages/xorg-xserver/xserver-xf86-lite_1.5.0.bb new file mode 100644 index 0000000000..d16e7b085d --- /dev/null +++ b/meta/packages/xorg-xserver/xserver-xf86-lite_1.5.0.bb | |||
@@ -0,0 +1,7 @@ | |||
1 | require xserver-xf86-lite.inc | ||
2 | |||
3 | PR = "r0" | ||
4 | |||
5 | SRC_URI += "file://drmfix.patch;patch=1 \ | ||
6 | file://libdri-xinerama-symbol.patch;patch=1 " | ||
7 | |||