summaryrefslogtreecommitdiffstats
path: root/meta/packages/xorg-xserver/xserver-xf86-dri-lite
diff options
context:
space:
mode:
authorRobert Bragg <bob@openedhand.com>2008-09-22 13:33:19 +0000
committerRobert Bragg <bob@openedhand.com>2008-09-22 13:33:19 +0000
commit3de4627417e62595ce4349cb3a13c9180f8e6bfd (patch)
tree37c5f48d49ce9702fb164ca4fe47433f59cd838a /meta/packages/xorg-xserver/xserver-xf86-dri-lite
parent9b6a24b65d840d8b207a9dfdc69e61b0c5c9ef07 (diff)
downloadpoky-3de4627417e62595ce4349cb3a13c9180f8e6bfd.tar.gz
Adds recipes to support building X servers based on the xfree86 DDX instead
of kdrive and building mesa. It's a big commit and it's still rather rough around the edges, but there is a desire to get this in early so people can review the work and help polish the changes. Some of the notable bits: • DRI support in mesa and the X server. (configured in machine conf via MACHINE_DRI_MODULES variable) • XCB backend for xlib • A fairly lite X server build with lots of legacy modules disabled. I'm sure there is plenty of other fairly low hanging fruit if we want to put more effort into reducing the size of the xserver build. Currently the server build comes in @ ~2.3MB vs a kdrive fbdev server build @ ~1MB. E.g xaa could be made conditional to save ~320K. Of course the kdrive server doesn't include glx stuff, which is a pretty big chunk. Also thanks to hrw, since I nabbed a some patches from him for this, and RP, for various bits of Poky style advice. git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5205 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/xorg-xserver/xserver-xf86-dri-lite')
-rw-r--r--meta/packages/xorg-xserver/xserver-xf86-dri-lite/drmfix.patch13
-rw-r--r--meta/packages/xorg-xserver/xserver-xf86-dri-lite/xorg.conf73
2 files changed, 86 insertions, 0 deletions
diff --git a/meta/packages/xorg-xserver/xserver-xf86-dri-lite/drmfix.patch b/meta/packages/xorg-xserver/xserver-xf86-dri-lite/drmfix.patch
new file mode 100644
index 0000000000..a62a767f23
--- /dev/null
+++ b/meta/packages/xorg-xserver/xserver-xf86-dri-lite/drmfix.patch
@@ -0,0 +1,13 @@
1Index: xorg-server-1.4/hw/xfree86/os-support/linux/Makefile.am
2===================================================================
3--- xorg-server-1.4.orig/hw/xfree86/os-support/linux/Makefile.am 2007-08-23 21:04:53.000000000 +0200
4+++ xorg-server-1.4/hw/xfree86/os-support/linux/Makefile.am 2008-03-13 18:27:23.000000000 +0100
5@@ -41,7 +41,7 @@
6
7 AM_CFLAGS = -DUSESTDRES -DHAVE_SYSV_IPC $(DIX_CFLAGS) $(XORG_CFLAGS) $(PLATFORM_DEFINES)
8
9-INCLUDES = $(XORG_INCS) $(PLATFORM_INCLUDES) -I/usr/include/drm # FIXME this last part is crack
10+INCLUDES = $(XORG_INCS) $(PLATFORM_INCLUDES) $(LIBDRM_CFLAGS)
11
12 # FIXME: These need to be added to the build
13 LNX_EXTRA_SRCS = \
diff --git a/meta/packages/xorg-xserver/xserver-xf86-dri-lite/xorg.conf b/meta/packages/xorg-xserver/xserver-xf86-dri-lite/xorg.conf
new file mode 100644
index 0000000000..e3ffbe6ed3
--- /dev/null
+++ b/meta/packages/xorg-xserver/xserver-xf86-dri-lite/xorg.conf
@@ -0,0 +1,73 @@
1
2Section "Files"
3EndSection
4
5Section "InputDevice"
6 Identifier "Synaptics Touchpad"
7 Driver "synaptics"
8 Option "SendCoreEvents" "true"
9 Option "Device" "/dev/psaux"
10 Option "Protocol" "auto-dev"
11 Option "HorizEdgeScroll" "0"
12EndSection
13
14Section "InputDevice"
15 Driver "wacom"
16 Identifier "stylus"
17 Option "Device" "/dev/input/wacom"
18 Option "Type" "stylus"
19 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
20EndSection
21
22Section "InputDevice"
23 Driver "wacom"
24 Identifier "eraser"
25 Option "Device" "/dev/input/wacom"
26 Option "Type" "eraser"
27 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
28EndSection
29
30Section "InputDevice"
31 Driver "wacom"
32 Identifier "cursor"
33 Option "Device" "/dev/input/wacom"
34 Option "Type" "cursor"
35 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
36EndSection
37
38Section "Device"
39 Identifier "Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller"
40 Driver "intel"
41 BusID "PCI:0:2:0"
42 Option "AccelMethod" "EXA"
43EndSection
44
45Section "Monitor"
46 Identifier "Generic Monitor"
47 Option "DPMS"
48EndSection
49
50Section "Screen"
51 Identifier "Default Screen"
52 Device "Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller"
53 Monitor "Generic Monitor"
54 DefaultDepth 24
55 SubSection "Display"
56 Modes "1024x768" "720x400" "640x480"
57 Virtual 3000 2048
58 EndSubSection
59EndSection
60
61Section "ServerLayout"
62 Identifier "Default Layout"
63 Screen "Default Screen"
64 InputDevice "Generic Keyboard"
65 InputDevice "Configured Mouse"
66
67# Uncomment if you have a wacom tablet
68# InputDevice "stylus" "SendCoreEvents"
69# InputDevice "cursor" "SendCoreEvents"
70# InputDevice "eraser" "SendCoreEvents"
71 InputDevice "Synaptics Touchpad"
72EndSection
73