summaryrefslogtreecommitdiffstats
path: root/meta/packages/xorg-util
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-01-15 15:27:11 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-01-15 15:27:11 +0000
commit29fd4733fdfe89d712bc555a63d85c2b15c5760f (patch)
treeae032cd573d5a4459526b56c3a91a0da309dd041 /meta/packages/xorg-util
parentb10b195b8ceabbb3f2ac1620ac4663792978b9ff (diff)
downloadpoky-29fd4733fdfe89d712bc555a63d85c2b15c5760f.tar.gz
util-macros: Add hack for the loss of the xaw.m4 file until xorg-apps are released which don't use it
Diffstat (limited to 'meta/packages/xorg-util')
-rw-r--r--meta/packages/xorg-util/util-macros/xaw.patch14
-rw-r--r--meta/packages/xorg-util/util-macros_1.2.1.bb5
2 files changed, 17 insertions, 2 deletions
diff --git a/meta/packages/xorg-util/util-macros/xaw.patch b/meta/packages/xorg-util/util-macros/xaw.patch
new file mode 100644
index 0000000000..8b39869cc1
--- /dev/null
+++ b/meta/packages/xorg-util/util-macros/xaw.patch
@@ -0,0 +1,14 @@
1Index: util-macros-1.2.1/xorg-macros.m4.in
2===================================================================
3--- util-macros-1.2.1.orig/xorg-macros.m4.in 2009-01-15 13:49:56.000000000 +0000
4+++ util-macros-1.2.1/xorg-macros.m4.in 2009-01-15 13:52:22.000000000 +0000
5@@ -456,3 +456,9 @@
6 fi
7 AC_SUBST(CWARNFLAGS)
8 ]) # XORG_CWARNFLAGS
9+
10+AC_DEFUN([XAW_CHECK_XPRINT_SUPPORT], [
11+PKG_CHECK_MODULES(TMP_XAW, xaw7)
12+$1_CFLAGS=$TMP_XAW_CFLAGS
13+$1_LIBS=$TMP_XAW_LIBS
14+])
diff --git a/meta/packages/xorg-util/util-macros_1.2.1.bb b/meta/packages/xorg-util/util-macros_1.2.1.bb
index 79288cd374..9616bd1d10 100644
--- a/meta/packages/xorg-util/util-macros_1.2.1.bb
+++ b/meta/packages/xorg-util/util-macros_1.2.1.bb
@@ -1,10 +1,11 @@
1require xorg-util-common.inc 1require xorg-util-common.inc
2 2
3DESCRIPTION = "X autotools macros" 3DESCRIPTION = "X autotools macros"
4PR = "r2" 4PR = "r5"
5PE = "1" 5PE = "1"
6 6
7SRC_URI += "file://unbreak_cross_compile.patch;patch=1" 7SRC_URI += "file://unbreak_cross_compile.patch;patch=1 \
8 file://xaw.patch;patch=1"
8 9
9# ${PN} is empty so we need to tweak -dev and -dbg package dependencies 10# ${PN} is empty so we need to tweak -dev and -dbg package dependencies
10RDEPENDS_${PN}-dev = "" 11RDEPENDS_${PN}-dev = ""