diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2009-11-26 09:17:08 +0000 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2009-11-26 09:17:08 +0000 |
commit | f0d2b379895a0def1c9fecbcaa5ce172017227ec (patch) | |
tree | c8eee37cd0dd40e386773bdabb22d7c3ea58ff77 /meta/packages/xorg-lib | |
parent | f721f7bc34b9b7977f87d9f41a353e4f80b4436d (diff) | |
download | poky-f0d2b379895a0def1c9fecbcaa5ce172017227ec.tar.gz |
libxcalibrate: Fix with xcb
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/xorg-lib')
-rw-r--r-- | meta/packages/xorg-lib/libxcalibrate/fix-xcb.patch | 27 | ||||
-rw-r--r-- | meta/packages/xorg-lib/libxcalibrate_git.bb | 4 |
2 files changed, 30 insertions, 1 deletions
diff --git a/meta/packages/xorg-lib/libxcalibrate/fix-xcb.patch b/meta/packages/xorg-lib/libxcalibrate/fix-xcb.patch new file mode 100644 index 0000000000..0d7efc70f3 --- /dev/null +++ b/meta/packages/xorg-lib/libxcalibrate/fix-xcb.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | There is no extra reply data and if we say not to disgard it, xcb | ||
2 | throws fatal asserts. | ||
3 | |||
4 | RP - 26/11/09 | ||
5 | |||
6 | Index: git/xcalibrate.c | ||
7 | =================================================================== | ||
8 | --- git.orig/xcalibrate.c 2009-11-26 08:11:48.000000000 +0000 | ||
9 | +++ git/xcalibrate.c 2009-11-26 08:09:55.000000000 +0000 | ||
10 | @@ -216,7 +216,7 @@ | ||
11 | req->reqType = info->codes->major_opcode; | ||
12 | req->xCalibrateReqType = X_XCalibrateRawMode; | ||
13 | req->on = enable; | ||
14 | - if (!_XReply (dpy, (xReply *) &rep, 0, xFalse)) | ||
15 | + if (!_XReply (dpy, (xReply *) &rep, 0, xTrue)) | ||
16 | { | ||
17 | UnlockDisplay (dpy); | ||
18 | SyncHandle (); | ||
19 | @@ -240,7 +240,7 @@ | ||
20 | req->xCalibrateReqType = X_XCalibrateScreenToCoord; | ||
21 | req->x = *x; | ||
22 | req->y = *y; | ||
23 | - if (!_XReply (dpy, (xReply *) &rep, 0, xFalse)) | ||
24 | + if (!_XReply (dpy, (xReply *) &rep, 0, xTrue)) | ||
25 | { | ||
26 | UnlockDisplay (dpy); | ||
27 | SyncHandle (); | ||
diff --git a/meta/packages/xorg-lib/libxcalibrate_git.bb b/meta/packages/xorg-lib/libxcalibrate_git.bb index 000004114d..2815520b03 100644 --- a/meta/packages/xorg-lib/libxcalibrate_git.bb +++ b/meta/packages/xorg-lib/libxcalibrate_git.bb | |||
@@ -4,8 +4,10 @@ DESCRIPTION = " Touchscreen calibration client library" | |||
4 | LICENSE = "BSD-X" | 4 | LICENSE = "BSD-X" |
5 | DEPENDS = "virtual/libx11 calibrateproto libxext" | 5 | DEPENDS = "virtual/libx11 calibrateproto libxext" |
6 | PV = "0.0+git${SRCPV}" | 6 | PV = "0.0+git${SRCPV}" |
7 | PR = "r1" | ||
7 | 8 | ||
8 | SRC_URI = "git://anongit.freedesktop.org/git/xorg/lib/libXCalibrate;protocol=git" | 9 | SRC_URI = "git://anongit.freedesktop.org/git/xorg/lib/libXCalibrate;protocol=git \ |
10 | file://fix-xcb.patch;patch=1" | ||
9 | 11 | ||
10 | S = "${WORKDIR}/git" | 12 | S = "${WORKDIR}/git" |
11 | 13 | ||