diff options
author | Ross Burton <ross@openedhand.com> | 2008-02-11 21:11:02 +0000 |
---|---|---|
committer | Ross Burton <ross@openedhand.com> | 2008-02-11 21:11:02 +0000 |
commit | de8dfb8bbad0af17b796e64d51ca48e661fa6856 (patch) | |
tree | d01d2b1d423f7bbe658c8f832efd198e7ccfd552 /meta/packages/xorg-lib | |
parent | d7753c6d471561cd20ee99ff8445b3c0adb90d6a (diff) | |
download | poky-de8dfb8bbad0af17b796e64d51ca48e661fa6856.tar.gz |
libxcalibrate: fix package versions, and update to latest git which has our patches merged
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3764 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/xorg-lib')
-rw-r--r-- | meta/packages/xorg-lib/libxcalibrate/coords.patch | 50 | ||||
-rw-r--r-- | meta/packages/xorg-lib/libxcalibrate_git.bb | 4 |
2 files changed, 1 insertions, 53 deletions
diff --git a/meta/packages/xorg-lib/libxcalibrate/coords.patch b/meta/packages/xorg-lib/libxcalibrate/coords.patch deleted file mode 100644 index 19cf1639f6..0000000000 --- a/meta/packages/xorg-lib/libxcalibrate/coords.patch +++ /dev/null | |||
@@ -1,50 +0,0 @@ | |||
1 | --- | ||
2 | xcalibrate.c | 26 ++++++++++++++++++++++++++ | ||
3 | xcalibrate.h | 2 ++ | ||
4 | 2 files changed, 28 insertions(+) | ||
5 | |||
6 | Index: XCalibrate/xcalibrate.c | ||
7 | =================================================================== | ||
8 | --- XCalibrate.orig/xcalibrate.c 2007-06-30 14:12:22.000000000 +0100 | ||
9 | +++ XCalibrate/xcalibrate.c 2007-06-30 14:18:10.000000000 +0100 | ||
10 | @@ -227,3 +227,29 @@ XCalibrateSetRawMode (Display *dpy, Bool | ||
11 | SyncHandle (); | ||
12 | return 0; | ||
13 | } | ||
14 | + | ||
15 | +Status | ||
16 | +XCalibrateScreenToCoord (Display *dpy, int *x, int *y) | ||
17 | +{ | ||
18 | + XExtDisplayInfo *info = XCalibrateFindDisplay (dpy); | ||
19 | + xXCalibrateScreenToCoordReq *req; | ||
20 | + xXCalibrateScreenToCoordReply rep; | ||
21 | + LockDisplay (dpy); | ||
22 | + GetReq (XCalibrateScreenToCoord, req); | ||
23 | + req->reqType = info->codes->major_opcode; | ||
24 | + req->xCalibrateReqType = X_XCalibrateScreenToCoord; | ||
25 | + req->x = *x; | ||
26 | + req->y = *y; | ||
27 | + if (!_XReply (dpy, (xReply *) &rep, 0, xFalse)) | ||
28 | + { | ||
29 | + UnlockDisplay (dpy); | ||
30 | + SyncHandle (); | ||
31 | + return 1; | ||
32 | + } | ||
33 | + *x = rep.x; | ||
34 | + *y = rep.y; | ||
35 | + UnlockDisplay (dpy); | ||
36 | + SyncHandle (); | ||
37 | + return 0; | ||
38 | +} | ||
39 | + | ||
40 | Index: XCalibrate/xcalibrate.h | ||
41 | =================================================================== | ||
42 | --- XCalibrate.orig/xcalibrate.h 2007-06-30 14:16:16.000000000 +0100 | ||
43 | +++ XCalibrate/xcalibrate.h 2007-06-30 14:16:38.000000000 +0100 | ||
44 | @@ -43,4 +43,6 @@ Status XCalibrateQueryVersion (Display * | ||
45 | |||
46 | Status XCalibrateSetRawMode (Display *dpy, Bool enable); | ||
47 | |||
48 | +Status XCalibrateScreenToCoord (Display *dpy, int *x, int *y); | ||
49 | + | ||
50 | #endif | ||
diff --git a/meta/packages/xorg-lib/libxcalibrate_git.bb b/meta/packages/xorg-lib/libxcalibrate_git.bb index 7ddc831d3f..24b4a1f067 100644 --- a/meta/packages/xorg-lib/libxcalibrate_git.bb +++ b/meta/packages/xorg-lib/libxcalibrate_git.bb | |||
@@ -4,10 +4,8 @@ DESCRIPTION = " Touchscreen calibration client library" | |||
4 | LICENSE = "BSD-X" | 4 | LICENSE = "BSD-X" |
5 | DEPENDS = "virtual/libx11 calibrateproto libxext" | 5 | DEPENDS = "virtual/libx11 calibrateproto libxext" |
6 | PV = "0.0+git${SRCREV}" | 6 | PV = "0.0+git${SRCREV}" |
7 | PR = "r3" | ||
8 | 7 | ||
9 | SRC_URI = "git://anongit.freedesktop.org/git/xorg/lib/libXCalibrate;protocol=git;tag=${SRCREV} \ | 8 | SRC_URI = "git://anongit.freedesktop.org/git/xorg/lib/libXCalibrate;protocol=git" |
10 | file://coords.patch;patch=1" | ||
11 | 9 | ||
12 | S = "${WORKDIR}/git" | 10 | S = "${WORKDIR}/git" |
13 | 11 | ||