diff options
author | Richard Purdie <richard@openedhand.com> | 2008-01-02 15:15:36 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2008-01-02 15:15:36 +0000 |
commit | f8b1fd4926f7dcba35d4e074225ba186b25e8f0d (patch) | |
tree | 3e3a89a2e36deefed898bd2afd831f472c8c7792 /meta/packages/xorg-lib | |
parent | 7eed7c05fdb54e30976eb6599637786e2260f432 (diff) | |
download | poky-f8b1fd4926f7dcba35d4e074225ba186b25e8f0d.tar.gz |
libx11/diet-x11: Fix /usr/include problem for keysymdef.h
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3398 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/xorg-lib')
-rw-r--r-- | meta/packages/xorg-lib/diet-x11/include_fix.patch | 62 | ||||
-rw-r--r-- | meta/packages/xorg-lib/diet-x11_1.1.2.bb | 4 | ||||
-rw-r--r-- | meta/packages/xorg-lib/libx11_1.1.2.bb | 6 |
3 files changed, 67 insertions, 5 deletions
diff --git a/meta/packages/xorg-lib/diet-x11/include_fix.patch b/meta/packages/xorg-lib/diet-x11/include_fix.patch new file mode 100644 index 0000000000..565308834e --- /dev/null +++ b/meta/packages/xorg-lib/diet-x11/include_fix.patch | |||
@@ -0,0 +1,62 @@ | |||
1 | --- | ||
2 | configure.ac | 44 ++++++++++++++++++++++++-------------------- | ||
3 | 1 file changed, 24 insertions(+), 20 deletions(-) | ||
4 | |||
5 | Index: libX11-1.1.2/configure.ac | ||
6 | =================================================================== | ||
7 | --- libX11-1.1.2.orig/configure.ac 2008-01-02 15:30:47.000000000 +0000 | ||
8 | +++ libX11-1.1.2/configure.ac 2008-01-02 15:47:25.000000000 +0000 | ||
9 | @@ -207,29 +207,33 @@ AC_CHECK_FUNC(poll, [AC_DEFINE(USE_POLL, | ||
10 | # | ||
11 | KEYSYMDEF="" | ||
12 | AC_MSG_CHECKING([keysymdef.h]) | ||
13 | -for flag in $XPROTO_CFLAGS -I/usr/include; do | ||
14 | - case "$KEYSYMDEF" in | ||
15 | - "") | ||
16 | - case "$flag" in | ||
17 | - *-I*) | ||
18 | - dir=`echo "$flag" | sed 's/ *-I//'` | ||
19 | - file="$dir/X11/keysymdef.h" | ||
20 | - if test -f "$file"; then | ||
21 | - KEYSYMDEF="$file" | ||
22 | - fi | ||
23 | +AC_ARG_WITH(keysymdef, | ||
24 | + AC_HELP_STRING([--with-keysymdef=DIR/keysymdef.h], [The location of keysymdef.h]), | ||
25 | + KEYSYMDEF=$withval, KEYSYMDEF="") | ||
26 | + | ||
27 | +if test x$KEYSYMDEF = x; then | ||
28 | + for flag in $XPROTO_CFLAGS -I/usr/include; do | ||
29 | + case "$KEYSYMDEF" in | ||
30 | + "") | ||
31 | + case "$flag" in | ||
32 | + *-I*) | ||
33 | + dir=`echo "$flag" | sed 's/ *-I//'` | ||
34 | + file="$dir/X11/keysymdef.h" | ||
35 | + if test -f "$file"; then | ||
36 | + KEYSYMDEF="$file" | ||
37 | + fi | ||
38 | + ;; | ||
39 | + esac | ||
40 | ;; | ||
41 | esac | ||
42 | - ;; | ||
43 | - esac | ||
44 | -done | ||
45 | -case "$KEYSYMDEF" in | ||
46 | -"") | ||
47 | - AC_MSG_ERROR([Cannot find keysymdef.h]) | ||
48 | - ;; | ||
49 | -*) | ||
50 | + done | ||
51 | +fi | ||
52 | + | ||
53 | +if test -f "$KEYSYMDEF"; then | ||
54 | AC_MSG_RESULT([$KEYSYMDEF]) | ||
55 | - ;; | ||
56 | -esac | ||
57 | +else | ||
58 | + AC_MSG_ERROR([Cannot find keysymdef.h]) | ||
59 | +fi | ||
60 | AC_SUBST(KEYSYMDEF) | ||
61 | |||
62 | AC_ARG_ENABLE(udc, | ||
diff --git a/meta/packages/xorg-lib/diet-x11_1.1.2.bb b/meta/packages/xorg-lib/diet-x11_1.1.2.bb index f032987b88..9f1e877ab8 100644 --- a/meta/packages/xorg-lib/diet-x11_1.1.2.bb +++ b/meta/packages/xorg-lib/diet-x11_1.1.2.bb | |||
@@ -1,8 +1,8 @@ | |||
1 | require libx11_${PV}.bb | 1 | require libx11_${PV}.bb |
2 | 2 | ||
3 | SRC_URI += "file://X18NCMSstubs.diff;patch=1 \ | 3 | SRC_URI += "file://X18NCMSstubs.diff;patch=1 \ |
4 | file://fix-disable-xlocale.diff;patch=1 \ | 4 | file://fix-disable-xlocale.diff;patch=1 \ |
5 | file://fix-utf8-wrong-define.patch;patch=1" | 5 | file://fix-utf8-wrong-define.patch;patch=1" |
6 | 6 | ||
7 | EXTRA_OECONF += "--disable-udc --disable-xcms --disable-xlocale --disable-xkb" | 7 | EXTRA_OECONF += "--disable-udc --disable-xcms --disable-xlocale --disable-xkb --with-keysymdef=${STAGING_INCDIR}/X11/keysymdef.h" |
8 | CFLAGS += "-D_GNU_SOURCE" | 8 | CFLAGS += "-D_GNU_SOURCE" |
diff --git a/meta/packages/xorg-lib/libx11_1.1.2.bb b/meta/packages/xorg-lib/libx11_1.1.2.bb index 93ad71f466..a4400ae88e 100644 --- a/meta/packages/xorg-lib/libx11_1.1.2.bb +++ b/meta/packages/xorg-lib/libx11_1.1.2.bb | |||
@@ -5,12 +5,12 @@ DEPENDS += "bigreqsproto xproto xextproto xtrans libxau xcmiscproto \ | |||
5 | libxdmcp xf86bigfontproto kbproto inputproto" | 5 | libxdmcp xf86bigfontproto kbproto inputproto" |
6 | PROVIDES = "virtual/libx11" | 6 | PROVIDES = "virtual/libx11" |
7 | PE = "1" | 7 | PE = "1" |
8 | PR = "r2" | 8 | PR = "r3" |
9 | 9 | ||
10 | XORG_PN = "libX11" | 10 | XORG_PN = "libX11" |
11 | 11 | ||
12 | SRC_URI += "file://x11_disable_makekeys.patch;patch=1" | 12 | SRC_URI += "file://x11_disable_makekeys.patch;patch=1 \ |
13 | 13 | file://include_fix.patch;patch=1" | |
14 | 14 | ||
15 | EXTRA_OECONF += "--without-xcb" | 15 | EXTRA_OECONF += "--without-xcb" |
16 | 16 | ||