diff options
author | Chris Larson <kergoth@openedhand.com> | 2006-08-15 11:58:37 +0000 |
---|---|---|
committer | Chris Larson <kergoth@openedhand.com> | 2006-08-15 11:58:37 +0000 |
commit | ca10363baac7de9581ec90ab47957f973e1dbdc4 (patch) | |
tree | 2000b53f806c79510671d8fd1a6a36125f8b25b3 /meta/packages/xorg-lib/libxfont | |
parent | c210d01a7ca8c00ddc45d292878b89086b137129 (diff) | |
download | poky-ca10363baac7de9581ec90ab47957f973e1dbdc4.tar.gz |
Numerous new xorg package versions from upstream OE. Pester me if any local changes got inadvertantly lost, or if any packages need upgrading.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@607 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/xorg-lib/libxfont')
-rw-r--r-- | meta/packages/xorg-lib/libxfont/autofoo.patch | 18 | ||||
-rw-r--r-- | meta/packages/xorg-lib/libxfont/no-scalable-crash.patch | 22 | ||||
-rw-r--r-- | meta/packages/xorg-lib/libxfont/scalable.patch | 27 |
3 files changed, 67 insertions, 0 deletions
diff --git a/meta/packages/xorg-lib/libxfont/autofoo.patch b/meta/packages/xorg-lib/libxfont/autofoo.patch new file mode 100644 index 0000000000..4998625c24 --- /dev/null +++ b/meta/packages/xorg-lib/libxfont/autofoo.patch | |||
@@ -0,0 +1,18 @@ | |||
1 | |||
2 | # | ||
3 | # Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher | ||
4 | # | ||
5 | |||
6 | --- libXfont-1.4.2/configure.ac~autofoo 2004-05-06 20:19:03.000000000 -0400 | ||
7 | +++ libXfont-1.4.2/configure.ac 2005-01-16 12:14:14.042598720 -0500 | ||
8 | @@ -35,9 +35,9 @@ | ||
9 | dnl Yes, it is a pain to synchronize version numbers. Unfortunately, it's | ||
10 | dnl not possible to extract the version number here from Xfont.h | ||
11 | dnl | ||
12 | +AC_CONFIG_AUX_DIR(.) | ||
13 | AM_INIT_AUTOMAKE([dist-bzip2]) | ||
14 | AM_CONFIG_HEADER(config.h) | ||
15 | -AC_CONFIG_AUX_DIR(.) | ||
16 | AC_CONFIG_HEADERS([include/X11/fonts/fontconf.h]) | ||
17 | |||
18 | # Check for progs | ||
diff --git a/meta/packages/xorg-lib/libxfont/no-scalable-crash.patch b/meta/packages/xorg-lib/libxfont/no-scalable-crash.patch new file mode 100644 index 0000000000..90bded6fba --- /dev/null +++ b/meta/packages/xorg-lib/libxfont/no-scalable-crash.patch | |||
@@ -0,0 +1,22 @@ | |||
1 | --- /tmp/fontdir.c 2006-08-01 16:17:22.000000000 +0200 | ||
2 | +++ libXfont-1.2.0/src/fontfile/fontdir.c 2006-08-01 16:20:37.248306000 +0200 | ||
3 | @@ -695,6 +695,11 @@ | ||
4 | */ | ||
5 | if (isscale) | ||
6 | { | ||
7 | + /* If the fontname says it is scalable, make sure that the | ||
8 | + * renderer supports OpenScalable and GetInfoScalable. | ||
9 | + */ | ||
10 | + if (renderer->OpenScalable && renderer->GetInfoScalable) | ||
11 | + { | ||
12 | if (vals.values_supplied & SIZE_SPECIFY_MASK) | ||
13 | { | ||
14 | bzero((char *)&zeroVals, sizeof(zeroVals)); | ||
15 | @@ -794,6 +799,7 @@ | ||
16 | bitmap->name.name); | ||
17 | } | ||
18 | } | ||
19 | + } | ||
20 | } | ||
21 | return TRUE; | ||
22 | } | ||
diff --git a/meta/packages/xorg-lib/libxfont/scalable.patch b/meta/packages/xorg-lib/libxfont/scalable.patch new file mode 100644 index 0000000000..7f97b9a8f6 --- /dev/null +++ b/meta/packages/xorg-lib/libxfont/scalable.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | Index: fontfile/fontdir.c | ||
2 | =================================================================== | ||
3 | RCS file: /cvs/xlibs/Xfont/fontfile/fontdir.c,v | ||
4 | retrieving revision 3.22 | ||
5 | diff -u -r3.22 fontdir.c | ||
6 | --- xfont/fontfile/fontdir.c 7 Jul 2003 16:40:11 -0000 3.22 | ||
7 | +++ xfont/fontfile/fontdir.c 30 Dec 2004 20:37:12 -0000 | ||
8 | @@ -699,6 +699,11 @@ | ||
9 | */ | ||
10 | if (isscale) | ||
11 | { | ||
12 | + /* If the fontname says it is scalable, make sure that the | ||
13 | + * renderer supports OpenScalable and GetInfoScalable. | ||
14 | + */ | ||
15 | + if (renderer->OpenScalable && renderer->GetInfoScalable) | ||
16 | + { | ||
17 | if (vals.values_supplied & SIZE_SPECIFY_MASK) | ||
18 | { | ||
19 | bzero((char *)&zeroVals, sizeof(zeroVals)); | ||
20 | @@ -798,6 +803,7 @@ | ||
21 | bitmap->name.name); | ||
22 | } | ||
23 | } | ||
24 | + } | ||
25 | } | ||
26 | return TRUE; | ||
27 | } | ||