summaryrefslogtreecommitdiffstats
path: root/meta/packages/xorg-app
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-03-28 15:32:15 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-03-28 15:32:15 +0000
commit270f331d1bba0651ec1500330fea7212f7ce7227 (patch)
tree0232077187e61d51afd06551bc16a71bd5ca9529 /meta/packages/xorg-app
parent74abe03003bda1dc08b1ab0a4f03394940a85238 (diff)
downloadpoky-270f331d1bba0651ec1500330fea7212f7ce7227.tar.gz
xev: upgraded to 1.0.3
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4133 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/xorg-app')
-rw-r--r--meta/packages/xorg-app/xev-1.0.2/diet-x11.patch80
-rw-r--r--meta/packages/xorg-app/xev/diet-x11.patch38
-rw-r--r--meta/packages/xorg-app/xev_1.0.3.bb (renamed from meta/packages/xorg-app/xev_1.0.2.bb)0
3 files changed, 22 insertions, 96 deletions
diff --git a/meta/packages/xorg-app/xev-1.0.2/diet-x11.patch b/meta/packages/xorg-app/xev-1.0.2/diet-x11.patch
deleted file mode 100644
index 9f515e8c73..0000000000
--- a/meta/packages/xorg-app/xev-1.0.2/diet-x11.patch
+++ /dev/null
@@ -1,80 +0,0 @@
1---
2 xev.c | 16 ++++++++--------
3 1 file changed, 8 insertions(+), 8 deletions(-)
4
5Index: xev-1.0.2/xev.c
6===================================================================
7--- xev-1.0.2.orig/xev.c 2006-06-02 00:25:44.000000000 +0100
8+++ xev-1.0.2/xev.c 2007-05-10 15:22:07.000000000 +0100
9@@ -109,7 +109,7 @@ do_KeyPress (XEvent *eventp)
10 nbytes = XLookupString (e, str, 256, &ks, NULL);
11
12 /* not supposed to call XmbLookupString on a key release event */
13- if (e->type == KeyPress && xic) {
14+ /*if (e->type == KeyPress && xic) {
15 do {
16 nmbbytes = XmbLookupString (xic, e, buf, bsize - 1, &ks, &status);
17 buf[nmbbytes] = '\0';
18@@ -119,7 +119,7 @@ do_KeyPress (XEvent *eventp)
19 buf = realloc (buf, bsize);
20 }
21 } while (status == XBufferOverflow);
22- }
23+ }*/
24
25 if (ks == NoSymbol)
26 ksname = "NoSymbol";
27@@ -149,7 +149,7 @@ do_KeyPress (XEvent *eventp)
28 }
29
30 /* not supposed to call XmbLookupString on a key release event */
31- if (e->type == KeyPress && xic) {
32+ /*if (e->type == KeyPress && xic) {
33 printf (" XmbLookupString gives %d bytes: ", nmbbytes);
34 if (nmbbytes > 0) {
35 dump (buf, nmbbytes);
36@@ -157,7 +157,7 @@ do_KeyPress (XEvent *eventp)
37 } else {
38 printf ("\n");
39 }
40- }
41+ } */
42
43 printf (" XFilterEvent returns: %s\n",
44 XFilterEvent (eventp, e->window) ? "True" : "False");
45@@ -804,7 +804,7 @@ main (int argc, char **argv)
46 fprintf (stderr, "%s: XSetLocaleModifiers failed\n", ProgramName);
47 }
48
49- xim = XOpenIM (dpy, NULL, NULL, NULL);
50+ /*xim = XOpenIM (dpy, NULL, NULL, NULL);
51 if (xim == NULL) {
52 fprintf (stderr, "%s: XOpenIM failed\n", ProgramName);
53 }
54@@ -831,7 +831,7 @@ main (int argc, char **argv)
55 }
56 XFree (xim_styles);
57 }
58- }
59+ }*/
60
61 screen = DefaultScreen (dpy);
62
63@@ -891,7 +891,7 @@ main (int argc, char **argv)
64 printf ("Outer window is 0x%lx, inner window is 0x%lx\n", w, subw);
65 }
66
67- if (xim && xim_style) {
68+ /*if (xim && xim_style) {
69 xic = XCreateIC (xim,
70 XNInputStyle, xim_style,
71 XNClientWindow, w,
72@@ -901,7 +901,7 @@ main (int argc, char **argv)
73 if (xic == NULL) {
74 fprintf (stderr, "XCreateIC failed\n");
75 }
76- }
77+ }*/
78
79 for (done = 0; !done; ) {
80 XEvent event;
diff --git a/meta/packages/xorg-app/xev/diet-x11.patch b/meta/packages/xorg-app/xev/diet-x11.patch
index 7e93f160a5..9f515e8c73 100644
--- a/meta/packages/xorg-app/xev/diet-x11.patch
+++ b/meta/packages/xorg-app/xev/diet-x11.patch
@@ -1,6 +1,12 @@
1--- xev/xev.c 2004-02-06 11:00:37.000000000 -0800 1---
2+++ xev/xev.new.c 2005-08-04 15:40:36.000000000 -0700 2 xev.c | 16 ++++++++--------
3@@ -149,7 +149,7 @@ 3 1 file changed, 8 insertions(+), 8 deletions(-)
4
5Index: xev-1.0.2/xev.c
6===================================================================
7--- xev-1.0.2.orig/xev.c 2006-06-02 00:25:44.000000000 +0100
8+++ xev-1.0.2/xev.c 2007-05-10 15:22:07.000000000 +0100
9@@ -109,7 +109,7 @@ do_KeyPress (XEvent *eventp)
4 nbytes = XLookupString (e, str, 256, &ks, NULL); 10 nbytes = XLookupString (e, str, 256, &ks, NULL);
5 11
6 /* not supposed to call XmbLookupString on a key release event */ 12 /* not supposed to call XmbLookupString on a key release event */
@@ -9,7 +15,7 @@
9 do { 15 do {
10 nmbbytes = XmbLookupString (xic, e, buf, bsize - 1, &ks, &status); 16 nmbbytes = XmbLookupString (xic, e, buf, bsize - 1, &ks, &status);
11 buf[nmbbytes] = '\0'; 17 buf[nmbbytes] = '\0';
12@@ -159,7 +159,7 @@ 18@@ -119,7 +119,7 @@ do_KeyPress (XEvent *eventp)
13 buf = realloc (buf, bsize); 19 buf = realloc (buf, bsize);
14 } 20 }
15 } while (status == XBufferOverflow); 21 } while (status == XBufferOverflow);
@@ -18,7 +24,7 @@
18 24
19 if (ks == NoSymbol) 25 if (ks == NoSymbol)
20 ksname = "NoSymbol"; 26 ksname = "NoSymbol";
21@@ -189,7 +189,7 @@ 27@@ -149,7 +149,7 @@ do_KeyPress (XEvent *eventp)
22 } 28 }
23 29
24 /* not supposed to call XmbLookupString on a key release event */ 30 /* not supposed to call XmbLookupString on a key release event */
@@ -27,16 +33,16 @@
27 printf (" XmbLookupString gives %d bytes: ", nmbbytes); 33 printf (" XmbLookupString gives %d bytes: ", nmbbytes);
28 if (nmbbytes > 0) { 34 if (nmbbytes > 0) {
29 dump (buf, nmbbytes); 35 dump (buf, nmbbytes);
30@@ -200,7 +200,7 @@ 36@@ -157,7 +157,7 @@ do_KeyPress (XEvent *eventp)
31 37 } else {
32 printf (" XFilterEvent returns: %s\n", 38 printf ("\n");
33 XFilterEvent (eventp, e->window) ? "True" : "False"); 39 }
34- } 40- }
35+ }*/ 41+ } */
36 }
37 42
38 static void 43 printf (" XFilterEvent returns: %s\n",
39@@ -857,7 +857,7 @@ 44 XFilterEvent (eventp, e->window) ? "True" : "False");
45@@ -804,7 +804,7 @@ main (int argc, char **argv)
40 fprintf (stderr, "%s: XSetLocaleModifiers failed\n", ProgramName); 46 fprintf (stderr, "%s: XSetLocaleModifiers failed\n", ProgramName);
41 } 47 }
42 48
@@ -45,7 +51,7 @@
45 if (xim == NULL) { 51 if (xim == NULL) {
46 fprintf (stderr, "%s: XOpenIM failed\n", ProgramName); 52 fprintf (stderr, "%s: XOpenIM failed\n", ProgramName);
47 } 53 }
48@@ -884,7 +884,7 @@ 54@@ -831,7 +831,7 @@ main (int argc, char **argv)
49 } 55 }
50 XFree (xim_styles); 56 XFree (xim_styles);
51 } 57 }
@@ -54,7 +60,7 @@
54 60
55 screen = DefaultScreen (dpy); 61 screen = DefaultScreen (dpy);
56 62
57@@ -948,7 +948,7 @@ 63@@ -891,7 +891,7 @@ main (int argc, char **argv)
58 printf ("Outer window is 0x%lx, inner window is 0x%lx\n", w, subw); 64 printf ("Outer window is 0x%lx, inner window is 0x%lx\n", w, subw);
59 } 65 }
60 66
@@ -63,7 +69,7 @@
63 xic = XCreateIC (xim, 69 xic = XCreateIC (xim,
64 XNInputStyle, xim_style, 70 XNInputStyle, xim_style,
65 XNClientWindow, w, 71 XNClientWindow, w,
66@@ -958,7 +958,7 @@ 72@@ -901,7 +901,7 @@ main (int argc, char **argv)
67 if (xic == NULL) { 73 if (xic == NULL) {
68 fprintf (stderr, "XCreateIC failed\n"); 74 fprintf (stderr, "XCreateIC failed\n");
69 } 75 }
diff --git a/meta/packages/xorg-app/xev_1.0.2.bb b/meta/packages/xorg-app/xev_1.0.3.bb
index b7a4070a8f..b7a4070a8f 100644
--- a/meta/packages/xorg-app/xev_1.0.2.bb
+++ b/meta/packages/xorg-app/xev_1.0.3.bb