diff options
author | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
commit | b2f192faabe412adce79534e22efe9fb69ee40e2 (patch) | |
tree | 7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/xlibs/libxfont | |
parent | 2cf0eadf9f730027833af802d7e6c90b44248f80 (diff) | |
download | poky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz |
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/xlibs/libxfont')
-rw-r--r-- | meta/packages/xlibs/libxfont/autofoo.patch | 18 | ||||
-rw-r--r-- | meta/packages/xlibs/libxfont/scalable.patch | 27 |
2 files changed, 45 insertions, 0 deletions
diff --git a/meta/packages/xlibs/libxfont/autofoo.patch b/meta/packages/xlibs/libxfont/autofoo.patch new file mode 100644 index 0000000000..4998625c24 --- /dev/null +++ b/meta/packages/xlibs/libxfont/autofoo.patch | |||
@@ -0,0 +1,18 @@ | |||
1 | |||
2 | # | ||
3 | # Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher | ||
4 | # | ||
5 | |||
6 | --- libXfont-1.4.2/configure.ac~autofoo 2004-05-06 20:19:03.000000000 -0400 | ||
7 | +++ libXfont-1.4.2/configure.ac 2005-01-16 12:14:14.042598720 -0500 | ||
8 | @@ -35,9 +35,9 @@ | ||
9 | dnl Yes, it is a pain to synchronize version numbers. Unfortunately, it's | ||
10 | dnl not possible to extract the version number here from Xfont.h | ||
11 | dnl | ||
12 | +AC_CONFIG_AUX_DIR(.) | ||
13 | AM_INIT_AUTOMAKE([dist-bzip2]) | ||
14 | AM_CONFIG_HEADER(config.h) | ||
15 | -AC_CONFIG_AUX_DIR(.) | ||
16 | AC_CONFIG_HEADERS([include/X11/fonts/fontconf.h]) | ||
17 | |||
18 | # Check for progs | ||
diff --git a/meta/packages/xlibs/libxfont/scalable.patch b/meta/packages/xlibs/libxfont/scalable.patch new file mode 100644 index 0000000000..7f97b9a8f6 --- /dev/null +++ b/meta/packages/xlibs/libxfont/scalable.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | Index: fontfile/fontdir.c | ||
2 | =================================================================== | ||
3 | RCS file: /cvs/xlibs/Xfont/fontfile/fontdir.c,v | ||
4 | retrieving revision 3.22 | ||
5 | diff -u -r3.22 fontdir.c | ||
6 | --- xfont/fontfile/fontdir.c 7 Jul 2003 16:40:11 -0000 3.22 | ||
7 | +++ xfont/fontfile/fontdir.c 30 Dec 2004 20:37:12 -0000 | ||
8 | @@ -699,6 +699,11 @@ | ||
9 | */ | ||
10 | if (isscale) | ||
11 | { | ||
12 | + /* If the fontname says it is scalable, make sure that the | ||
13 | + * renderer supports OpenScalable and GetInfoScalable. | ||
14 | + */ | ||
15 | + if (renderer->OpenScalable && renderer->GetInfoScalable) | ||
16 | + { | ||
17 | if (vals.values_supplied & SIZE_SPECIFY_MASK) | ||
18 | { | ||
19 | bzero((char *)&zeroVals, sizeof(zeroVals)); | ||
20 | @@ -798,6 +803,7 @@ | ||
21 | bitmap->name.name); | ||
22 | } | ||
23 | } | ||
24 | + } | ||
25 | } | ||
26 | return TRUE; | ||
27 | } | ||