diff options
author | Dongxiao Xu <dongxiao.xu@intel.com> | 2010-07-15 20:43:41 +0800 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-07-16 16:25:17 +0100 |
commit | e4f0d88caf0f67a574196bf1576a01dea7494b1c (patch) | |
tree | 44a5bfbff9d12d3c8d2663f65627686e5e3028c7 /meta/packages/wpa-supplicant | |
parent | 397793a0a4d931f2b277762c5a0652e173e6e1c8 (diff) | |
download | poky-e4f0d88caf0f67a574196bf1576a01dea7494b1c.tar.gz |
wpa-supplicant: Upgraded to version 0.7.2
Removed local patches since the changes have accpeted in latest version
Rename wpa-supplicant-0.5.inc to wpa-supplicant-0.7.inc
Modify ${S} since the new code structure is changed
Also fixed recipe metadata
Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Diffstat (limited to 'meta/packages/wpa-supplicant')
-rw-r--r-- | meta/packages/wpa-supplicant/files/defconfig-gnutls | 178 | ||||
-rw-r--r-- | meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/99_wpa_supplicant (renamed from meta/packages/wpa-supplicant/files/99_wpa_supplicant) | 0 | ||||
-rw-r--r-- | meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/defaults-sane (renamed from meta/packages/wpa-supplicant/files/defaults-sane) | 0 | ||||
-rw-r--r-- | meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/defconfig (renamed from meta/packages/wpa-supplicant/files/defconfig) | 0 | ||||
-rw-r--r-- | meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/defconfig-gnutls | 407 | ||||
-rw-r--r--[-rwxr-xr-x] | meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/init.sh (renamed from meta/packages/wpa-supplicant/files/init.sh) | 0 | ||||
-rw-r--r-- | meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/wpa-supplicant.sh (renamed from meta/packages/wpa-supplicant/files/wpa-supplicant.sh) | 0 | ||||
-rw-r--r-- | meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/wpa_supplicant-0.5.7-always-scan.patch (renamed from meta/packages/wpa-supplicant/files/wpa_supplicant-0.5.7-always-scan.patch) | 0 | ||||
-rw-r--r-- | meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/wpa_supplicant-fix-deprecated-dbus-function.patch (renamed from meta/packages/wpa-supplicant/files/wpa_supplicant-fix-deprecated-dbus-function.patch) | 0 | ||||
-rw-r--r-- | meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/wpa_supplicant.conf (renamed from meta/packages/wpa-supplicant/files/wpa_supplicant.conf) | 0 | ||||
-rw-r--r-- | meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/wpa_supplicant.conf-sane (renamed from meta/packages/wpa-supplicant/files/wpa_supplicant.conf-sane) | 0 | ||||
-rw-r--r-- | meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/wpa_supplicant_default.conf (renamed from meta/packages/wpa-supplicant/files/wpa_supplicant_default.conf) | 0 | ||||
-rw-r--r-- | meta/packages/wpa-supplicant/wpa-supplicant-0.7.inc (renamed from meta/packages/wpa-supplicant/wpa-supplicant-0.5.inc) | 35 | ||||
-rw-r--r-- | meta/packages/wpa-supplicant/wpa-supplicant_0.5.8.bb | 3 | ||||
-rw-r--r-- | meta/packages/wpa-supplicant/wpa-supplicant_0.7.2.bb | 3 |
15 files changed, 429 insertions, 197 deletions
diff --git a/meta/packages/wpa-supplicant/files/defconfig-gnutls b/meta/packages/wpa-supplicant/files/defconfig-gnutls deleted file mode 100644 index 5b4ff0d03e..0000000000 --- a/meta/packages/wpa-supplicant/files/defconfig-gnutls +++ /dev/null | |||
@@ -1,178 +0,0 @@ | |||
1 | # This file lists the configuration options that are used when building the | ||
2 | # hostapd binary. All lines starting with # are ignored. Configuration option | ||
3 | # lines must be commented out complete, if they are not to be included, i.e., | ||
4 | # just setting VARIABLE=n is not disabling that variable. | ||
5 | # | ||
6 | # This file is included in Makefile, so variables like CFLAGS and LIBS can also | ||
7 | # be modified from here. In most cass, these lines should use += in order not | ||
8 | # to override previous values of the variables. | ||
9 | |||
10 | CFLAGS = $(TARGET_CFLAGS) -I../hostapd -I../utils -I../driver/modules -Wall -MMD | ||
11 | LIBS = $(TARGET_LDFLAGS) | ||
12 | |||
13 | # Driver interface for Host AP driver | ||
14 | CONFIG_DRIVER_HOSTAP=y | ||
15 | |||
16 | # Driver interface for Agere driver | ||
17 | #CONFIG_DRIVER_HERMES=n | ||
18 | |||
19 | # Driver interface for madwifi driver | ||
20 | #CONFIG_DRIVER_MADWIFI=y | ||
21 | |||
22 | # Driver interface for Prism54 driver | ||
23 | #CONFIG_DRIVER_PRISM54=y | ||
24 | |||
25 | # Driver interface for ndiswrapper | ||
26 | #CONFIG_DRIVER_NDISWRAPPER=y | ||
27 | |||
28 | # Driver interface for Atmel driver | ||
29 | #CONFIG_DRIVER_ATMEL=y | ||
30 | |||
31 | # Driver interface for Broadcom driver | ||
32 | #CONFIG_DRIVER_BROADCOM=y | ||
33 | |||
34 | # Driver interface for Intel ipw2100 driver | ||
35 | #CONFIG_DRIVER_IPW2100=y | ||
36 | |||
37 | # Driver interface for generic Linux wireless extensions | ||
38 | CONFIG_DRIVER_WEXT=y | ||
39 | |||
40 | # Driver interface for FreeBSD net80211 layer (e.g., Atheros driver) | ||
41 | #CONFIG_DRIVER_BSD=y | ||
42 | #CFLAGS += -I/usr/local/include | ||
43 | #LIBS += -L/usr/local/lib | ||
44 | |||
45 | # Driver interface for development testing | ||
46 | #CONFIG_DRIVER_TEST=y | ||
47 | |||
48 | # Driver interface for wired Ethernet drivers | ||
49 | CONFIG_DRIVER_WIRED=y | ||
50 | |||
51 | # Enable IEEE 802.1X Supplicant (automatically included if any EAP method is | ||
52 | # included) | ||
53 | CONFIG_IEEE8021X_EAPOL=y | ||
54 | |||
55 | # EAP-MD5 (automatically included if EAP-TTLS is enabled) | ||
56 | CONFIG_EAP_MD5=y | ||
57 | |||
58 | # EAP-MSCHAPv2 (automatically included if EAP-PEAP is enabled) | ||
59 | CONFIG_EAP_MSCHAPV2=y | ||
60 | |||
61 | # EAP-TLS | ||
62 | CONFIG_EAP_TLS=y | ||
63 | |||
64 | # EAL-PEAP | ||
65 | CONFIG_EAP_PEAP=y | ||
66 | |||
67 | # EAP-TTLS | ||
68 | CONFIG_EAP_TTLS=y | ||
69 | |||
70 | # EAP-GTC | ||
71 | CONFIG_EAP_GTC=y | ||
72 | |||
73 | # EAP-OTP | ||
74 | CONFIG_EAP_OTP=y | ||
75 | |||
76 | # EAP-SIM (enable CONFIG_PCSC, if EAP-SIM is used) | ||
77 | #CONFIG_EAP_SIM=y | ||
78 | |||
79 | # EAP-PSK (experimental; this is _not_ needed for WPA-PSK) | ||
80 | #CONFIG_EAP_PSK=y | ||
81 | |||
82 | # EAP-PAX | ||
83 | #CONFIG_EAP_PAX=y | ||
84 | |||
85 | # LEAP | ||
86 | CONFIG_EAP_LEAP=y | ||
87 | |||
88 | # EAP-AKA (enable CONFIG_PCSC, if EAP-AKA is used) | ||
89 | #CONFIG_EAP_AKA=y | ||
90 | |||
91 | # PKCS#12 (PFX) support (used to read private key and certificate file from | ||
92 | # a file that usually has extension .p12 or .pfx) | ||
93 | CONFIG_PKCS12=y | ||
94 | |||
95 | # Smartcard support (i.e., private key on a smartcard), e.g., with openssl | ||
96 | # engine. | ||
97 | CONFIG_SMARTCARD=y | ||
98 | |||
99 | # PC/SC interface for smartcards (USIM, GSM SIM) | ||
100 | # Enable this if EAP-SIM or EAP-AKA is included | ||
101 | #CONFIG_PCSC=y | ||
102 | |||
103 | # Development testing | ||
104 | #CONFIG_EAPOL_TEST=y | ||
105 | |||
106 | # Replace native Linux implementation of packet sockets with libdnet/libpcap. | ||
107 | # This will be automatically set for non-Linux OS. | ||
108 | #CONFIG_DNET_PCAP=y | ||
109 | |||
110 | # Include control interface for external programs, e.g, wpa_cli | ||
111 | CONFIG_CTRL_IFACE=y | ||
112 | |||
113 | # Include support for GNU Readline and History Libraries in wpa_cli. | ||
114 | # When building a wpa_cli binary for distribution, please note that these | ||
115 | # libraries are licensed under GPL and as such, BSD license may not apply for | ||
116 | # the resulting binary. | ||
117 | #CONFIG_READLINE=y | ||
118 | |||
119 | # Remove debugging code that is printing out debug message to stdout. | ||
120 | # This can be used to reduce the size of the wpa_supplicant considerably | ||
121 | # if debugging code is not needed. The size reduction can be around 35% | ||
122 | # (e.g., 90 kB). | ||
123 | #CONFIG_NO_STDOUT_DEBUG=y | ||
124 | |||
125 | # Remove WPA support, e.g., for wired-only IEEE 802.1X supplicant, to save | ||
126 | # 35-50 kB in code size. | ||
127 | #CONFIG_NO_WPA=y | ||
128 | |||
129 | # Select configuration backend: | ||
130 | # file = text file (e.g., wpa_supplicant.conf) | ||
131 | # winreg = Windows registry (see win_example.reg for an example) | ||
132 | CONFIG_BACKEND=file | ||
133 | |||
134 | # Select program entry point implementation: | ||
135 | # main = UNIX/POSIX like main() function (default) | ||
136 | # main_winsvc = Windows service (read parameters from registry) | ||
137 | # main_none = Very basic example (development use only) | ||
138 | #CONFIG_MAIN=main | ||
139 | |||
140 | # Select wrapper for operatins system and C library specific functions | ||
141 | # unix = UNIX/POSIX like systems (default) | ||
142 | # win32 = Windows systems | ||
143 | # none = Empty template | ||
144 | #CONFIG_OS=unix | ||
145 | |||
146 | # Select event loop implementation | ||
147 | # eloop = select() loop (default) | ||
148 | # eloop_win = Windows events and WaitForMultipleObject() loop | ||
149 | # eloop_none = Empty template | ||
150 | #CONFIG_ELOOP=eloop | ||
151 | |||
152 | # Select layer 2 packet implementation | ||
153 | # linux = Linux packet socket (default) | ||
154 | # pcap = libpcap/libdnet/WinPcap | ||
155 | # freebsd = FreeBSD libpcap | ||
156 | # winpcap = WinPcap with receive thread | ||
157 | # none = Empty template | ||
158 | #CONFIG_L2_PACKET=linux | ||
159 | |||
160 | # IEEE 802.11i/IEEE 802.11e STAKey negotiation for direct link connection | ||
161 | #CONFIG_STAKEY=y | ||
162 | |||
163 | # Select TLS implementation | ||
164 | # openssl = OpenSSL (default) | ||
165 | # gnutls = GnuTLS (needed for TLS/IA, see also CONFIG_GNUTLS_EXTRA) | ||
166 | # none = Empty template | ||
167 | CONFIG_TLS=gnutls | ||
168 | |||
169 | # Whether to enable TLS/IA support, which is required for EAP-TTLSv1. | ||
170 | # You need CONFIG_TLS=gnutls for this to have any effect. Please note that | ||
171 | # even though the core GnuTLS library is released under LGPL, this extra | ||
172 | # library uses GPL and as such, the terms of GPL apply to the combination | ||
173 | # of wpa_supplicant and GnuTLS if this option is enabled. BSD license may not | ||
174 | # apply for distribution of the resulting binary. | ||
175 | CONFIG_GNUTLS_EXTRA=y | ||
176 | |||
177 | # Add support for DBus control interface | ||
178 | CONFIG_CTRL_IFACE_DBUS=y | ||
diff --git a/meta/packages/wpa-supplicant/files/99_wpa_supplicant b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/99_wpa_supplicant index 6ff4dd8826..6ff4dd8826 100644 --- a/meta/packages/wpa-supplicant/files/99_wpa_supplicant +++ b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/99_wpa_supplicant | |||
diff --git a/meta/packages/wpa-supplicant/files/defaults-sane b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/defaults-sane index 67c4cbddf8..67c4cbddf8 100644 --- a/meta/packages/wpa-supplicant/files/defaults-sane +++ b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/defaults-sane | |||
diff --git a/meta/packages/wpa-supplicant/files/defconfig b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/defconfig index c165343399..c165343399 100644 --- a/meta/packages/wpa-supplicant/files/defconfig +++ b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/defconfig | |||
diff --git a/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/defconfig-gnutls b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/defconfig-gnutls new file mode 100644 index 0000000000..e325bb83e9 --- /dev/null +++ b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/defconfig-gnutls | |||
@@ -0,0 +1,407 @@ | |||
1 | # Example wpa_supplicant build time configuration | ||
2 | # | ||
3 | # This file lists the configuration options that are used when building the | ||
4 | # hostapd binary. All lines starting with # are ignored. Configuration option | ||
5 | # lines must be commented out complete, if they are not to be included, i.e., | ||
6 | # just setting VARIABLE=n is not disabling that variable. | ||
7 | # | ||
8 | # This file is included in Makefile, so variables like CFLAGS and LIBS can also | ||
9 | # be modified from here. In most cases, these lines should use += in order not | ||
10 | # to override previous values of the variables. | ||
11 | |||
12 | |||
13 | # Uncomment following two lines and fix the paths if you have installed OpenSSL | ||
14 | # or GnuTLS in non-default location | ||
15 | #CFLAGS += -I/usr/local/openssl/include | ||
16 | #LIBS += -L/usr/local/openssl/lib | ||
17 | |||
18 | # Some Red Hat versions seem to include kerberos header files from OpenSSL, but | ||
19 | # the kerberos files are not in the default include path. Following line can be | ||
20 | # used to fix build issues on such systems (krb5.h not found). | ||
21 | #CFLAGS += -I/usr/include/kerberos | ||
22 | |||
23 | # Example configuration for various cross-compilation platforms | ||
24 | |||
25 | #### sveasoft (e.g., for Linksys WRT54G) ###################################### | ||
26 | #CC=mipsel-uclibc-gcc | ||
27 | #CC=/opt/brcm/hndtools-mipsel-uclibc/bin/mipsel-uclibc-gcc | ||
28 | #CFLAGS += -Os | ||
29 | #CPPFLAGS += -I../src/include -I../../src/router/openssl/include | ||
30 | #LIBS += -L/opt/brcm/hndtools-mipsel-uclibc-0.9.19/lib -lssl | ||
31 | ############################################################################### | ||
32 | |||
33 | #### openwrt (e.g., for Linksys WRT54G) ####################################### | ||
34 | #CC=mipsel-uclibc-gcc | ||
35 | #CC=/opt/brcm/hndtools-mipsel-uclibc/bin/mipsel-uclibc-gcc | ||
36 | #CFLAGS += -Os | ||
37 | #CPPFLAGS=-I../src/include -I../openssl-0.9.7d/include \ | ||
38 | # -I../WRT54GS/release/src/include | ||
39 | #LIBS = -lssl | ||
40 | ############################################################################### | ||
41 | |||
42 | |||
43 | # Driver interface for Host AP driver | ||
44 | CONFIG_DRIVER_HOSTAP=y | ||
45 | |||
46 | # Driver interface for Agere driver | ||
47 | #CONFIG_DRIVER_HERMES=y | ||
48 | # Change include directories to match with the local setup | ||
49 | #CFLAGS += -I../../hcf -I../../include -I../../include/hcf | ||
50 | #CFLAGS += -I../../include/wireless | ||
51 | |||
52 | # Driver interface for madwifi driver | ||
53 | # Deprecated; use CONFIG_DRIVER_WEXT=y instead. | ||
54 | #CONFIG_DRIVER_MADWIFI=y | ||
55 | # Set include directory to the madwifi source tree | ||
56 | #CFLAGS += -I../../madwifi | ||
57 | |||
58 | # Driver interface for ndiswrapper | ||
59 | # Deprecated; use CONFIG_DRIVER_WEXT=y instead. | ||
60 | #CONFIG_DRIVER_NDISWRAPPER=y | ||
61 | |||
62 | # Driver interface for Atmel driver | ||
63 | # CONFIG_DRIVER_ATMEL=y | ||
64 | |||
65 | # Driver interface for old Broadcom driver | ||
66 | # Please note that the newer Broadcom driver ("hybrid Linux driver") supports | ||
67 | # Linux wireless extensions and does not need (or even work) with the old | ||
68 | # driver wrapper. Use CONFIG_DRIVER_WEXT=y with that driver. | ||
69 | #CONFIG_DRIVER_BROADCOM=y | ||
70 | # Example path for wlioctl.h; change to match your configuration | ||
71 | #CFLAGS += -I/opt/WRT54GS/release/src/include | ||
72 | |||
73 | # Driver interface for Intel ipw2100/2200 driver | ||
74 | # Deprecated; use CONFIG_DRIVER_WEXT=y instead. | ||
75 | #CONFIG_DRIVER_IPW=y | ||
76 | |||
77 | # Driver interface for Ralink driver | ||
78 | #CONFIG_DRIVER_RALINK=y | ||
79 | |||
80 | # Driver interface for generic Linux wireless extensions | ||
81 | CONFIG_DRIVER_WEXT=y | ||
82 | |||
83 | # Driver interface for Linux drivers using the nl80211 kernel interface | ||
84 | #CONFIG_DRIVER_NL80211=y | ||
85 | |||
86 | # Driver interface for FreeBSD net80211 layer (e.g., Atheros driver) | ||
87 | #CONFIG_DRIVER_BSD=y | ||
88 | #CFLAGS += -I/usr/local/include | ||
89 | #LIBS += -L/usr/local/lib | ||
90 | #LIBS_p += -L/usr/local/lib | ||
91 | #LIBS_c += -L/usr/local/lib | ||
92 | |||
93 | # Driver interface for Windows NDIS | ||
94 | #CONFIG_DRIVER_NDIS=y | ||
95 | #CFLAGS += -I/usr/include/w32api/ddk | ||
96 | #LIBS += -L/usr/local/lib | ||
97 | # For native build using mingw | ||
98 | #CONFIG_NATIVE_WINDOWS=y | ||
99 | # Additional directories for cross-compilation on Linux host for mingw target | ||
100 | #CFLAGS += -I/opt/mingw/mingw32/include/ddk | ||
101 | #LIBS += -L/opt/mingw/mingw32/lib | ||
102 | #CC=mingw32-gcc | ||
103 | # By default, driver_ndis uses WinPcap for low-level operations. This can be | ||
104 | # replaced with the following option which replaces WinPcap calls with NDISUIO. | ||
105 | # However, this requires that WZC is disabled (net stop wzcsvc) before starting | ||
106 | # wpa_supplicant. | ||
107 | # CONFIG_USE_NDISUIO=y | ||
108 | |||
109 | # Driver interface for development testing | ||
110 | #CONFIG_DRIVER_TEST=y | ||
111 | |||
112 | # Include client MLME (management frame processing) for test driver | ||
113 | # This can be used to test MLME operations in hostapd with the test interface. | ||
114 | # space. | ||
115 | #CONFIG_CLIENT_MLME=y | ||
116 | |||
117 | # Driver interface for wired Ethernet drivers | ||
118 | CONFIG_DRIVER_WIRED=y | ||
119 | |||
120 | # Driver interface for the Broadcom RoboSwitch family | ||
121 | #CONFIG_DRIVER_ROBOSWITCH=y | ||
122 | |||
123 | # Driver interface for no driver (e.g., WPS ER only) | ||
124 | #CONFIG_DRIVER_NONE=y | ||
125 | |||
126 | # Enable IEEE 802.1X Supplicant (automatically included if any EAP method is | ||
127 | # included) | ||
128 | CONFIG_IEEE8021X_EAPOL=y | ||
129 | |||
130 | # EAP-MD5 | ||
131 | CONFIG_EAP_MD5=y | ||
132 | |||
133 | # EAP-MSCHAPv2 | ||
134 | CONFIG_EAP_MSCHAPV2=y | ||
135 | |||
136 | # EAP-TLS | ||
137 | CONFIG_EAP_TLS=y | ||
138 | |||
139 | # EAL-PEAP | ||
140 | CONFIG_EAP_PEAP=y | ||
141 | |||
142 | # EAP-TTLS | ||
143 | CONFIG_EAP_TTLS=y | ||
144 | |||
145 | # EAP-FAST | ||
146 | # Note: Default OpenSSL package does not include support for all the | ||
147 | # functionality needed for EAP-FAST. If EAP-FAST is enabled with OpenSSL, | ||
148 | # the OpenSSL library must be patched (openssl-0.9.8d-tls-extensions.patch) | ||
149 | # to add the needed functions. | ||
150 | #CONFIG_EAP_FAST=y | ||
151 | |||
152 | # EAP-GTC | ||
153 | CONFIG_EAP_GTC=y | ||
154 | |||
155 | # EAP-OTP | ||
156 | CONFIG_EAP_OTP=y | ||
157 | |||
158 | # EAP-SIM (enable CONFIG_PCSC, if EAP-SIM is used) | ||
159 | #CONFIG_EAP_SIM=y | ||
160 | |||
161 | # EAP-PSK (experimental; this is _not_ needed for WPA-PSK) | ||
162 | #CONFIG_EAP_PSK=y | ||
163 | |||
164 | # EAP-PAX | ||
165 | #CONFIG_EAP_PAX=y | ||
166 | |||
167 | # LEAP | ||
168 | CONFIG_EAP_LEAP=y | ||
169 | |||
170 | # EAP-AKA (enable CONFIG_PCSC, if EAP-AKA is used) | ||
171 | #CONFIG_EAP_AKA=y | ||
172 | |||
173 | # EAP-AKA' (enable CONFIG_PCSC, if EAP-AKA' is used). | ||
174 | # This requires CONFIG_EAP_AKA to be enabled, too. | ||
175 | #CONFIG_EAP_AKA_PRIME=y | ||
176 | |||
177 | # Enable USIM simulator (Milenage) for EAP-AKA | ||
178 | #CONFIG_USIM_SIMULATOR=y | ||
179 | |||
180 | # EAP-SAKE | ||
181 | #CONFIG_EAP_SAKE=y | ||
182 | |||
183 | # EAP-GPSK | ||
184 | #CONFIG_EAP_GPSK=y | ||
185 | # Include support for optional SHA256 cipher suite in EAP-GPSK | ||
186 | #CONFIG_EAP_GPSK_SHA256=y | ||
187 | |||
188 | # EAP-TNC and related Trusted Network Connect support (experimental) | ||
189 | #CONFIG_EAP_TNC=y | ||
190 | |||
191 | # Wi-Fi Protected Setup (WPS) | ||
192 | #CONFIG_WPS=y | ||
193 | |||
194 | # EAP-IKEv2 | ||
195 | #CONFIG_EAP_IKEV2=y | ||
196 | |||
197 | # PKCS#12 (PFX) support (used to read private key and certificate file from | ||
198 | # a file that usually has extension .p12 or .pfx) | ||
199 | CONFIG_PKCS12=y | ||
200 | |||
201 | # Smartcard support (i.e., private key on a smartcard), e.g., with openssl | ||
202 | # engine. | ||
203 | CONFIG_SMARTCARD=y | ||
204 | |||
205 | # PC/SC interface for smartcards (USIM, GSM SIM) | ||
206 | # Enable this if EAP-SIM or EAP-AKA is included | ||
207 | #CONFIG_PCSC=y | ||
208 | |||
209 | # Development testing | ||
210 | #CONFIG_EAPOL_TEST=y | ||
211 | |||
212 | # Select control interface backend for external programs, e.g, wpa_cli: | ||
213 | # unix = UNIX domain sockets (default for Linux/*BSD) | ||
214 | # udp = UDP sockets using localhost (127.0.0.1) | ||
215 | # named_pipe = Windows Named Pipe (default for Windows) | ||
216 | # y = use default (backwards compatibility) | ||
217 | # If this option is commented out, control interface is not included in the | ||
218 | # build. | ||
219 | CONFIG_CTRL_IFACE=y | ||
220 | |||
221 | # Include support for GNU Readline and History Libraries in wpa_cli. | ||
222 | # When building a wpa_cli binary for distribution, please note that these | ||
223 | # libraries are licensed under GPL and as such, BSD license may not apply for | ||
224 | # the resulting binary. | ||
225 | #CONFIG_READLINE=y | ||
226 | |||
227 | # Remove debugging code that is printing out debug message to stdout. | ||
228 | # This can be used to reduce the size of the wpa_supplicant considerably | ||
229 | # if debugging code is not needed. The size reduction can be around 35% | ||
230 | # (e.g., 90 kB). | ||
231 | #CONFIG_NO_STDOUT_DEBUG=y | ||
232 | |||
233 | # Remove WPA support, e.g., for wired-only IEEE 802.1X supplicant, to save | ||
234 | # 35-50 kB in code size. | ||
235 | #CONFIG_NO_WPA=y | ||
236 | |||
237 | # Remove WPA2 support. This allows WPA to be used, but removes WPA2 code to | ||
238 | # save about 1 kB in code size when building only WPA-Personal (no EAP support) | ||
239 | # or 6 kB if building for WPA-Enterprise. | ||
240 | #CONFIG_NO_WPA2=y | ||
241 | |||
242 | # Remove IEEE 802.11i/WPA-Personal ASCII passphrase support | ||
243 | # This option can be used to reduce code size by removing support for | ||
244 | # converting ASCII passphrases into PSK. If this functionality is removed, the | ||
245 | # PSK can only be configured as the 64-octet hexstring (e.g., from | ||
246 | # wpa_passphrase). This saves about 0.5 kB in code size. | ||
247 | #CONFIG_NO_WPA_PASSPHRASE=y | ||
248 | |||
249 | # Disable scan result processing (ap_mode=1) to save code size by about 1 kB. | ||
250 | # This can be used if ap_scan=1 mode is never enabled. | ||
251 | #CONFIG_NO_SCAN_PROCESSING=y | ||
252 | |||
253 | # Select configuration backend: | ||
254 | # file = text file (e.g., wpa_supplicant.conf; note: the configuration file | ||
255 | # path is given on command line, not here; this option is just used to | ||
256 | # select the backend that allows configuration files to be used) | ||
257 | # winreg = Windows registry (see win_example.reg for an example) | ||
258 | CONFIG_BACKEND=file | ||
259 | |||
260 | # Remove configuration write functionality (i.e., to allow the configuration | ||
261 | # file to be updated based on runtime configuration changes). The runtime | ||
262 | # configuration can still be changed, the changes are just not going to be | ||
263 | # persistent over restarts. This option can be used to reduce code size by | ||
264 | # about 3.5 kB. | ||
265 | #CONFIG_NO_CONFIG_WRITE=y | ||
266 | |||
267 | # Remove support for configuration blobs to reduce code size by about 1.5 kB. | ||
268 | #CONFIG_NO_CONFIG_BLOBS=y | ||
269 | |||
270 | # Select program entry point implementation: | ||
271 | # main = UNIX/POSIX like main() function (default) | ||
272 | # main_winsvc = Windows service (read parameters from registry) | ||
273 | # main_none = Very basic example (development use only) | ||
274 | #CONFIG_MAIN=main | ||
275 | |||
276 | # Select wrapper for operatins system and C library specific functions | ||
277 | # unix = UNIX/POSIX like systems (default) | ||
278 | # win32 = Windows systems | ||
279 | # none = Empty template | ||
280 | #CONFIG_OS=unix | ||
281 | |||
282 | # Select event loop implementation | ||
283 | # eloop = select() loop (default) | ||
284 | # eloop_win = Windows events and WaitForMultipleObject() loop | ||
285 | # eloop_none = Empty template | ||
286 | #CONFIG_ELOOP=eloop | ||
287 | |||
288 | # Select layer 2 packet implementation | ||
289 | # linux = Linux packet socket (default) | ||
290 | # pcap = libpcap/libdnet/WinPcap | ||
291 | # freebsd = FreeBSD libpcap | ||
292 | # winpcap = WinPcap with receive thread | ||
293 | # ndis = Windows NDISUIO (note: requires CONFIG_USE_NDISUIO=y) | ||
294 | # none = Empty template | ||
295 | #CONFIG_L2_PACKET=linux | ||
296 | |||
297 | # PeerKey handshake for Station to Station Link (IEEE 802.11e DLS) | ||
298 | CONFIG_PEERKEY=y | ||
299 | |||
300 | # IEEE 802.11w (management frame protection) | ||
301 | # This version is an experimental implementation based on IEEE 802.11w/D1.0 | ||
302 | # draft and is subject to change since the standard has not yet been finalized. | ||
303 | # Driver support is also needed for IEEE 802.11w. | ||
304 | #CONFIG_IEEE80211W=y | ||
305 | |||
306 | # Select TLS implementation | ||
307 | # openssl = OpenSSL (default) | ||
308 | # gnutls = GnuTLS (needed for TLS/IA, see also CONFIG_GNUTLS_EXTRA) | ||
309 | # internal = Internal TLSv1 implementation (experimental) | ||
310 | # none = Empty template | ||
311 | #CONFIG_TLS=openssl | ||
312 | |||
313 | # Whether to enable TLS/IA support, which is required for EAP-TTLSv1. | ||
314 | # You need CONFIG_TLS=gnutls for this to have any effect. Please note that | ||
315 | # even though the core GnuTLS library is released under LGPL, this extra | ||
316 | # library uses GPL and as such, the terms of GPL apply to the combination | ||
317 | # of wpa_supplicant and GnuTLS if this option is enabled. BSD license may not | ||
318 | # apply for distribution of the resulting binary. | ||
319 | #CONFIG_GNUTLS_EXTRA=y | ||
320 | |||
321 | # If CONFIG_TLS=internal is used, additional library and include paths are | ||
322 | # needed for LibTomMath. Alternatively, an integrated, minimal version of | ||
323 | # LibTomMath can be used. See beginning of libtommath.c for details on benefits | ||
324 | # and drawbacks of this option. | ||
325 | #CONFIG_INTERNAL_LIBTOMMATH=y | ||
326 | #ifndef CONFIG_INTERNAL_LIBTOMMATH | ||
327 | #LTM_PATH=/usr/src/libtommath-0.39 | ||
328 | #CFLAGS += -I$(LTM_PATH) | ||
329 | #LIBS += -L$(LTM_PATH) | ||
330 | #LIBS_p += -L$(LTM_PATH) | ||
331 | #endif | ||
332 | # At the cost of about 4 kB of additional binary size, the internal LibTomMath | ||
333 | # can be configured to include faster routines for exptmod, sqr, and div to | ||
334 | # speed up DH and RSA calculation considerably | ||
335 | #CONFIG_INTERNAL_LIBTOMMATH_FAST=y | ||
336 | |||
337 | # Include NDIS event processing through WMI into wpa_supplicant/wpasvc. | ||
338 | # This is only for Windows builds and requires WMI-related header files and | ||
339 | # WbemUuid.Lib from Platform SDK even when building with MinGW. | ||
340 | #CONFIG_NDIS_EVENTS_INTEGRATED=y | ||
341 | #PLATFORMSDKLIB="/opt/Program Files/Microsoft Platform SDK/Lib" | ||
342 | |||
343 | # Add support for old DBus control interface | ||
344 | # (fi.epitest.hostap.WPASupplicant) | ||
345 | #CONFIG_CTRL_IFACE_DBUS=y | ||
346 | |||
347 | # Add support for new DBus control interface | ||
348 | # (fi.w1.hostap.wpa_supplicant1) | ||
349 | #CONFIG_CTRL_IFACE_DBUS_NEW=y | ||
350 | |||
351 | # Add introspection support for new DBus control interface | ||
352 | #CONFIG_CTRL_IFACE_DBUS_INTRO=y | ||
353 | |||
354 | # Add support for loading EAP methods dynamically as shared libraries. | ||
355 | # When this option is enabled, each EAP method can be either included | ||
356 | # statically (CONFIG_EAP_<method>=y) or dynamically (CONFIG_EAP_<method>=dyn). | ||
357 | # Dynamic EAP methods are build as shared objects (eap_*.so) and they need to | ||
358 | # be loaded in the beginning of the wpa_supplicant configuration file | ||
359 | # (see load_dynamic_eap parameter in the example file) before being used in | ||
360 | # the network blocks. | ||
361 | # | ||
362 | # Note that some shared parts of EAP methods are included in the main program | ||
363 | # and in order to be able to use dynamic EAP methods using these parts, the | ||
364 | # main program must have been build with the EAP method enabled (=y or =dyn). | ||
365 | # This means that EAP-TLS/PEAP/TTLS/FAST cannot be added as dynamic libraries | ||
366 | # unless at least one of them was included in the main build to force inclusion | ||
367 | # of the shared code. Similarly, at least one of EAP-SIM/AKA must be included | ||
368 | # in the main build to be able to load these methods dynamically. | ||
369 | # | ||
370 | # Please also note that using dynamic libraries will increase the total binary | ||
371 | # size. Thus, it may not be the best option for targets that have limited | ||
372 | # amount of memory/flash. | ||
373 | #CONFIG_DYNAMIC_EAP_METHODS=y | ||
374 | |||
375 | # IEEE Std 802.11r-2008 (Fast BSS Transition) | ||
376 | #CONFIG_IEEE80211R=y | ||
377 | |||
378 | # Add support for writing debug log to a file (/tmp/wpa_supplicant-log-#.txt) | ||
379 | #CONFIG_DEBUG_FILE=y | ||
380 | |||
381 | # Enable privilege separation (see README 'Privilege separation' for details) | ||
382 | #CONFIG_PRIVSEP=y | ||
383 | |||
384 | # Enable mitigation against certain attacks against TKIP by delaying Michael | ||
385 | # MIC error reports by a random amount of time between 0 and 60 seconds | ||
386 | #CONFIG_DELAYED_MIC_ERROR_REPORT=y | ||
387 | |||
388 | # Enable tracing code for developer debugging | ||
389 | # This tracks use of memory allocations and other registrations and reports | ||
390 | # incorrect use with a backtrace of call (or allocation) location. | ||
391 | #CONFIG_WPA_TRACE=y | ||
392 | # For BSD, comment out these. | ||
393 | #LIBS += -lexecinfo | ||
394 | #LIBS_p += -lexecinfo | ||
395 | #LIBS_c += -lexecinfo | ||
396 | |||
397 | # Use libbfd to get more details for developer debugging | ||
398 | # This enables use of libbfd to get more detailed symbols for the backtraces | ||
399 | # generated by CONFIG_WPA_TRACE=y. | ||
400 | #CONFIG_WPA_TRACE_BFD=y | ||
401 | # For BSD, comment out these. | ||
402 | #LIBS += -lbfd -liberty -lz | ||
403 | #LIBS_p += -lbfd -liberty -lz | ||
404 | #LIBS_c += -lbfd -liberty -lz | ||
405 | CONFIG_TLS = gnutls | ||
406 | CONFIG_GNUTLS_EXTRA=y | ||
407 | CONFIG_CTRL_IFACE_DBUS=y | ||
diff --git a/meta/packages/wpa-supplicant/files/init.sh b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/init.sh index bc7ee9184e..bc7ee9184e 100755..100644 --- a/meta/packages/wpa-supplicant/files/init.sh +++ b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/init.sh | |||
diff --git a/meta/packages/wpa-supplicant/files/wpa-supplicant.sh b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/wpa-supplicant.sh index 5c9e5d33a7..5c9e5d33a7 100644 --- a/meta/packages/wpa-supplicant/files/wpa-supplicant.sh +++ b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/wpa-supplicant.sh | |||
diff --git a/meta/packages/wpa-supplicant/files/wpa_supplicant-0.5.7-always-scan.patch b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/wpa_supplicant-0.5.7-always-scan.patch index 25afd07a11..25afd07a11 100644 --- a/meta/packages/wpa-supplicant/files/wpa_supplicant-0.5.7-always-scan.patch +++ b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/wpa_supplicant-0.5.7-always-scan.patch | |||
diff --git a/meta/packages/wpa-supplicant/files/wpa_supplicant-fix-deprecated-dbus-function.patch b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/wpa_supplicant-fix-deprecated-dbus-function.patch index dbd5e4e934..dbd5e4e934 100644 --- a/meta/packages/wpa-supplicant/files/wpa_supplicant-fix-deprecated-dbus-function.patch +++ b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/wpa_supplicant-fix-deprecated-dbus-function.patch | |||
diff --git a/meta/packages/wpa-supplicant/files/wpa_supplicant.conf b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/wpa_supplicant.conf index f0c993d195..f0c993d195 100644 --- a/meta/packages/wpa-supplicant/files/wpa_supplicant.conf +++ b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/wpa_supplicant.conf | |||
diff --git a/meta/packages/wpa-supplicant/files/wpa_supplicant.conf-sane b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/wpa_supplicant.conf-sane index c91ffe0c84..c91ffe0c84 100644 --- a/meta/packages/wpa-supplicant/files/wpa_supplicant.conf-sane +++ b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/wpa_supplicant.conf-sane | |||
diff --git a/meta/packages/wpa-supplicant/files/wpa_supplicant_default.conf b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/wpa_supplicant_default.conf index 8eebdeb5cb..8eebdeb5cb 100644 --- a/meta/packages/wpa-supplicant/files/wpa_supplicant_default.conf +++ b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.2/wpa_supplicant_default.conf | |||
diff --git a/meta/packages/wpa-supplicant/wpa-supplicant-0.5.inc b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.inc index 220516e57f..b1641061ff 100644 --- a/meta/packages/wpa-supplicant/wpa-supplicant-0.5.inc +++ b/meta/packages/wpa-supplicant/wpa-supplicant-0.7.inc | |||
@@ -1,33 +1,36 @@ | |||
1 | DESCRIPTION = "A Client for Wi-Fi Protected Access (WPA)." | 1 | DESCRIPTION = "A Client for Wi-Fi Protected Access (WPA)." |
2 | SECTION = "network" | ||
3 | LICENSE = "GPL" | ||
4 | HOMEPAGE = "http://hostap.epitest.fi/wpa_supplicant/" | 2 | HOMEPAGE = "http://hostap.epitest.fi/wpa_supplicant/" |
3 | BUGTRACKER = "http://hostap.epitest.fi/bugz/" | ||
4 | SECTION = "network" | ||
5 | LICENSE = "GPLv2 | BSD" | ||
6 | LIC_FILES_CHKSUM = "file://../COPYING;md5=c54ce9345727175ff66d17b67ff51f58 \ | ||
7 | file://../README;md5=54cfc88015d3ce83f7156e63c6bb1738 \ | ||
8 | file://wpa_supplicant.c;beginline=1;endline=17;md5=acdc5a4b0d6345f21f136eace747260e" | ||
5 | DEPENDS = "gnutls dbus" | 9 | DEPENDS = "gnutls dbus" |
10 | RRECOMMENDS_${PN} = "wpa-supplicant-passphrase wpa-supplicant-cli" | ||
6 | 11 | ||
7 | SRC_URI = "http://hostap.epitest.fi/releases/wpa_supplicant-${PV}.tar.gz \ | 12 | SRC_URI = "http://hostap.epitest.fi/releases/wpa_supplicant-${PV}.tar.gz \ |
8 | file://wpa_supplicant-0.5.7-always-scan.patch;patch=1 \ | 13 | file://defconfig-gnutls \ |
9 | file://wpa_supplicant-fix-deprecated-dbus-function.patch;patch=1;pnum=0 \ | 14 | file://defaults-sane \ |
10 | file://defconfig-gnutls \ | 15 | file://wpa-supplicant.sh \ |
11 | file://defaults-sane \ | 16 | file://wpa_supplicant.conf \ |
12 | file://wpa-supplicant.sh \ | 17 | file://wpa_supplicant.conf-sane \ |
13 | file://wpa_supplicant.conf \ | 18 | file://99_wpa_supplicant" |
14 | file://wpa_supplicant.conf-sane \ | ||
15 | file://99_wpa_supplicant" | ||
16 | 19 | ||
17 | S = "${WORKDIR}/wpa_supplicant-${PV}" | 20 | S = "${WORKDIR}/wpa_supplicant-${PV}/wpa_supplicant" |
18 | 21 | ||
19 | PACKAGES_prepend = "wpa-supplicant-passphrase wpa-supplicant-cli " | 22 | PACKAGES_prepend = "wpa-supplicant-passphrase wpa-supplicant-cli " |
20 | FILES_wpa-supplicant-passphrase = "/usr/sbin/wpa_passphrase" | 23 | FILES_wpa-supplicant-passphrase = "/usr/sbin/wpa_passphrase" |
21 | FILES_wpa-supplicant-cli = "/usr/sbin/wpa_cli" | 24 | FILES_wpa-supplicant-cli = "/usr/sbin/wpa_cli" |
22 | 25 | ||
23 | RRECOMMENDS_${PN} = "wpa-supplicant-passphrase wpa-supplicant-cli" | ||
24 | |||
25 | do_configure () { | 26 | do_configure () { |
26 | install -m 0755 ${WORKDIR}/defconfig-gnutls .config | 27 | install -m 0755 ${WORKDIR}/defconfig-gnutls .config |
27 | } | 28 | } |
28 | 29 | ||
30 | export EXTRA_CFLAGS = "${CFLAGS}" | ||
29 | do_compile () { | 31 | do_compile () { |
30 | make | 32 | unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS |
33 | oe_runmake | ||
31 | } | 34 | } |
32 | 35 | ||
33 | do_install () { | 36 | do_install () { |
@@ -52,7 +55,7 @@ do_install () { | |||
52 | ln -sf ../if-pre-up.d/wpa-supplicant if-post-down.d/wpa-supplicant | 55 | ln -sf ../if-pre-up.d/wpa-supplicant if-post-down.d/wpa-supplicant |
53 | 56 | ||
54 | install -d ${D}/${sysconfdir}/dbus-1/system.d | 57 | install -d ${D}/${sysconfdir}/dbus-1/system.d |
55 | install -m 644 ${S}/dbus-wpa_supplicant.conf ${D}/${sysconfdir}/dbus-1/system.d | 58 | install -m 644 ${S}/dbus/dbus-wpa_supplicant.conf ${D}/${sysconfdir}/dbus-1/system.d |
56 | 59 | ||
57 | install -d ${D}/etc/default/volatiles | 60 | install -d ${D}/etc/default/volatiles |
58 | install -m 0644 ${WORKDIR}/99_wpa_supplicant ${D}/etc/default/volatiles | 61 | install -m 0644 ${WORKDIR}/99_wpa_supplicant ${D}/etc/default/volatiles |
diff --git a/meta/packages/wpa-supplicant/wpa-supplicant_0.5.8.bb b/meta/packages/wpa-supplicant/wpa-supplicant_0.5.8.bb deleted file mode 100644 index 6feed719eb..0000000000 --- a/meta/packages/wpa-supplicant/wpa-supplicant_0.5.8.bb +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | require wpa-supplicant-0.5.inc | ||
2 | |||
3 | PR = "r6" | ||
diff --git a/meta/packages/wpa-supplicant/wpa-supplicant_0.7.2.bb b/meta/packages/wpa-supplicant/wpa-supplicant_0.7.2.bb new file mode 100644 index 0000000000..c6ebbaff4b --- /dev/null +++ b/meta/packages/wpa-supplicant/wpa-supplicant_0.7.2.bb | |||
@@ -0,0 +1,3 @@ | |||
1 | require wpa-supplicant-0.7.inc | ||
2 | |||
3 | PR = "r0" | ||