summaryrefslogtreecommitdiffstats
path: root/meta/packages/webkit/webkit-gtk_svn.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-03-05 13:19:52 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-03-05 13:19:52 +0000
commit5ab50f9ba2597a6f252a01ff3aeb3eaf3d9c9810 (patch)
treec6542c17cc0652a7ab7c2dea91103a6aa07ca36e /meta/packages/webkit/webkit-gtk_svn.bb
parenta31ec3d0f61846fe89284443c93adfb6a7b5bcf2 (diff)
downloadpoky-5ab50f9ba2597a6f252a01ff3aeb3eaf3d9c9810.tar.gz
webkit: update to 30762 from OE
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3919 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/webkit/webkit-gtk_svn.bb')
-rw-r--r--meta/packages/webkit/webkit-gtk_svn.bb82
1 files changed, 54 insertions, 28 deletions
diff --git a/meta/packages/webkit/webkit-gtk_svn.bb b/meta/packages/webkit/webkit-gtk_svn.bb
index 517d7e8062..4fe9cb8a00 100644
--- a/meta/packages/webkit/webkit-gtk_svn.bb
+++ b/meta/packages/webkit/webkit-gtk_svn.bb
@@ -1,33 +1,59 @@
1DEPENDS = "curl icu libxml2 cairo libxslt libidn gnutls gtk+" 1DEPENDS = "curl icu libxml2 cairo libxslt libidn gnutls gtk+ gstreamer gst-plugins-base gnome-vfs flex-native gperf-native perl-native sqlite3"
2 2
3# If you activate HTML5 media support (ENABLE_VIDEO=1) you'll need: 3SRCREV_FORMAT = "webcore-rwebkit"
4# DEPENDS += " gstreamer gst-plugins-base gnome-vfs " 4
5 5# Yes, this is wrong...
6 6PV = "0.1+svnr${SRCREV}"
7WEBKIT_PORT = "gtk-port" 7PR = "r4"
8WEBKIT_EXTRA_OPTIONS = "CONFIG-=qt" 8
9 9SRC_URI = "\
10FILES_webkit-gtklauncher = "${bindir}/GtkLauncher" 10 svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptCore;proto=http \
11FILES_webkit-gtklauncher-dbg += "${bindir}/.debug/GtkLauncher" 11 svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptGlue;proto=http \
12 12 svn://svn.webkit.org/repository/webkit/trunk/;module=WebCore;proto=http;name=webcore \
13require webkit.inc 13 svn://svn.webkit.org/repository/webkit/trunk/;module=WebKit;proto=http;name=webkit \
14 svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitLibraries;proto=http \
15 svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitTools;proto=http \
16 file://Makefile \
17 file://Makefile.shared \
18 file://autogen.sh \
19 file://configure.ac \
20 file://GNUmakefile.am \
21 "
22
23S = "${WORKDIR}/"
24
25inherit autotools pkgconfig
26
27EXTRA_OECONF = "\
28 --enable-debug=no \
29 --enable-svg \
30 --enable-icon-database=yes \
31 "
32
33do_compile_prepend() {
34 mkdir -p ${S}/WebKitBuilds/Debug/JavaScriptCore/pcre/tmp/
35 mkdir -p ${S}/Programs/
36 cd ${S}/JavaScriptCore/pcre
37 if test -e dftables.c
38 then
39 ${BUILD_CC} dftables.c -o dftables -I. -I../wtf
40 elif test -e dftables.cpp
41 then
42 ${BUILD_CXX} dftables.cpp -o dftables -I. -I../wtf
43 fi
44 cp dftables ${S}/WebKitBuilds/Debug/JavaScriptCore/pcre/tmp/
45 cp dftables ${S}/Programs/
46 cd ${S}
47}
14 48
15SRC_URI += "file://autogen.sh \ 49do_stage() {
16 file://configure.ac \ 50 autotools_stage_all
17 file://GNUmakefile.am \ 51}
18 file://fix_im.patch;patch=1 \
19 "
20 52
21PR = "r5" 53PACKAGES =+ "${PN}launcher-dbg ${PN}launcher libjavascriptcore"
54FILES_${PN}launcher = "${bindir}/GtkLauncher"
55FILES_${PN}launcher-dbg = "${bindir}/.debug/GtkLauncher"
56FILES_libjavascriptcore = "${libdir}/libJavaScriptCore.so.*"
22 57
23do_install() {
24 install -d ${D}${bindir}
25 install -d ${D}${libdir}
26 install -d ${D}${libdir}/pkgconfig
27 58
28 install -m 0755 ${S}/WebKitBuilds/Debug/WebKitTools/GtkLauncher/GtkLauncher ${D}${bindir}
29 cd ${S}/WebKitBuilds/Debug
30 PWD=`pwd` ${WEBKIT_QMAKE} WEBKIT_INC_DIR=${D}${prefix}/include WEBKIT_LIB_DIR=${D}${libdir} $PWD/../../WebKit.pro
31 oe_runmake install
32}
33 59