summaryrefslogtreecommitdiffstats
path: root/meta/packages/webkit/files
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-03-31 18:34:18 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-03-31 18:34:18 +0000
commit133a314a4f1d38fc93d37caf204c9946b92eccf3 (patch)
treea985dc190621c74caedb209b156cd5117cb77428 /meta/packages/webkit/files
parent544fa41378c23e3e5b4519fa8fecb9351f299b6c (diff)
downloadpoky-133a314a4f1d38fc93d37caf204c9946b92eccf3.tar.gz
webkit: upgraded to rev 31467, enabled SVG fonts
http://bugs.webkit.org/show_bug.cgi?id=18239 was reported as SVG fonts support is required to make Webkit built. git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4151 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/webkit/files')
-rw-r--r--meta/packages/webkit/files/GNUmakefile.am29
-rw-r--r--meta/packages/webkit/files/WebKit.pri11
-rw-r--r--meta/packages/webkit/files/WebKit.pro6
-rw-r--r--meta/packages/webkit/files/autogen.sh36
-rw-r--r--meta/packages/webkit/files/configure.ac95
-rw-r--r--meta/packages/webkit/files/fix_im.patch12
6 files changed, 125 insertions, 64 deletions
diff --git a/meta/packages/webkit/files/GNUmakefile.am b/meta/packages/webkit/files/GNUmakefile.am
index 977770a1ed..4cdd3dbfeb 100644
--- a/meta/packages/webkit/files/GNUmakefile.am
+++ b/meta/packages/webkit/files/GNUmakefile.am
@@ -52,11 +52,7 @@ EXTRA_DIST :=
52global_cppflags := 52global_cppflags :=
53 53
54global_cppflags += \ 54global_cppflags += \
55 -I$(srcdir)/JavaScriptCore \ 55 -DWTF_USE_ICU_UNICODE=1
56 -I$(srcdir)/JavaScriptCore/ForwardingHeaders \
57 -I$(srcdir)/JavaScriptCore/wtf \
58 -I$(srcdir)/JavaScriptCore/kjs \
59 -I$(top_builddir)/DerivedSources
60 56
61# Default compiler flags 57# Default compiler flags
62global_cflags := \ 58global_cflags := \
@@ -94,6 +90,13 @@ javascriptcore_sources :=
94javascriptcore_built_sources := 90javascriptcore_built_sources :=
95javascriptcore_built_nosources := 91javascriptcore_built_nosources :=
96 92
93javascriptcore_cppflags += \
94 -I$(srcdir)/JavaScriptCore \
95 -I$(srcdir)/JavaScriptCore/ForwardingHeaders \
96 -I$(srcdir)/JavaScriptCore/wtf \
97 -I$(srcdir)/JavaScriptCore/kjs \
98 -I$(top_builddir)/DerivedSources
99
97# The variables above are already included below so no need to touch 100# The variables above are already included below so no need to touch
98# these variables unless you really have to 101# these variables unless you really have to
99libJavaScriptCore_ladir = $(prefix)/include/webkit-1.0/JavaScriptCore 102libJavaScriptCore_ladir = $(prefix)/include/webkit-1.0/JavaScriptCore
@@ -104,7 +107,7 @@ libJavaScriptCore_la_SOURCES = \
104 $(javascriptcore_sources) 107 $(javascriptcore_sources)
105 108
106libJavaScriptCore_la_LIBADD = \ 109libJavaScriptCore_la_LIBADD = \
107 $(ICU_LIBS) \ 110 $(UNICODE_LIBS) \
108 $(GLOBALDEPS_LIBS) \ 111 $(GLOBALDEPS_LIBS) \
109 -lpthread 112 -lpthread
110 113
@@ -112,17 +115,18 @@ libJavaScriptCore_la_CXXFLAGS = \
112 $(global_cxxflags) \ 115 $(global_cxxflags) \
113 $(global_cflags) \ 116 $(global_cflags) \
114 $(GLOBALDEPS_CFLAGS) \ 117 $(GLOBALDEPS_CFLAGS) \
118 $(UNICODE_CFLAGS) \
115 -fstrict-aliasing 119 -fstrict-aliasing
116 120
117libJavaScriptCore_la_CFLAGS = \ 121libJavaScriptCore_la_CFLAGS = \
118 $(global_cflags) \ 122 $(global_cflags) \
119 $(GLOBALDEPS_CFLAGS) \ 123 $(GLOBALDEPS_CFLAGS) \
124 $(UNICODE_CFLAGS) \
120 -fstrict-aliasing 125 -fstrict-aliasing
121 126
122libJavaScriptCore_la_CPPFLAGS = \ 127libJavaScriptCore_la_CPPFLAGS = \
123 $(global_cppflags) \ 128 $(global_cppflags) \
124 $(javascriptcore_cppflags) \ 129 $(javascriptcore_cppflags)
125 $(ICU_CPPFLAGS)
126 130
127# 131#
128# WebCore 132# WebCore
@@ -154,8 +158,10 @@ libWebCore_la_CXXFLAGS = \
154 $(global_cxxflags) \ 158 $(global_cxxflags) \
155 $(global_cflags) \ 159 $(global_cflags) \
156 $(GLOBALDEPS_CFLAGS) \ 160 $(GLOBALDEPS_CFLAGS) \
161 $(UNICODE_CFLAGS) \
157 $(WEBKITDEPS_CFLAGS) \ 162 $(WEBKITDEPS_CFLAGS) \
158 $(LIBCURL_CFLAGS) \ 163 $(LIBCURL_CFLAGS) \
164 $(LIBSOUP_CFLAGS) \
159 $(SQLITE3_CFLAGS) \ 165 $(SQLITE3_CFLAGS) \
160 $(GSTREAMER_CFLAGS) \ 166 $(GSTREAMER_CFLAGS) \
161 $(LIBXSLT_CFLAGS) \ 167 $(LIBXSLT_CFLAGS) \
@@ -166,8 +172,10 @@ libWebCore_la_CFLAGS = \
166 -fno-strict-aliasing \ 172 -fno-strict-aliasing \
167 $(global_cflags) \ 173 $(global_cflags) \
168 $(GLOBALDEPS_CFLAGS) \ 174 $(GLOBALDEPS_CFLAGS) \
175 $(UNICODE_CFLAGS) \
169 $(WEBKITDEPS_CFLAGS) \ 176 $(WEBKITDEPS_CFLAGS) \
170 $(LIBCURL_CFLAGS) \ 177 $(LIBCURL_CFLAGS) \
178 $(LIBSOUP_CFLAGS) \
171 $(SQLITE3_CFLAGS) \ 179 $(SQLITE3_CFLAGS) \
172 $(GSTREAMER_CFLAGS) \ 180 $(GSTREAMER_CFLAGS) \
173 $(LIBXSLT_CFLAGS) \ 181 $(LIBXSLT_CFLAGS) \
@@ -175,9 +183,9 @@ libWebCore_la_CFLAGS = \
175 $(HILDON_CFLAGS) 183 $(HILDON_CFLAGS)
176 184
177libWebCore_la_CPPFLAGS = \ 185libWebCore_la_CPPFLAGS = \
178 $(ICU_CPPFLAGS) \
179 $(global_cppflags) \ 186 $(global_cppflags) \
180 $(webcore_cppflags) \ 187 $(webcore_cppflags) \
188 $(javascriptcore_cppflags) \
181 $(webkitgtk_cppflags) 189 $(webkitgtk_cppflags)
182 190
183libWebCore_la_LIBADD = \ 191libWebCore_la_LIBADD = \
@@ -186,7 +194,8 @@ libWebCore_la_LIBADD = \
186 $(GLOBALDEPS_LIBS) \ 194 $(GLOBALDEPS_LIBS) \
187 $(WEBKITDEPS_LIBS) \ 195 $(WEBKITDEPS_LIBS) \
188 $(LIBCURL_LIBS) \ 196 $(LIBCURL_LIBS) \
189 $(ICU_LIBS) \ 197 $(LIBSOUP_LIBS) \
198 $(UNICODE_LIBS) \
190 $(SQLITE3_LIBS) \ 199 $(SQLITE3_LIBS) \
191 $(GSTREAMER_LIBS) \ 200 $(GSTREAMER_LIBS) \
192 $(LIBXSLT_LIBS) \ 201 $(LIBXSLT_LIBS) \
diff --git a/meta/packages/webkit/files/WebKit.pri b/meta/packages/webkit/files/WebKit.pri
index 36404ac803..d12423beb2 100644
--- a/meta/packages/webkit/files/WebKit.pri
+++ b/meta/packages/webkit/files/WebKit.pri
@@ -17,7 +17,7 @@ qt-port:!building-libs {
17gtk-port:!building-libs { 17gtk-port:!building-libs {
18 QMAKE_LIBDIR = $$OUTPUT_DIR/lib $$QMAKE_LIBDIR 18 QMAKE_LIBDIR = $$OUTPUT_DIR/lib $$QMAKE_LIBDIR
19 LIBS += -lWebKitGtk 19 LIBS += -lWebKitGtk
20 DEPENDPATH += $$PWD/WebKit/gtk/WebView $$PWD/WebKit/gtk/WebCoreSupport 20 DEPENDPATH += $$PWD/WebKit/gtk $$PWD/WebKit/gtk/WebCoreSupport $$PWD/WebKit/gtk/webkit
21} 21}
22 22
23gtk-port { 23gtk-port {
@@ -36,6 +36,7 @@ gtk-port {
36 36
37 # We use the curl http backend on all platforms 37 # We use the curl http backend on all platforms
38 PKGCONFIG += libcurl 38 PKGCONFIG += libcurl
39 DEFINES += WTF_USE_CURL=1
39 40
40 LIBS += -lWebKitGtk -ljpeg -lpng 41 LIBS += -lWebKitGtk -ljpeg -lpng
41 42
@@ -72,8 +73,9 @@ gtk-port:INCLUDEPATH += \
72 $$BASE_DIR/WebCore/platform/graphics/cairo \ 73 $$BASE_DIR/WebCore/platform/graphics/cairo \
73 $$BASE_DIR/WebCore/loader/gtk \ 74 $$BASE_DIR/WebCore/loader/gtk \
74 $$BASE_DIR/WebCore/page/gtk \ 75 $$BASE_DIR/WebCore/page/gtk \
75 $$BASE_DIR/WebKit/gtk/WebView \ 76 $$BASE_DIR/WebKit/gtk \
76 $$BASE_DIR/WebKit/gtk/WebCoreSupport 77 $$BASE_DIR/WebKit/gtk/WebCoreSupport \
78 $$BASE_DIR/WebKit/gtk/webkit
77INCLUDEPATH += \ 79INCLUDEPATH += \
78 $$BASE_DIR/JavaScriptCore/ \ 80 $$BASE_DIR/JavaScriptCore/ \
79 $$BASE_DIR/JavaScriptCore/kjs \ 81 $$BASE_DIR/JavaScriptCore/kjs \
@@ -95,7 +97,8 @@ INCLUDEPATH += \
95 $$BASE_DIR/WebCore/rendering \ 97 $$BASE_DIR/WebCore/rendering \
96 $$BASE_DIR/WebCore/history \ 98 $$BASE_DIR/WebCore/history \
97 $$BASE_DIR/WebCore/xml \ 99 $$BASE_DIR/WebCore/xml \
98 $$BASE_DIR/WebCore/html 100 $$BASE_DIR/WebCore/html \
101 $$BASE_DIR/WebCore/plugins
99 102
100 103
101macx { 104macx {
diff --git a/meta/packages/webkit/files/WebKit.pro b/meta/packages/webkit/files/WebKit.pro
index 027017bd8d..bc14feb5f6 100644
--- a/meta/packages/webkit/files/WebKit.pro
+++ b/meta/packages/webkit/files/WebKit.pro
@@ -1,7 +1,11 @@
1TEMPLATE = subdirs 1TEMPLATE = subdirs
2CONFIG += ordered 2CONFIG += ordered
3!gtk-port:CONFIG += qt-port 3!gtk-port:CONFIG += qt-port
4qt-port:!win32-*:SUBDIRS += WebKit/qt/Plugins 4qt-port {
5 lessThan(QT_MINOR_VERSION, 4) {
6 !win32-*:SUBDIRS += WebKit/qt/Plugins
7 }
8}
5SUBDIRS += \ 9SUBDIRS += \
6 WebCore \ 10 WebCore \
7 JavaScriptCore/kjs/testkjs.pro 11 JavaScriptCore/kjs/testkjs.pro
diff --git a/meta/packages/webkit/files/autogen.sh b/meta/packages/webkit/files/autogen.sh
index 1c0fc61156..a929538d20 100644
--- a/meta/packages/webkit/files/autogen.sh
+++ b/meta/packages/webkit/files/autogen.sh
@@ -11,23 +11,35 @@ cd $srcdir
11DIE=0 11DIE=0
12 12
13(autoconf --version) < /dev/null > /dev/null 2>&1 || { 13(autoconf --version) < /dev/null > /dev/null 2>&1 || {
14 echo 14 echo
15 echo "You must have autoconf installed to compile $PROJECT." 15 echo "You must have autoconf installed to compile $PROJECT."
16 echo "Install the appropriate package for your distribution," 16 echo "Install the appropriate package for your distribution,"
17 echo "or get the source tarball at http://ftp.gnu.org/gnu/autoconf/" 17 echo "or get the source tarball at http://ftp.gnu.org/gnu/autoconf/"
18 DIE=1 18 DIE=1
19} 19}
20 20
21(automake --version) < /dev/null > /dev/null 2>&1 || { 21(automake --version) < /dev/null > /dev/null 2>&1 || {
22 echo 22 echo
23 echo "You must have automake installed to compile $PROJECT." 23 echo "You must have automake installed to compile $PROJECT."
24 echo "Install the appropriate package for your distribution," 24 echo "Install the appropriate package for your distribution,"
25 echo "or get the source tarball at http://ftp.gnu.org/gnu/automake/" 25 echo "or get the source tarball at http://ftp.gnu.org/gnu/automake/"
26 DIE=1 26 DIE=1
27}
28
29LIBTOOLIZE=libtoolize
30($LIBTOOLIZE --version) < /dev/null > /dev/null 2>&1 || {
31 LIBTOOLIZE=glibtoolize
32 ($LIBTOOLIZE --version) < /dev/null > /dev/null 2>&1 || {
33 echo
34 echo "You must have libtool installed to compile $PROJECT."
35 echo "Install the appropriate package for your distribution,"
36 echo "or get the source tarball at http://ftp.gnu.org/gnu/libtool/"
37 DIE=1
38 }
27} 39}
28 40
29if test "$DIE" -eq 1; then 41if test "$DIE" -eq 1; then
30 exit 1 42 exit 1
31fi 43fi
32 44
33rm -rf $top_srcdir/autom4te.cache 45rm -rf $top_srcdir/autom4te.cache
@@ -35,7 +47,7 @@ rm -rf $top_srcdir/autom4te.cache
35touch README INSTALL 47touch README INSTALL
36 48
37aclocal || exit $? 49aclocal || exit $?
38libtoolize --force || exit $? 50$LIBTOOLIZE --force || exit $?
39autoheader || exit $? 51autoheader || exit $?
40automake --foreign --add-missing || exit $? 52automake --foreign --add-missing || exit $?
41autoconf || exit $? 53autoconf || exit $?
diff --git a/meta/packages/webkit/files/configure.ac b/meta/packages/webkit/files/configure.ac
index 404e5a0d6a..64f32dc689 100644
--- a/meta/packages/webkit/files/configure.ac
+++ b/meta/packages/webkit/files/configure.ac
@@ -129,25 +129,42 @@ if test "$PKG_CONFIG" = "no"; then
129 AC_MSG_ERROR([Cannot find pkg-config, make sure it is installed in your PATH]) 129 AC_MSG_ERROR([Cannot find pkg-config, make sure it is installed in your PATH])
130fi 130fi
131 131
132# check for icu-config 132# determine the Unicode backend
133if test "$os_darwin" = "yes"; then 133AC_MSG_CHECKING([the Unicode backend to use])
134ICU_CPPFLAGS="-I\$(srcdir)/JavaScriptCore/icu -I\$(srcdir)/WebCore/icu" 134AC_ARG_WITH(unicode_backend,
135ICU_LIBS="-licucore" 135 AC_HELP_STRING([--with-unicode-backend=@<:@icu@:>@],
136else 136 [Select Unicode backend [default=icu]]),
137AC_PATH_PROG(icu_config, icu-config, no) 137 [],[unicode_backend="icu"])
138if test "$icu_config" = "no"; then 138
139 AC_MSG_ERROR([Cannot find icu-config. ICU library is needed.]) 139case "$unicode_backend" in
140fi 140 icu) ;;
141 *) AC_MSG_ERROR([Invalid Unicode backend: must be icu.]) ;;
142esac
141 143
142# We don't use --cflags as this gives us a lot of things that we don't 144AC_MSG_RESULT([$unicode_backend])
143# necessarily want, like debugging and optimization flags 145
144# See man (1) icu-config for more info. 146if test "$unicode_backend" = "icu"; then
145ICU_CPPFLAGS=`$icu_config --cppflags` 147 # check for icu-config
146ICU_LIBS=`$icu_config --ldflags` 148 if test "$os_darwin" = "yes"; then
147AC_SUBST([ICU_CPPFLAGS]) 149 UNICODE_CFLAGS="-I\$(srcdir)/JavaScriptCore/icu -I\$(srcdir)/WebCore/icu"
148AC_SUBST([ICU_LIBS]) 150 UNICODE_LIBS="-licucore"
151 else
152 AC_PATH_PROG(icu_config, icu-config, no)
153 if test "$icu_config" = "no"; then
154 AC_MSG_ERROR([Cannot find icu-config. The ICU library is needed.])
155 fi
156
157 # We don't use --cflags as this gives us a lot of things that we don't
158 # necessarily want, like debugging and optimization flags
159 # See man (1) icu-config for more info.
160 UNICODE_CFLAGS=`$icu_config --cppflags`
161 UNICODE_LIBS=`$icu_config --ldflags`
162 fi
149fi 163fi
150 164
165AC_SUBST([UNICODE_CFLAGS])
166AC_SUBST([UNICODE_LIBS])
167
151# determine the GDK/GTK+ target 168# determine the GDK/GTK+ target
152AC_MSG_CHECKING([the target windowing system]) 169AC_MSG_CHECKING([the target windowing system])
153AC_ARG_WITH(target, 170AC_ARG_WITH(target,
@@ -180,16 +197,16 @@ fi
180# determine the http backend 197# determine the http backend
181AC_MSG_CHECKING([the HTTP backend to use]) 198AC_MSG_CHECKING([the HTTP backend to use])
182AC_ARG_WITH(http_backend, 199AC_ARG_WITH(http_backend,
183 AC_HELP_STRING([--with-http-backend=@<:@curl@:>@], 200 AC_HELP_STRING([--with-http-backend=@<:@curl/soup@:>@],
184 [Select HTTP backend [default=curl]]), 201 [Select HTTP backend [default=curl]]),
185 [],[http_backend="curl"]) 202 [],[with_http_backend="curl"])
186 203
187case "$http_backend" in 204case "$with_http_backend" in
188 curl) ;; 205 curl|soup) ;;
189 *) AC_MSG_ERROR([Invalid HTTP backend: must be curl.]) ;; 206 *) AC_MSG_ERROR([Invalid HTTP backend: must be curl, soup.]) ;;
190esac 207esac
191 208
192AC_MSG_RESULT([$http_backend]) 209AC_MSG_RESULT([$with_http_backend])
193 210
194# minimum base dependencies 211# minimum base dependencies
195CAIRO_REQUIRED_VERSION=1.4 212CAIRO_REQUIRED_VERSION=1.4
@@ -206,6 +223,7 @@ GTK_REQUIRED_VERSION=2.8
206 223
207# optional modules 224# optional modules
208LIBCURL_REQUIRED_VERSION=7.15 225LIBCURL_REQUIRED_VERSION=7.15
226LIBSOUP_REQUIRED_VERSION=2.4
209LIBXSLT_REQUIRED_VERSION=1.1.7 227LIBXSLT_REQUIRED_VERSION=1.1.7
210SQLITE_REQUIRED_VERSION=3.0 228SQLITE_REQUIRED_VERSION=3.0
211GSTREAMER_REQUIRED_VERSION=0.10 229GSTREAMER_REQUIRED_VERSION=0.10
@@ -376,6 +394,19 @@ AC_ARG_ENABLE(fast_malloc,
376 [],[if test "$enable_debug" = "yes"; then enable_fast_malloc="no"; else enable_fast_malloc="yes"; fi]) 394 [],[if test "$enable_debug" = "yes"; then enable_fast_malloc="no"; else enable_fast_malloc="yes"; fi])
377AC_MSG_RESULT([$enable_fast_malloc]) 395AC_MSG_RESULT([$enable_fast_malloc])
378 396
397# determine the font backend
398AC_MSG_CHECKING([the font backend to use])
399AC_ARG_WITH(font_backend,
400 AC_HELP_STRING([--with-font-backend=@<:@freetype/pango@:>@],
401 [Select font backend [default=freetype]]),
402 [],[with_font_backend="freetype"])
403
404case "$with_font_backend" in
405 freetype|pango) ;;
406 *) AC_MSG_ERROR([Invalid font backend: must be freetype or pango.]) ;;
407esac
408AC_MSG_RESULT([$with_font_backend])
409
379# Add '-g' flag to gcc if it's debug build 410# Add '-g' flag to gcc if it's debug build
380if test "$enable_debug" = "yes"; then 411if test "$enable_debug" = "yes"; then
381 CXXFLAGS="$CXXFLAGS -g" 412 CXXFLAGS="$CXXFLAGS -g"
@@ -383,13 +414,20 @@ if test "$enable_debug" = "yes"; then
383fi 414fi
384 415
385# check if curl is available 416# check if curl is available
386if test "$http_backend" = "curl"; then 417if test "$with_http_backend" = "curl"; then
387 PKG_CHECK_MODULES([LIBCURL], 418 PKG_CHECK_MODULES([LIBCURL],
388 [libcurl >= $LIBCURL_REQUIRED_VERSION]) 419 [libcurl >= $LIBCURL_REQUIRED_VERSION])
389 AC_SUBST([LIBCURL_CFLAGS]) 420 AC_SUBST([LIBCURL_CFLAGS])
390 AC_SUBST([LIBCURL_LIBS]) 421 AC_SUBST([LIBCURL_LIBS])
391fi 422fi
392 423
424if test "$with_http_backend" = "soup"; then
425 PKG_CHECK_MODULES([LIBSOUP],
426 [libsoup-2.4 >= $LIBSOUP_REQUIRED_VERSION])
427 AC_SUBST([LIBSOUP_CFLAGS])
428 AC_SUBST([LIBSOUP_LIBS])
429fi
430
393# check if sqlite 3 is available 431# check if sqlite 3 is available
394if test "$enable_icon_database" = "yes" || test "$enable_database" = "yes"; then 432if test "$enable_icon_database" = "yes" || test "$enable_database" = "yes"; then
395 PKG_CHECK_MODULES([SQLITE3], [sqlite3 >= $SQLITE_REQUIRED_VERSION]) 433 PKG_CHECK_MODULES([SQLITE3], [sqlite3 >= $SQLITE_REQUIRED_VERSION])
@@ -450,7 +488,12 @@ AM_CONDITIONAL([TARGET_QUARTZ], [test "$with_target" = "quartz"])
450AM_CONDITIONAL([TARGET_DIRECTFB], [test "$with_target" = "directfb"]) 488AM_CONDITIONAL([TARGET_DIRECTFB], [test "$with_target" = "directfb"])
451 489
452# HTTP backend conditionals 490# HTTP backend conditionals
453AM_CONDITIONAL([USE_CURL], [test "$http_backend" = "curl"]) 491AM_CONDITIONAL([USE_CURL], [test "$with_http_backend" = "curl"])
492AM_CONDITIONAL([USE_SOUP], [test "$with_http_backend" = "soup"])
493
494# Font backend conditionals
495AM_CONDITIONAL([USE_FREETYPE], [test "$with_font_backend" = "freetype"])
496AM_CONDITIONAL([USE_PANGO], [test "$with_font_backend" = "pango"])
454 497
455# WebKit feature conditionals 498# WebKit feature conditionals
456AM_CONDITIONAL([ENABLE_DEBUG],[test "$enable_debug" = "yes"]) 499AM_CONDITIONAL([ENABLE_DEBUG],[test "$enable_debug" = "yes"])
@@ -485,7 +528,9 @@ WebKit was configured with the following options:
485Build configuration: 528Build configuration:
486 Enable debugging (slow) : $enable_debug 529 Enable debugging (slow) : $enable_debug
487 Code coverage support : $enable_coverage 530 Code coverage support : $enable_coverage
488 HTTP backend : $http_backend 531 Unicode backend : $unicode_backend
532 HTTP backend : $with_http_backend
533 Font backend : $with_font_backend
489 Optimized memory allocator : $enable_fast_malloc 534 Optimized memory allocator : $enable_fast_malloc
490Features: 535Features:
491 HTML5 cross-document messaging : $enable_cross_document_messaging 536 HTML5 cross-document messaging : $enable_cross_document_messaging
diff --git a/meta/packages/webkit/files/fix_im.patch b/meta/packages/webkit/files/fix_im.patch
index 4bd7b5a4cb..e69de29bb2 100644
--- a/meta/packages/webkit/files/fix_im.patch
+++ b/meta/packages/webkit/files/fix_im.patch
@@ -1,12 +0,0 @@
1Index: webkit-gtk-0.1+svnr28656-r4/WebKit/gtk/WebView/webkitwebview.cpp
2===================================================================
3--- webkit-gtk-0.1+svnr28656-r4.orig/WebKit/gtk/WebView/webkitwebview.cpp 2008-02-08 17:41:55.000000000 +0000
4+++ webkit-gtk-0.1+svnr28656-r4/WebKit/gtk/WebView/webkitwebview.cpp 2008-02-08 17:42:17.000000000 +0000
5@@ -183,6 +183,7 @@
6 hildon_gtk_im_context_filter_event(webViewData->imContext, (GdkEvent*)event);
7 hildon_gtk_im_context_show(webViewData->imContext);
8 #endif
9+ gtk_im_context_focus_in(webViewData->imContext);
10 }
11
12 return frame->eventHandler()->handleMouseReleaseEvent(PlatformMouseEvent(event));