summaryrefslogtreecommitdiffstats
path: root/meta/packages/webkit/files/configure.ac
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-03-05 13:19:52 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-03-05 13:19:52 +0000
commit5ab50f9ba2597a6f252a01ff3aeb3eaf3d9c9810 (patch)
treec6542c17cc0652a7ab7c2dea91103a6aa07ca36e /meta/packages/webkit/files/configure.ac
parenta31ec3d0f61846fe89284443c93adfb6a7b5bcf2 (diff)
downloadpoky-5ab50f9ba2597a6f252a01ff3aeb3eaf3d9c9810.tar.gz
webkit: update to 30762 from OE
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3919 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/webkit/files/configure.ac')
-rw-r--r--meta/packages/webkit/files/configure.ac217
1 files changed, 170 insertions, 47 deletions
diff --git a/meta/packages/webkit/files/configure.ac b/meta/packages/webkit/files/configure.ac
index 05c25b94a8..404e5a0d6a 100644
--- a/meta/packages/webkit/files/configure.ac
+++ b/meta/packages/webkit/files/configure.ac
@@ -9,9 +9,7 @@ AC_CONFIG_SRCDIR([WebCore/config.h])
9LIBWEBKITGTK_VERSION=1:0:0 9LIBWEBKITGTK_VERSION=1:0:0
10AC_SUBST([LIBWEBKITGTK_VERSION]) 10AC_SUBST([LIBWEBKITGTK_VERSION])
11 11
12AM_INIT_AUTOMAKE([1.9 foreign tar-ustar subdir-objects]) 12AM_INIT_AUTOMAKE([foreign subdir-objects])
13
14AM_MAINTAINER_MODE
15 13
16AC_CANONICAL_HOST 14AC_CANONICAL_HOST
17 15
@@ -35,6 +33,9 @@ case "$host" in
35 *-*-freebsd*) 33 *-*-freebsd*)
36 os_freebsd=yes 34 os_freebsd=yes
37 ;; 35 ;;
36 *-*-darwin*)
37 os_darwin=yes
38 ;;
38esac 39esac
39 40
40# If CXXFLAGS and CFLAGS are unset, default to -O2 41# If CXXFLAGS and CFLAGS are unset, default to -O2
@@ -53,9 +54,20 @@ AM_PROG_LIBTOOL
53AC_PROG_INSTALL 54AC_PROG_INSTALL
54AM_PROG_CC_STDC 55AM_PROG_CC_STDC
55AC_PROG_CXX 56AC_PROG_CXX
56AC_PROG_CXX_C_O
57AM_PROG_CC_C_O 57AM_PROG_CC_C_O
58 58
59# check for -fvisibility=hidden compiler support (GCC >= 4)
60saved_CFLAGS="$CFLAGS"
61CFLAGS="$CFLAGS -fvisibility=hidden -fvisibility-inlines-hidden"
62AC_MSG_CHECKING([if ${CXX} supports -fvisibility=hidden -fvisibility-inlines-hidden])
63AC_COMPILE_IFELSE([char foo;],
64 [ AC_MSG_RESULT([yes])
65 SYMBOL_VISIBILITY="-fvisibility=hidden" SYMBOL_VISIBILITY_INLINES="-fvisibility-inlines-hidden" ],
66 AC_MSG_RESULT([no]))
67CFLAGS="$saved_CFLAGS"
68AC_SUBST(SYMBOL_VISIBILITY)
69AC_SUBST(SYMBOL_VISIBILITY_INLINES)
70
59AC_PATH_PROG(PERL, perl) 71AC_PATH_PROG(PERL, perl)
60if test -z "$PERL"; then 72if test -z "$PERL"; then
61 AC_MSG_ERROR([You need 'perl' to compile WebKit]) 73 AC_MSG_ERROR([You need 'perl' to compile WebKit])
@@ -101,10 +113,12 @@ AC_C_VOLATILE
101AC_HEADER_STDC 113AC_HEADER_STDC
102AC_HEADER_STDBOOL 114AC_HEADER_STDBOOL
103 115
104# pthread 116# pthread (not needed on Windows)
117if test "$os_win32" = "no"; then
105AC_CHECK_HEADERS([pthread.h], 118AC_CHECK_HEADERS([pthread.h],
106 AC_DEFINE([HAVE_PTHREAD_H],[1],[Define if pthread exist]), 119 AC_DEFINE([HAVE_PTHREAD_H],[1],[Define if pthread exist]),
107 AC_MSG_ERROR([pthread support is required to build WebKit])) 120 AC_MSG_ERROR([pthread support is required to build WebKit]))
121fi
108 122
109# libjpeg headers 123# libjpeg headers
110AC_CHECK_HEADERS([jpeglib.h]) 124AC_CHECK_HEADERS([jpeglib.h])
@@ -116,75 +130,126 @@ if test "$PKG_CONFIG" = "no"; then
116fi 130fi
117 131
118# check for icu-config 132# check for icu-config
133if test "$os_darwin" = "yes"; then
134ICU_CPPFLAGS="-I\$(srcdir)/JavaScriptCore/icu -I\$(srcdir)/WebCore/icu"
135ICU_LIBS="-licucore"
136else
119AC_PATH_PROG(icu_config, icu-config, no) 137AC_PATH_PROG(icu_config, icu-config, no)
120if test "$icu_config" = "no"; then 138if test "$icu_config" = "no"; then
121 AC_MSG_ERROR([Cannot find icu-config. ICU library is needed.]) 139 AC_MSG_ERROR([Cannot find icu-config. ICU library is needed.])
122fi 140fi
123ICU_CFLAGS=`$icu_config --cflags` 141
142# We don't use --cflags as this gives us a lot of things that we don't
143# necessarily want, like debugging and optimization flags
144# See man (1) icu-config for more info.
145ICU_CPPFLAGS=`$icu_config --cppflags`
124ICU_LIBS=`$icu_config --ldflags` 146ICU_LIBS=`$icu_config --ldflags`
125AC_SUBST([ICU_CFLAGS]) 147AC_SUBST([ICU_CPPFLAGS])
126AC_SUBST([ICU_LIBS]) 148AC_SUBST([ICU_LIBS])
149fi
127 150
128# determine the GDK/GTK+ target 151# determine the GDK/GTK+ target
129AC_MSG_CHECKING([the target for WebKit GTK+]) 152AC_MSG_CHECKING([the target windowing system])
130AC_ARG_WITH(webkit_target, 153AC_ARG_WITH(target,
131 AC_HELP_STRING([--with-webkit-target=@<:@x11/win32/quartz/directfb@:>@], 154 AC_HELP_STRING([--with-target=@<:@x11/win32/quartz/directfb@:>@],
132 [Select webkit target [default=x11]]), 155 [Select webkit target [default=x11]]),
133 [],[with_webkit_target="x11"]) 156 [],[with_target="x11"])
134 157
135case "$with_webkit_target" in 158case "$with_target" in
136 x11|win32|quartz|directfb) ;; 159 x11|win32|quartz|directfb) ;;
137 *) AC_MSG_ERROR([Invalid target: must be x11, quartz, win32, or directfb.]) ;; 160 *) AC_MSG_ERROR([Invalid target: must be x11, quartz, win32, or directfb.]) ;;
138esac 161esac
139 162
140AC_MSG_RESULT([$with_webkit_target]) 163AC_MSG_RESULT([$with_target])
164
165AC_MSG_CHECKING([for Hildon UI extensions])
166AC_ARG_WITH(hildon,
167 AC_HELP_STRING([--with-hildon],
168 [Use Hildon UI extensions [default=no]]),
169 [],[with_hildon="no"])
170AC_MSG_RESULT([$with_hildon])
171
172if test "$with_hildon" = "yes"; then
173 HILDON_CPPFLAGS="-DMAEMO_CHANGES"
174 PKG_CHECK_MODULES([HILDON], [hildon-1])
175 AC_SUBST([HILDON_CPPFLAGS])
176 AC_SUBST([HILDON_CFLAGS])
177 AC_SUBST([HILDON_LIBS])
178fi
179
180# determine the http backend
181AC_MSG_CHECKING([the HTTP backend to use])
182AC_ARG_WITH(http_backend,
183 AC_HELP_STRING([--with-http-backend=@<:@curl@:>@],
184 [Select HTTP backend [default=curl]]),
185 [],[http_backend="curl"])
186
187case "$http_backend" in
188 curl) ;;
189 *) AC_MSG_ERROR([Invalid HTTP backend: must be curl.]) ;;
190esac
191
192AC_MSG_RESULT([$http_backend])
141 193
142# minimum base dependencies 194# minimum base dependencies
195CAIRO_REQUIRED_VERSION=1.4
196FONTCONFIG_REQUIRED_VERSION=2.4
197FREETYPE2_REQUIRED_VERSION=9.0
198LIBXML_REQUIRED_VERSION=2.6
199
200# minimum GTK+ base dependencies
143GLIB_REQUIRED_VERSION=2.0 201GLIB_REQUIRED_VERSION=2.0
144GOBJECT_REQUIRED_VERSION=2.0 202GOBJECT_REQUIRED_VERSION=2.0
145GTHREAD_REQUIRED_VERSION=2.0 203GTHREAD_REQUIRED_VERSION=2.0
146PANGO_REQUIRED_VERSION=1.0 204PANGO_REQUIRED_VERSION=1.0
147CAIRO_REQUIRED_VERSION=1.2 205GTK_REQUIRED_VERSION=2.8
148FONTCONFIG_REQUIRED_VERSION=2.4
149FREETYPE2_REQUIRED_VERSION=9.0
150LIBCURL_REQUIRED_VERSION=7.15
151LIBXML_REQUIRED_VERSION=2.6
152 206
153# optional modules 207# optional modules
154GTK_REQUIRED_VERSION=2.0 208LIBCURL_REQUIRED_VERSION=7.15
155LIBXSLT_REQUIRED_VERSION=1.1.7 209LIBXSLT_REQUIRED_VERSION=1.1.7
156SQLITE_REQUIRED_VERSION=3.0 210SQLITE_REQUIRED_VERSION=3.0
157GSTREAMER_REQUIRED_VERSION=0.10 211GSTREAMER_REQUIRED_VERSION=0.10
158GNOME_VFS_REQUIRED_VERSION=2.0 212GNOME_VFS_REQUIRED_VERSION=2.0
159 213
160PKG_CHECK_MODULES([DEPENDENCIES], 214PKG_CHECK_MODULES([GLOBALDEPS],
161 [glib-2.0 >= $GLIB_REQUIRED_VERSION 215 [glib-2.0 >= $GLIB_REQUIRED_VERSION
162 gobject-2.0 >= $GOBJECT_REQUIRED_VERSION 216 gobject-2.0 >= $GOBJECT_REQUIRED_VERSION
163 gthread-2.0 >= $GTHREAD_REQUIRED_VERSION 217 gthread-2.0 >= $GTHREAD_REQUIRED_VERSION])
164 gtk+-2.0 >= $GTK_REQUIRED_VERSION 218AC_SUBST([GLOBALDEPS_CFLAGS])
219AC_SUBST([GLOBALDEPS_LIBS])
220
221PKG_CHECK_MODULES([WEBKITDEPS],
222 [gtk+-2.0 >= $GTK_REQUIRED_VERSION
165 pango >= $PANGO_REQUIRED_VERSION 223 pango >= $PANGO_REQUIRED_VERSION
166 libcurl >= $LIBCURL_REQUIRED_VERSION
167 cairo >= $CAIRO_REQUIRED_VERSION 224 cairo >= $CAIRO_REQUIRED_VERSION
168 cairo-ft, 225 cairo-ft,
169 fontconfig >= $FONTCONFIG_REQUIRED_VERSION 226 fontconfig >= $FONTCONFIG_REQUIRED_VERSION
170 freetype2 >= $FREETYPE2_REQUIRED_VERSION 227 freetype2 >= $FREETYPE2_REQUIRED_VERSION
171 libxml-2.0 >= $LIBXML_REQUIRED_VERSION]) 228 libxml-2.0 >= $LIBXML_REQUIRED_VERSION])
172AC_SUBST([DEPENDENCIES_CFLAGS]) 229AC_SUBST([WEBKITDEPS_CFLAGS])
173AC_SUBST([DEPENDENCIES_LIBS]) 230AC_SUBST([WEBKITDEPS_LIBS])
174 231
175# check whether to build with debugging enabled 232# check whether to build with debugging enabled
176AC_MSG_CHECKING([whether to do a debug build]) 233AC_MSG_CHECKING([whether to do a debug build])
177AC_ARG_ENABLE(debug, 234AC_ARG_ENABLE(debug,
178 AC_HELP_STRING([--enable-debug], 235 AC_HELP_STRING([--enable-debug],
179 [turn on debugging [default=no]]), 236 [turn on debugging [default=no]]),
180 [enable_debug="yes"],[enable_debug="no"]) 237 [],[enable_debug="no"])
181AC_MSG_RESULT([$enable_debug]) 238AC_MSG_RESULT([$enable_debug])
182 239
240# check whether to build with cross-document messaging support
241AC_MSG_CHECKING([whether to enable HTML5 cross-document messaging support])
242AC_ARG_ENABLE(cross_document_messaging,
243 AC_HELP_STRING([--enable-cross-document-messaging],
244 [enable HTML5 cross-document messaging support [default=yes]]),
245 [],[enable_cross_document_messaging="yes"])
246AC_MSG_RESULT([$enable_cross_document_messaging])
247
183# check whether to build with database support 248# check whether to build with database support
184AC_MSG_CHECKING([whether to enable HTML5 client-side storage support]) 249AC_MSG_CHECKING([whether to enable HTML5 client-side storage support])
185AC_ARG_ENABLE(database, 250AC_ARG_ENABLE(database,
186 AC_HELP_STRING([--enable-database], 251 AC_HELP_STRING([--enable-database],
187 [enable HTML5 client-side storage support [default=no]]), 252 [enable HTML5 client-side storage support [default=yes]]),
188 [],[enable_database="yes"]) 253 [],[enable_database="yes"])
189AC_MSG_RESULT([$enable_database]) 254AC_MSG_RESULT([$enable_database])
190 255
@@ -201,14 +266,14 @@ AC_MSG_CHECKING([whether to enable HTML5 video support])
201AC_ARG_ENABLE(video, 266AC_ARG_ENABLE(video,
202 AC_HELP_STRING([--enable-video], 267 AC_HELP_STRING([--enable-video],
203 [enable HTML5 video support [default=no]]), 268 [enable HTML5 video support [default=no]]),
204 [enable_video="yes"],[enable_video="no"]) 269 [],[enable_video="no"])
205AC_MSG_RESULT([$enable_video]) 270AC_MSG_RESULT([$enable_video])
206 271
207# check whether to enable XPath support 272# check whether to enable XPath support
208AC_MSG_CHECKING([whether to enable XPath support]) 273AC_MSG_CHECKING([whether to enable XPath support])
209AC_ARG_ENABLE(xpath, 274AC_ARG_ENABLE(xpath,
210 AC_HELP_STRING([--enable-xpath], 275 AC_HELP_STRING([--enable-xpath],
211 [enable support for XPath [default=no]]), 276 [enable support for XPath [default=yes]]),
212 [],[enable_xpath="yes"]) 277 [],[enable_xpath="yes"])
213AC_MSG_RESULT([$enable_xpath]) 278AC_MSG_RESULT([$enable_xpath])
214 279
@@ -216,10 +281,29 @@ AC_MSG_RESULT([$enable_xpath])
216AC_MSG_CHECKING([whether to enable XSLT support]) 281AC_MSG_CHECKING([whether to enable XSLT support])
217AC_ARG_ENABLE(xslt, 282AC_ARG_ENABLE(xslt,
218 AC_HELP_STRING([--enable-xslt], 283 AC_HELP_STRING([--enable-xslt],
219 [enable support for XSLT [default=no]]), 284 [enable support for XSLT [default=yes]]),
220 [],[enable_xslt="yes"]) 285 [],[enable_xslt="yes"])
221AC_MSG_RESULT([$enable_xslt]) 286AC_MSG_RESULT([$enable_xslt])
222 287
288# check whether to enable SVG experimental features
289# Enable all SVG if it is
290AC_MSG_CHECKING([whether to enable SVG experimental features])
291AC_ARG_ENABLE(svg_experimental,
292 AC_HELP_STRING([--enable-svg-experimental],
293 [enable support for SVG experimental features [default=no]]),
294 [],[enable_svg_experimental="no"])
295AC_MSG_RESULT([$enable_svg_experimental])
296
297if test "$enable_svg_experimental" = "yes"; then
298 enable_svg=yes
299 enable_svg_animation=yes
300# enable_svg_filters=yes
301 enable_svg_fonts=yes
302 enable_svg_foreign_object=yes
303 enable_svg_as_image=yes
304 enable_svg_use_element=yes
305fi
306
223# check whether to enable SVG support 307# check whether to enable SVG support
224AC_MSG_CHECKING([whether to enable SVG support]) 308AC_MSG_CHECKING([whether to enable SVG support])
225AC_ARG_ENABLE(svg, 309AC_ARG_ENABLE(svg,
@@ -229,10 +313,10 @@ AC_ARG_ENABLE(svg,
229AC_MSG_RESULT([$enable_svg]) 313AC_MSG_RESULT([$enable_svg])
230 314
231# check whether to enable support for SVG animation 315# check whether to enable support for SVG animation
232AC_MSG_CHECKING([whether to enable support for SVG animataion]) 316AC_MSG_CHECKING([whether to enable support for SVG animation])
233AC_ARG_ENABLE(svg_animation, 317AC_ARG_ENABLE(svg_animation,
234 AC_HELP_STRING([--enable-svg-animation], 318 AC_HELP_STRING([--enable-svg-animation],
235 [enable support for SVG animation feature (experimental) [default=no]]), 319 [enable support for SVG animation (experimental) [default=no]]),
236 [],[enable_svg_animation="no"]) 320 [],[enable_svg_animation="no"])
237AC_MSG_RESULT([$enable_svg_animation]) 321AC_MSG_RESULT([$enable_svg_animation])
238 322
@@ -252,6 +336,14 @@ AC_ARG_ENABLE(svg_fonts,
252 [],[enable_svg_fonts="no"]) 336 [],[enable_svg_fonts="no"])
253AC_MSG_RESULT([$enable_svg_fonts]) 337AC_MSG_RESULT([$enable_svg_fonts])
254 338
339# check whether to enable foreign objects support for SVG
340AC_MSG_CHECKING([whether to enable support for SVG foreign objects])
341AC_ARG_ENABLE(svg_foreign_object,
342 AC_HELP_STRING([--enable-svg-foreign-object],
343 [enable support for SVG foreign objects (experimental) [default=no]]),
344 [],[enable_svg_foreign_object="no"])
345AC_MSG_RESULT([$enable_svg_foreign_object])
346
255# check whether to enable SVG As Image support 347# check whether to enable SVG As Image support
256AC_MSG_CHECKING([whether to enable SVG as Image support]) 348AC_MSG_CHECKING([whether to enable SVG as Image support])
257AC_ARG_ENABLE(svg_as_image, 349AC_ARG_ENABLE(svg_as_image,
@@ -276,19 +368,35 @@ AC_ARG_ENABLE(coverage,
276 [],[enable_coverage="no"]) 368 [],[enable_coverage="no"])
277AC_MSG_RESULT([$enable_coverage]) 369AC_MSG_RESULT([$enable_coverage])
278 370
371# check whether to enable FastMalloc
372AC_MSG_CHECKING([whether to enable optimized memory allocator])
373AC_ARG_ENABLE(fast_malloc,
374 AC_HELP_STRING([--enable-fast-malloc],
375 [enable optimized memory allocator default=yes, default=no for debug builds]),
376 [],[if test "$enable_debug" = "yes"; then enable_fast_malloc="no"; else enable_fast_malloc="yes"; fi])
377AC_MSG_RESULT([$enable_fast_malloc])
378
279# Add '-g' flag to gcc if it's debug build 379# Add '-g' flag to gcc if it's debug build
280if test "$enable_debug" = "yes"; then 380if test "$enable_debug" = "yes"; then
281 CXXFLAGS="$CXXFLAGS -g" 381 CXXFLAGS="$CXXFLAGS -g"
282 CFLAGS="$CFLAGS -g" 382 CFLAGS="$CFLAGS -g"
283fi 383fi
284 384
385# check if curl is available
386if test "$http_backend" = "curl"; then
387 PKG_CHECK_MODULES([LIBCURL],
388 [libcurl >= $LIBCURL_REQUIRED_VERSION])
389 AC_SUBST([LIBCURL_CFLAGS])
390 AC_SUBST([LIBCURL_LIBS])
391fi
392
285# check if sqlite 3 is available 393# check if sqlite 3 is available
286if test "$enable_icon_database" = "yes" || test "$enable_database" = "yes"; then 394if test "$enable_icon_database" = "yes" || test "$enable_database" = "yes"; then
287 PKG_CHECK_MODULES([SQLITE3], [sqlite3 >= $SQLITE_REQUIRED_VERSION]) 395 PKG_CHECK_MODULES([SQLITE3], [sqlite3 >= $SQLITE_REQUIRED_VERSION])
288 AC_SUBST([SQLITE3_CFLAGS]) 396 AC_SUBST([SQLITE3_CFLAGS])
289 AC_SUBST([SQLITE3_LIBS]) 397 AC_SUBST([SQLITE3_LIBS])
290fi 398fi
291 399
292# check if libxslt is available 400# check if libxslt is available
293if test "$enable_xslt" = "yes"; then 401if test "$enable_xslt" = "yes"; then
294 PKG_CHECK_MODULES([LIBXSLT],[libxslt >= $LIBXSLT_REQUIRED_VERSION]) 402 PKG_CHECK_MODULES([LIBXSLT],[libxslt >= $LIBXSLT_REQUIRED_VERSION])
@@ -316,16 +424,17 @@ if test "$enable_coverage" = "yes"; then
316fi 424fi
317 425
318# check for SVG features, enabling SVG if necessary 426# check for SVG features, enabling SVG if necessary
319if test "$enable_svg" = "no" && (\ 427if test "$enable_svg_animation" = "yes" || \
320 test "$enable_svg_animation" = "yes" || \
321 test "$enable_svg_filters" = "yes" || \ 428 test "$enable_svg_filters" = "yes" || \
322 test "$enable_svg_fonts" = "yes" || \ 429 test "$enable_svg_fonts" = "yes" || \
430 test "$enable_svg_foreign_object" = "yes" || \
323 test "$enable_svg_as_image" = "yes" || \ 431 test "$enable_svg_as_image" = "yes" || \
324 test "$enable_svg_use_element" = "yes"); then 432 test "$enable_svg_use_element" = "yes"; then
325 433 svg_flags=yes
326 AC_MSG_WARN([SVG feature(s) requested but SVG is disabled.. Enabling SVG support]) 434 if test "$enable_svg" = "no"; then
327 enable_svg = yes 435 AC_MSG_WARN([SVG feature(s) requested but SVG is disabled.. Enabling SVG support])
328 svg_flags = yes 436 enable_svg=yes
437 fi
329fi 438fi
330 439
331# OS conditionals 440# OS conditionals
@@ -335,13 +444,17 @@ AM_CONDITIONAL([OS_LINUX],[test "$os_linux" = "yes"])
335AM_CONDITIONAL([OS_FREEBSD],[test "$os_freebsd" = "yes"]) 444AM_CONDITIONAL([OS_FREEBSD],[test "$os_freebsd" = "yes"])
336 445
337# target conditionals 446# target conditionals
338AM_CONDITIONAL([TARGET_X11], [test "$with_webkit_target" = "x11"]) 447AM_CONDITIONAL([TARGET_X11], [test "$with_target" = "x11"])
339AM_CONDITIONAL([TARGET_WIN32], [test "$with_webkit_target" = "win32"]) 448AM_CONDITIONAL([TARGET_WIN32], [test "$with_target" = "win32"])
340AM_CONDITIONAL([TARGET_QUARTZ], [test "$with_webkit_target" = "quartz"]) 449AM_CONDITIONAL([TARGET_QUARTZ], [test "$with_target" = "quartz"])
341AM_CONDITIONAL([TARGET_DIRECTFB], [test "$with_webkit_target" = "directfb"]) 450AM_CONDITIONAL([TARGET_DIRECTFB], [test "$with_target" = "directfb"])
451
452# HTTP backend conditionals
453AM_CONDITIONAL([USE_CURL], [test "$http_backend" = "curl"])
342 454
343# WebKit feature conditionals 455# WebKit feature conditionals
344AM_CONDITIONAL([ENABLE_DEBUG],[test "$enable_debug" = "yes"]) 456AM_CONDITIONAL([ENABLE_DEBUG],[test "$enable_debug" = "yes"])
457AM_CONDITIONAL([ENABLE_CROSS_DOCUMENT_MESSAGING],[test "$enable_cross_document_messaging" = "yes"])
345AM_CONDITIONAL([ENABLE_DATABASE],[test "$enable_database" = "yes"]) 458AM_CONDITIONAL([ENABLE_DATABASE],[test "$enable_database" = "yes"])
346AM_CONDITIONAL([ENABLE_ICONDATABASE],[test "$enable_icon_database" = "yes"]) 459AM_CONDITIONAL([ENABLE_ICONDATABASE],[test "$enable_icon_database" = "yes"])
347AM_CONDITIONAL([ENABLE_XPATH],[test "$enable_xpath" = "yes"]) 460AM_CONDITIONAL([ENABLE_XPATH],[test "$enable_xpath" = "yes"])
@@ -351,14 +464,16 @@ AM_CONDITIONAL([ENABLE_SVG],[test "$enable_svg" = "yes"])
351AM_CONDITIONAL([ENABLE_SVG_ANIMATION],[test "$enable_svg_animation" = "yes"]) 464AM_CONDITIONAL([ENABLE_SVG_ANIMATION],[test "$enable_svg_animation" = "yes"])
352AM_CONDITIONAL([ENABLE_SVG_FILTERS],[test "$enable_svg_filters" = "yes"]) 465AM_CONDITIONAL([ENABLE_SVG_FILTERS],[test "$enable_svg_filters" = "yes"])
353AM_CONDITIONAL([ENABLE_SVG_FONTS],[test "$enable_svg_fonts" = "yes"]) 466AM_CONDITIONAL([ENABLE_SVG_FONTS],[test "$enable_svg_fonts" = "yes"])
467AM_CONDITIONAL([ENABLE_SVG_FOREIGN_OBJECT],[test "$enable_svg_foreign_object" = "yes"])
354AM_CONDITIONAL([ENABLE_SVG_AS_IMAGE],[test "$enable_svg_as_image" = "yes"]) 468AM_CONDITIONAL([ENABLE_SVG_AS_IMAGE],[test "$enable_svg_as_image" = "yes"])
355AM_CONDITIONAL([ENABLE_SVG_USE],[test "$enable_svg_use_element" = "yes"]) 469AM_CONDITIONAL([ENABLE_SVG_USE],[test "$enable_svg_use_element" = "yes"])
356AM_CONDITIONAL([ENABLE_COVERAGE],[test "$enable_coverage" = "yes"]) 470AM_CONDITIONAL([ENABLE_COVERAGE],[test "$enable_coverage" = "yes"])
471AM_CONDITIONAL([ENABLE_FAST_MALLOC],[test "$enable_fast_malloc" = "yes"])
357AM_CONDITIONAL([SVG_FLAGS],[test "$svg_flags" = "yes"]) 472AM_CONDITIONAL([SVG_FLAGS],[test "$svg_flags" = "yes"])
358 473
359AC_CONFIG_FILES([ 474AC_CONFIG_FILES([
360GNUmakefile 475GNUmakefile
361WebKit/gtk/WebKitGtk.pc:WebKit/gtk/WebKitGtk.pc.in 476WebKit/gtk/webkit-1.0.pc:WebKit/gtk/webkit.pc.in
362] 477]
363) 478)
364 479
@@ -367,9 +482,13 @@ AC_OUTPUT
367echo " 482echo "
368WebKit was configured with the following options: 483WebKit was configured with the following options:
369 484
370 Target : $with_webkit_target 485Build configuration:
371 Enable debug : $enable_debug 486 Enable debugging (slow) : $enable_debug
372 Code coverage support : $enable_coverage 487 Code coverage support : $enable_coverage
488 HTTP backend : $http_backend
489 Optimized memory allocator : $enable_fast_malloc
490Features:
491 HTML5 cross-document messaging : $enable_cross_document_messaging
373 HTML5 client-side storage support : $enable_database 492 HTML5 client-side storage support : $enable_database
374 HTML5 video element support : $enable_video 493 HTML5 video element support : $enable_video
375 Icon database support : $enable_icon_database 494 Icon database support : $enable_icon_database
@@ -377,8 +496,12 @@ WebKit was configured with the following options:
377 SVG animation support : $enable_svg_animation 496 SVG animation support : $enable_svg_animation
378 SVG filters support : $enable_svg_filters 497 SVG filters support : $enable_svg_filters
379 SVG fonts support : $enable_svg_fonts 498 SVG fonts support : $enable_svg_fonts
499 SVG foreign object support : $enable_svg_foreign_object
380 SVG as image support : $enable_svg_as_image 500 SVG as image support : $enable_svg_as_image
381 SVG use element support : $enable_svg_use_element 501 SVG use element support : $enable_svg_use_element
382 XPATH support : $enable_xpath 502 XPATH support : $enable_xpath
383 XSLT support : $enable_xslt 503 XSLT support : $enable_xslt
504GTK+ configuration:
505 GDK target : $with_target
506 Hildon UI extensions : $with_hildon
384" 507"