summaryrefslogtreecommitdiffstats
path: root/meta/packages/webkit/files/configure.ac
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-03-31 18:34:18 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-03-31 18:34:18 +0000
commit133a314a4f1d38fc93d37caf204c9946b92eccf3 (patch)
treea985dc190621c74caedb209b156cd5117cb77428 /meta/packages/webkit/files/configure.ac
parent544fa41378c23e3e5b4519fa8fecb9351f299b6c (diff)
downloadpoky-133a314a4f1d38fc93d37caf204c9946b92eccf3.tar.gz
webkit: upgraded to rev 31467, enabled SVG fonts
http://bugs.webkit.org/show_bug.cgi?id=18239 was reported as SVG fonts support is required to make Webkit built. git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4151 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/webkit/files/configure.ac')
-rw-r--r--meta/packages/webkit/files/configure.ac95
1 files changed, 70 insertions, 25 deletions
diff --git a/meta/packages/webkit/files/configure.ac b/meta/packages/webkit/files/configure.ac
index 404e5a0d6a..64f32dc689 100644
--- a/meta/packages/webkit/files/configure.ac
+++ b/meta/packages/webkit/files/configure.ac
@@ -129,25 +129,42 @@ if test "$PKG_CONFIG" = "no"; then
129 AC_MSG_ERROR([Cannot find pkg-config, make sure it is installed in your PATH]) 129 AC_MSG_ERROR([Cannot find pkg-config, make sure it is installed in your PATH])
130fi 130fi
131 131
132# check for icu-config 132# determine the Unicode backend
133if test "$os_darwin" = "yes"; then 133AC_MSG_CHECKING([the Unicode backend to use])
134ICU_CPPFLAGS="-I\$(srcdir)/JavaScriptCore/icu -I\$(srcdir)/WebCore/icu" 134AC_ARG_WITH(unicode_backend,
135ICU_LIBS="-licucore" 135 AC_HELP_STRING([--with-unicode-backend=@<:@icu@:>@],
136else 136 [Select Unicode backend [default=icu]]),
137AC_PATH_PROG(icu_config, icu-config, no) 137 [],[unicode_backend="icu"])
138if test "$icu_config" = "no"; then 138
139 AC_MSG_ERROR([Cannot find icu-config. ICU library is needed.]) 139case "$unicode_backend" in
140fi 140 icu) ;;
141 *) AC_MSG_ERROR([Invalid Unicode backend: must be icu.]) ;;
142esac
141 143
142# We don't use --cflags as this gives us a lot of things that we don't 144AC_MSG_RESULT([$unicode_backend])
143# necessarily want, like debugging and optimization flags 145
144# See man (1) icu-config for more info. 146if test "$unicode_backend" = "icu"; then
145ICU_CPPFLAGS=`$icu_config --cppflags` 147 # check for icu-config
146ICU_LIBS=`$icu_config --ldflags` 148 if test "$os_darwin" = "yes"; then
147AC_SUBST([ICU_CPPFLAGS]) 149 UNICODE_CFLAGS="-I\$(srcdir)/JavaScriptCore/icu -I\$(srcdir)/WebCore/icu"
148AC_SUBST([ICU_LIBS]) 150 UNICODE_LIBS="-licucore"
151 else
152 AC_PATH_PROG(icu_config, icu-config, no)
153 if test "$icu_config" = "no"; then
154 AC_MSG_ERROR([Cannot find icu-config. The ICU library is needed.])
155 fi
156
157 # We don't use --cflags as this gives us a lot of things that we don't
158 # necessarily want, like debugging and optimization flags
159 # See man (1) icu-config for more info.
160 UNICODE_CFLAGS=`$icu_config --cppflags`
161 UNICODE_LIBS=`$icu_config --ldflags`
162 fi
149fi 163fi
150 164
165AC_SUBST([UNICODE_CFLAGS])
166AC_SUBST([UNICODE_LIBS])
167
151# determine the GDK/GTK+ target 168# determine the GDK/GTK+ target
152AC_MSG_CHECKING([the target windowing system]) 169AC_MSG_CHECKING([the target windowing system])
153AC_ARG_WITH(target, 170AC_ARG_WITH(target,
@@ -180,16 +197,16 @@ fi
180# determine the http backend 197# determine the http backend
181AC_MSG_CHECKING([the HTTP backend to use]) 198AC_MSG_CHECKING([the HTTP backend to use])
182AC_ARG_WITH(http_backend, 199AC_ARG_WITH(http_backend,
183 AC_HELP_STRING([--with-http-backend=@<:@curl@:>@], 200 AC_HELP_STRING([--with-http-backend=@<:@curl/soup@:>@],
184 [Select HTTP backend [default=curl]]), 201 [Select HTTP backend [default=curl]]),
185 [],[http_backend="curl"]) 202 [],[with_http_backend="curl"])
186 203
187case "$http_backend" in 204case "$with_http_backend" in
188 curl) ;; 205 curl|soup) ;;
189 *) AC_MSG_ERROR([Invalid HTTP backend: must be curl.]) ;; 206 *) AC_MSG_ERROR([Invalid HTTP backend: must be curl, soup.]) ;;
190esac 207esac
191 208
192AC_MSG_RESULT([$http_backend]) 209AC_MSG_RESULT([$with_http_backend])
193 210
194# minimum base dependencies 211# minimum base dependencies
195CAIRO_REQUIRED_VERSION=1.4 212CAIRO_REQUIRED_VERSION=1.4
@@ -206,6 +223,7 @@ GTK_REQUIRED_VERSION=2.8
206 223
207# optional modules 224# optional modules
208LIBCURL_REQUIRED_VERSION=7.15 225LIBCURL_REQUIRED_VERSION=7.15
226LIBSOUP_REQUIRED_VERSION=2.4
209LIBXSLT_REQUIRED_VERSION=1.1.7 227LIBXSLT_REQUIRED_VERSION=1.1.7
210SQLITE_REQUIRED_VERSION=3.0 228SQLITE_REQUIRED_VERSION=3.0
211GSTREAMER_REQUIRED_VERSION=0.10 229GSTREAMER_REQUIRED_VERSION=0.10
@@ -376,6 +394,19 @@ AC_ARG_ENABLE(fast_malloc,
376 [],[if test "$enable_debug" = "yes"; then enable_fast_malloc="no"; else enable_fast_malloc="yes"; fi]) 394 [],[if test "$enable_debug" = "yes"; then enable_fast_malloc="no"; else enable_fast_malloc="yes"; fi])
377AC_MSG_RESULT([$enable_fast_malloc]) 395AC_MSG_RESULT([$enable_fast_malloc])
378 396
397# determine the font backend
398AC_MSG_CHECKING([the font backend to use])
399AC_ARG_WITH(font_backend,
400 AC_HELP_STRING([--with-font-backend=@<:@freetype/pango@:>@],
401 [Select font backend [default=freetype]]),
402 [],[with_font_backend="freetype"])
403
404case "$with_font_backend" in
405 freetype|pango) ;;
406 *) AC_MSG_ERROR([Invalid font backend: must be freetype or pango.]) ;;
407esac
408AC_MSG_RESULT([$with_font_backend])
409
379# Add '-g' flag to gcc if it's debug build 410# Add '-g' flag to gcc if it's debug build
380if test "$enable_debug" = "yes"; then 411if test "$enable_debug" = "yes"; then
381 CXXFLAGS="$CXXFLAGS -g" 412 CXXFLAGS="$CXXFLAGS -g"
@@ -383,13 +414,20 @@ if test "$enable_debug" = "yes"; then
383fi 414fi
384 415
385# check if curl is available 416# check if curl is available
386if test "$http_backend" = "curl"; then 417if test "$with_http_backend" = "curl"; then
387 PKG_CHECK_MODULES([LIBCURL], 418 PKG_CHECK_MODULES([LIBCURL],
388 [libcurl >= $LIBCURL_REQUIRED_VERSION]) 419 [libcurl >= $LIBCURL_REQUIRED_VERSION])
389 AC_SUBST([LIBCURL_CFLAGS]) 420 AC_SUBST([LIBCURL_CFLAGS])
390 AC_SUBST([LIBCURL_LIBS]) 421 AC_SUBST([LIBCURL_LIBS])
391fi 422fi
392 423
424if test "$with_http_backend" = "soup"; then
425 PKG_CHECK_MODULES([LIBSOUP],
426 [libsoup-2.4 >= $LIBSOUP_REQUIRED_VERSION])
427 AC_SUBST([LIBSOUP_CFLAGS])
428 AC_SUBST([LIBSOUP_LIBS])
429fi
430
393# check if sqlite 3 is available 431# check if sqlite 3 is available
394if test "$enable_icon_database" = "yes" || test "$enable_database" = "yes"; then 432if test "$enable_icon_database" = "yes" || test "$enable_database" = "yes"; then
395 PKG_CHECK_MODULES([SQLITE3], [sqlite3 >= $SQLITE_REQUIRED_VERSION]) 433 PKG_CHECK_MODULES([SQLITE3], [sqlite3 >= $SQLITE_REQUIRED_VERSION])
@@ -450,7 +488,12 @@ AM_CONDITIONAL([TARGET_QUARTZ], [test "$with_target" = "quartz"])
450AM_CONDITIONAL([TARGET_DIRECTFB], [test "$with_target" = "directfb"]) 488AM_CONDITIONAL([TARGET_DIRECTFB], [test "$with_target" = "directfb"])
451 489
452# HTTP backend conditionals 490# HTTP backend conditionals
453AM_CONDITIONAL([USE_CURL], [test "$http_backend" = "curl"]) 491AM_CONDITIONAL([USE_CURL], [test "$with_http_backend" = "curl"])
492AM_CONDITIONAL([USE_SOUP], [test "$with_http_backend" = "soup"])
493
494# Font backend conditionals
495AM_CONDITIONAL([USE_FREETYPE], [test "$with_font_backend" = "freetype"])
496AM_CONDITIONAL([USE_PANGO], [test "$with_font_backend" = "pango"])
454 497
455# WebKit feature conditionals 498# WebKit feature conditionals
456AM_CONDITIONAL([ENABLE_DEBUG],[test "$enable_debug" = "yes"]) 499AM_CONDITIONAL([ENABLE_DEBUG],[test "$enable_debug" = "yes"])
@@ -485,7 +528,9 @@ WebKit was configured with the following options:
485Build configuration: 528Build configuration:
486 Enable debugging (slow) : $enable_debug 529 Enable debugging (slow) : $enable_debug
487 Code coverage support : $enable_coverage 530 Code coverage support : $enable_coverage
488 HTTP backend : $http_backend 531 Unicode backend : $unicode_backend
532 HTTP backend : $with_http_backend
533 Font backend : $with_font_backend
489 Optimized memory allocator : $enable_fast_malloc 534 Optimized memory allocator : $enable_fast_malloc
490Features: 535Features:
491 HTML5 cross-document messaging : $enable_cross_document_messaging 536 HTML5 cross-document messaging : $enable_cross_document_messaging