summaryrefslogtreecommitdiffstats
path: root/meta/packages/web
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-04-14 22:11:08 +0000
committerRichard Purdie <richard@openedhand.com>2008-04-14 22:11:08 +0000
commitd6c7475e2466922a95a8254aaebd86c1c1a4cd58 (patch)
tree6e0cb9846744c176358faa26df567de20109bcdd /meta/packages/web
parent0ba7ff12f8ce8438ca9df3991797bc4c28b630a2 (diff)
downloadpoky-d6c7475e2466922a95a8254aaebd86c1c1a4cd58.tar.gz
web-webkit: Add patch to configure for linking with g++ tweak else it breaks with libtool 2.2.2
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4253 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/web')
-rw-r--r--meta/packages/web/web-webkit/link-with-g++.patch19
-rw-r--r--meta/packages/web/web-webkit_svn.bb2
2 files changed, 17 insertions, 4 deletions
diff --git a/meta/packages/web/web-webkit/link-with-g++.patch b/meta/packages/web/web-webkit/link-with-g++.patch
index 946d950cfd..50d6e93792 100644
--- a/meta/packages/web/web-webkit/link-with-g++.patch
+++ b/meta/packages/web/web-webkit/link-with-g++.patch
@@ -1,7 +1,8 @@
1--- 1The main webkit library links against stdc++ so we need to use g++ for
2 src/Makefile.am | 2 +- 2linking. The easiest way to achieve this is to add a dummy cpp file.
3 1 file changed, 1 insertion(+), 1 deletion(-) 3This also means we have to add AC_PROG_CXX else libtool 2.2.2 gets upset.
4 4
5RP - 14/4/08
5--- webkit.orig/src/Makefile.am 6--- webkit.orig/src/Makefile.am
6+++ webkit/src/Makefile.am 7+++ webkit/src/Makefile.am
7@@ -1,11 +1,11 @@ 8@@ -1,11 +1,11 @@
@@ -17,3 +18,15 @@
17 MAINTAINERCLEANFILES = config.h.in Makefile.in 18 MAINTAINERCLEANFILES = config.h.in Makefile.in
18 19
19 uidir = $(pkgdatadir) 20 uidir = $(pkgdatadir)
21Index: webkit/configure.ac
22===================================================================
23--- webkit.orig/configure.ac 2008-04-14 22:15:25.000000000 +0100
24+++ webkit/configure.ac 2008-04-14 22:16:31.000000000 +0100
25@@ -7,6 +7,7 @@
26
27 AC_ISC_POSIX
28 AC_PROG_CC
29+AC_PROG_CXX
30 AC_STDC_HEADERS
31 AC_PROG_LIBTOOL
32
diff --git a/meta/packages/web/web-webkit_svn.bb b/meta/packages/web/web-webkit_svn.bb
index e6789c8806..75b3cf0cdf 100644
--- a/meta/packages/web/web-webkit_svn.bb
+++ b/meta/packages/web/web-webkit_svn.bb
@@ -4,7 +4,7 @@ SECTION = "x11"
4DEPENDS = "libxml2 glib-2.0 gtk+ libglade webkit-gtk curl gconf js libowl" 4DEPENDS = "libxml2 glib-2.0 gtk+ libglade webkit-gtk curl gconf js libowl"
5 5
6PV = "0.0+svnr${SRCREV}" 6PV = "0.0+svnr${SRCREV}"
7PR = "r1" 7PR = "r2"
8 8
9SRC_URI = "svn://svn.o-hand.com/repos/web/branches;module=webkit;proto=http \ 9SRC_URI = "svn://svn.o-hand.com/repos/web/branches;module=webkit;proto=http \
10 file://link-with-g++.patch;patch=1" 10 file://link-with-g++.patch;patch=1"