diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:14:24 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:29:45 +0100 |
commit | 29d6678fd546377459ef75cf54abeef5b969b5cf (patch) | |
tree | 8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/packages/valgrind | |
parent | da49de6885ee1bc424e70bc02f21f6ab920efb55 (diff) | |
download | poky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz |
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things
and is generally overwhelming. This commit splits it into several
logical sections roughly based on function, recipes.txt gives more
information about the classifications used.
The opportunity is also used to switch from "packages" to "recipes"
as used in OpenEmbedded as the term "packages" can be confusing to
people and has many different meanings.
Not all recipes have been classified yet, this is just a first pass
at separating things out. Some packages are moved to meta-extras as
they're no longer actively used or maintained.
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/valgrind')
-rw-r--r-- | meta/packages/valgrind/valgrind/fix_issue_caused_by_ccache.patch | 30 | ||||
-rw-r--r-- | meta/packages/valgrind/valgrind/valgrind_3.5.0-svn_r11264.patch.bz2 | bin | 3681800 -> 0 bytes | |||
-rw-r--r-- | meta/packages/valgrind/valgrind_3.5.0.bb | 24 |
3 files changed, 0 insertions, 54 deletions
diff --git a/meta/packages/valgrind/valgrind/fix_issue_caused_by_ccache.patch b/meta/packages/valgrind/valgrind/fix_issue_caused_by_ccache.patch deleted file mode 100644 index a5c273c45b..0000000000 --- a/meta/packages/valgrind/valgrind/fix_issue_caused_by_ccache.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | The script does not expect use of ccache, hence fix it to recognise it. | ||
2 | |||
3 | 2010/08/17 | ||
4 | Nitin A Kamble <nitin.a.kamble@intel.com> | ||
5 | |||
6 | Index: valgrind-3.5.0/coregrind/link_tool_exe_linux.in | ||
7 | =================================================================== | ||
8 | --- valgrind-3.5.0.orig/coregrind/link_tool_exe_linux.in | ||
9 | +++ valgrind-3.5.0/coregrind/link_tool_exe_linux.in | ||
10 | @@ -62,6 +62,11 @@ die "Bogus alt-load address" | ||
11 | |||
12 | # The cc invokation to do the final link | ||
13 | my $cc = $ARGV[1]; | ||
14 | +my $next = 2; | ||
15 | +if ("$cc" eq "ccache") { | ||
16 | + $cc = "$cc $ARGV[2]"; | ||
17 | + $next = 3; | ||
18 | +} | ||
19 | |||
20 | # and the 'restargs' are argv[2 ..] | ||
21 | |||
22 | @@ -71,7 +76,7 @@ my $cc = $ARGV[1]; | ||
23 | my $cmd="$cc -static -Wl,-Ttext=$ala"; | ||
24 | |||
25 | # Add the rest of the parameters | ||
26 | -foreach my $n (2 .. $#ARGV) { | ||
27 | +foreach my $n ($next .. $#ARGV) { | ||
28 | $cmd = "$cmd $ARGV[$n]"; | ||
29 | } | ||
30 | |||
diff --git a/meta/packages/valgrind/valgrind/valgrind_3.5.0-svn_r11264.patch.bz2 b/meta/packages/valgrind/valgrind/valgrind_3.5.0-svn_r11264.patch.bz2 deleted file mode 100644 index 66b3698f25..0000000000 --- a/meta/packages/valgrind/valgrind/valgrind_3.5.0-svn_r11264.patch.bz2 +++ /dev/null | |||
Binary files differ | |||
diff --git a/meta/packages/valgrind/valgrind_3.5.0.bb b/meta/packages/valgrind/valgrind_3.5.0.bb deleted file mode 100644 index c1a73f878d..0000000000 --- a/meta/packages/valgrind/valgrind_3.5.0.bb +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | DESCRIPTION = "Valgrind memory debugger" | ||
2 | HOMEPAGE = "http://valgrind.org/" | ||
3 | BUGTRACKER = "http://valgrind.org/support/bug_reports.html" | ||
4 | LICENSE = "GPLv2+ & BSD & FDLv1.2" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=c46082167a314d785d012a244748d803 \ | ||
6 | file://include/pub_tool_basics.h;beginline=1;endline=29;md5=b4765f122b7672cdf9b2e8fd75a33172 \ | ||
7 | file://include/valgrind.h;beginline=1;endline=56;md5=13a71cedba99112334d8596162aec37e \ | ||
8 | file://COPYING.DOCS;md5=8fdeb5abdb235a08e76835f8f3260215" | ||
9 | DEPENDS = "virtual/libx11" | ||
10 | PR = "r3" | ||
11 | |||
12 | SRC_URI = "http://www.valgrind.org/downloads/valgrind-${PV}.tar.bz2 \ | ||
13 | file://valgrind_3.5.0-svn_r11264.patch.bz2 \ | ||
14 | file://fix_issue_caused_by_ccache.patch " | ||
15 | |||
16 | COMPATIBLE_HOST = '(i.86|x86_64).*-linux' | ||
17 | |||
18 | inherit autotools | ||
19 | |||
20 | EXTRA_OECONF = "--enable-tls" | ||
21 | EXTRA_OEMAKE = "-w" | ||
22 | PARALLEL_MAKE = "" | ||
23 | |||
24 | FILES_${PN}-dbg += "${libdir}/${PN}/*/.debug/*" | ||