diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:14:24 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:29:45 +0100 |
commit | 29d6678fd546377459ef75cf54abeef5b969b5cf (patch) | |
tree | 8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/packages/update-modules/update-modules_1.0.bb | |
parent | da49de6885ee1bc424e70bc02f21f6ab920efb55 (diff) | |
download | poky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz |
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things
and is generally overwhelming. This commit splits it into several
logical sections roughly based on function, recipes.txt gives more
information about the classifications used.
The opportunity is also used to switch from "packages" to "recipes"
as used in OpenEmbedded as the term "packages" can be confusing to
people and has many different meanings.
Not all recipes have been classified yet, this is just a first pass
at separating things out. Some packages are moved to meta-extras as
they're no longer actively used or maintained.
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/update-modules/update-modules_1.0.bb')
-rw-r--r-- | meta/packages/update-modules/update-modules_1.0.bb | 30 |
1 files changed, 0 insertions, 30 deletions
diff --git a/meta/packages/update-modules/update-modules_1.0.bb b/meta/packages/update-modules/update-modules_1.0.bb deleted file mode 100644 index 73ee558a08..0000000000 --- a/meta/packages/update-modules/update-modules_1.0.bb +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | DESCRIPTION = "script to manage module configuration files." | ||
2 | SECTION = "base" | ||
3 | LICENSE = "GPLv2" | ||
4 | PACKAGE_ARCH = "all" | ||
5 | RDEPENDS = "${@base_contains("MACHINE_FEATURES", "kernel26", "module-init-tools-depmod","modutils-depmod",d)} " | ||
6 | PR = "r6" | ||
7 | |||
8 | SRC_URI = "file://update-modules" | ||
9 | |||
10 | pkg_postinst() { | ||
11 | if [ "x$D" != "x" ]; then | ||
12 | exit 1 | ||
13 | fi | ||
14 | update-modules | ||
15 | } | ||
16 | |||
17 | do_install() { | ||
18 | install -d ${D}${sbindir} | ||
19 | install ${WORKDIR}/update-modules ${D}${sbindir} | ||
20 | } | ||
21 | |||
22 | # The Unslung distro uses a 2.4 kernel for a machine (the NSLU2) which | ||
23 | # supports both 2.4 and 2.6 kernels. Rather than forcing OE to have | ||
24 | # to deal with that unique legacy corner case, we just nullify the | ||
25 | # RDEPENDS here and handle it in the Unslung image recipe. I know this | ||
26 | # is ugly. Please don't remove it unless you first make the RDEPENDS | ||
27 | # line at the top of this file understand that a machine can be used | ||
28 | # in both a 2.4 kernel distro and a 2.6 kernel distro. Really, it's | ||
29 | # not worth the effort to do that, so just overlook the next line. | ||
30 | RDEPENDS_unslung = "" | ||