diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2009-11-17 21:44:17 +0000 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2009-11-17 21:44:17 +0000 |
commit | d71502666689f3c725850e52b71684ea9bcc1306 (patch) | |
tree | 26dd4d8ba0db5c09f163ed3865d41868f1dfc475 /meta/packages/update-alternatives | |
parent | a00293790bb46812e63f3a2a7e1bce627873eb77 (diff) | |
download | poky-d71502666689f3c725850e52b71684ea9bcc1306.tar.gz |
update-alternatives-dpkg: Convert to BBCLASSEXTEND
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/update-alternatives')
3 files changed, 15 insertions, 25 deletions
diff --git a/meta/packages/update-alternatives/update-alternatives-dpkg-native_1.13.22.bb b/meta/packages/update-alternatives/update-alternatives-dpkg-native_1.13.22.bb deleted file mode 100644 index 0cbdc5ac77..0000000000 --- a/meta/packages/update-alternatives/update-alternatives-dpkg-native_1.13.22.bb +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | require update-alternatives-dpkg.inc | ||
2 | inherit native | ||
3 | |||
4 | PROVIDES += "virtual/update-alternatives-native" | ||
5 | RPROVIDES += "update-alternatives-native" | ||
6 | DEPENDS += "perl-native dpkg-native" | ||
7 | DEFAULT_PREFERENCE = "-1" | ||
8 | |||
9 | do_stage () { | ||
10 | install -d ${sbindir} \ | ||
11 | ${localstatedir}/dpkg/alternatives \ | ||
12 | ${sysconfdir}/alternatives | ||
13 | |||
14 | install -m 0755 scripts/update-alternatives ${sbindir}/update-alternatives | ||
15 | } | ||
diff --git a/meta/packages/update-alternatives/update-alternatives-dpkg.inc b/meta/packages/update-alternatives/update-alternatives-dpkg.inc index 66232139d4..91f9883ff3 100644 --- a/meta/packages/update-alternatives/update-alternatives-dpkg.inc +++ b/meta/packages/update-alternatives/update-alternatives-dpkg.inc | |||
@@ -3,7 +3,7 @@ SECTION = "base" | |||
3 | SRC_URI = "${DEBIAN_MIRROR}/main/d/dpkg/dpkg_${PV}.tar.gz" | 3 | SRC_URI = "${DEBIAN_MIRROR}/main/d/dpkg/dpkg_${PV}.tar.gz" |
4 | S = "${WORKDIR}/dpkg-${PV}" | 4 | S = "${WORKDIR}/dpkg-${PV}" |
5 | PACKAGE_ARCH = "all" | 5 | PACKAGE_ARCH = "all" |
6 | PR = "r1" | 6 | PR = "r2" |
7 | 7 | ||
8 | do_patch () { | 8 | do_patch () { |
9 | cat ${S}/scripts/update-alternatives.pl | \ | 9 | cat ${S}/scripts/update-alternatives.pl | \ |
@@ -18,3 +18,14 @@ do_patch () { | |||
18 | s,^\$altdir=.*$,$altdir="$D${sysconfdir}/alternatives"\;,; | 18 | s,^\$altdir=.*$,$altdir="$D${sysconfdir}/alternatives"\;,; |
19 | p;' > ${S}/scripts/update-alternatives | 19 | p;' > ${S}/scripts/update-alternatives |
20 | } | 20 | } |
21 | |||
22 | NATIVE_INSTALL_WORKS = "1" | ||
23 | do_install () { | ||
24 | install -d ${D}${sbindir} \ | ||
25 | ${D}${localstatedir}/dpkg/alternatives \ | ||
26 | ${D}${sysconfdir}/alternatives | ||
27 | |||
28 | install -m 0755 scripts/update-alternatives ${D}${sbindir}/update-alternatives | ||
29 | } | ||
30 | |||
31 | BBCLASSEXTEND = "native" | ||
diff --git a/meta/packages/update-alternatives/update-alternatives-dpkg_1.13.22.bb b/meta/packages/update-alternatives/update-alternatives-dpkg_1.13.22.bb index ea759fc202..5d38d5d36f 100644 --- a/meta/packages/update-alternatives/update-alternatives-dpkg_1.13.22.bb +++ b/meta/packages/update-alternatives/update-alternatives-dpkg_1.13.22.bb | |||
@@ -2,12 +2,6 @@ require update-alternatives-dpkg.inc | |||
2 | 2 | ||
3 | PROVIDES += "virtual/update-alternatives" | 3 | PROVIDES += "virtual/update-alternatives" |
4 | RPROVIDES_${PN} += "update-alternatives" | 4 | RPROVIDES_${PN} += "update-alternatives" |
5 | RDEPENDS_${PN} += "perl dpkg" | 5 | EXTRA_RDEPENDS = "perl dpkg" |
6 | 6 | EXTRA_RDEPENDS_virtclass-native = "" | |
7 | do_install () { | 7 | RDEPENDS_${PN} += "${EXTRA_RDEPENDS}" |
8 | install -d ${D}${sbindir} \ | ||
9 | ${D}${localstatedir}/dpkg/alternatives \ | ||
10 | ${D}${sysconfdir}/alternatives | ||
11 | |||
12 | install -m 0755 scripts/update-alternatives ${D}${sbindir}/update-alternatives | ||
13 | } | ||