summaryrefslogtreecommitdiffstats
path: root/meta/packages/unzip/unzip_6.0.bb
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-07-05 16:56:36 +0800
committerJoshua Lock <josh@linux.intel.com>2010-07-07 17:12:13 +0100
commit0976252a53292d1724a4234e4196ce6a6f16c5e2 (patch)
treeca66144164a2c6c3065b5e1a4cfe66f333042931 /meta/packages/unzip/unzip_6.0.bb
parent01af31aec216371d62b9ec1c1df35498d1a675f3 (diff)
downloadpoky-0976252a53292d1724a4234e4196ce6a6f16c5e2.tar.gz
unzip: upgrade to version 6.0
from 5.52 (552 in poky) update license changes: - bump PE so that 1:6.0 >> 552 Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/packages/unzip/unzip_6.0.bb')
-rw-r--r--meta/packages/unzip/unzip_6.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/packages/unzip/unzip_6.0.bb b/meta/packages/unzip/unzip_6.0.bb
new file mode 100644
index 0000000000..7b0f9dc721
--- /dev/null
+++ b/meta/packages/unzip/unzip_6.0.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "A (de)compression library for the ZIP format"
2HOMEPAGE = "http://www.info-zip.org"
3SECTION = "console/utils"
4LICENSE = "Info-ZIP"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=94caec5a51ef55ef711ee4e8b1c69e29"
6PE = "1"
7PR = "r0"
8
9SRC_URI = "ftp://ftp.info-zip.org/pub/infozip/src/unzip60.tgz"
10S = "${WORKDIR}/unzip60"
11
12export LD = "${CC}"
13LD_virtclass-native = "${CC}"
14
15do_compile() {
16 oe_runmake -f unix/Makefile generic
17}
18
19do_install() {
20 oe_runmake -f unix/Makefile install prefix=${D}${prefix}
21 install -d ${D}${mandir}
22 mv ${D}${prefix}/man/* ${D}${mandir}
23}
24
25BBCLASSEXTEND = "native"
26NATIVE_INSTALL_WORKS = "1"